79 matches found
CVE-2026-61817
A flaw was found in pgpartman. A user with partmanuser privileges can exploit a SQL injection vulnerability by storing malicious SQL in the partconfig.timedecoder value. This malicious SQL is then executed without proper validation during certain maintenance operations. This can lead to privilege...
CVE-2026-61821
pgpartman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, droppartitionid and droppartitiontime use partconfig.retentionschema as the target for ALTER TABLE SET SCHEMA and accept any nonempty schema name. A role with partmanuser access can select a target...
UBUNTU-CVE-2026-61817
pgpartman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, runmaintenance, showpartitions, showpartitioninfo, undopartition, and partitiondatatime interpolate the writable partconfig.timedncoder text value without identifier quoting into dynamic SQL. A role...
CVE-2026-61822: Improper Check or Handling of Exceptional Conditions
pgpartman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, runmaintenance handles exceptions outside the loop that processes rows from partconfig, so an exception for one partition set immediately terminates the loop and skips every later set. A role with...
PT-2026-95650
Name of the Vulnerable Software and Affected Versions pg partman versions prior to 5.5.0 Description pg partman is a PostgreSQL extension used for managing partitioned tables by time or ID. The functions drop partition id and drop partition time utilize part config.retention schema as the target...
Ubuntu 22.04 LTS / 24.04 LTS / 26.04 LTS / Pro Realtime 22.04 LTS / Pro Realtime 24.04 LTS : PHP vulnerabilities (USN-8743-1)
The remote Ubuntu 22.04 LTS / 24.04 LTS / 26.04 LTS / Pro Realtime 22.04 LTS / Pro Realtime 24.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-8743-1 advisory. It was discovered that PHP incorrectly handled backslash escaping in the...
USN-8743-1: PHP vulnerabilities
It was discovered that PHP incorrectly handled backslash escaping in the PostgreSQL extension. An attacker could use this issue to perform SQL injection attacks. CVE-2026-17543 It was discovered that PHP incorrectly handled certain inputs to the bccomp function. An attacker could use this issue t...
USN-8743-1 php8.1, php8.3, php8.5 vulnerabilities
It was discovered that PHP incorrectly handled backslash escaping in the PostgreSQL extension. An attacker could use this issue to perform SQL injection attacks. CVE-2026-17543 It was discovered that PHP incorrectly handled certain inputs to the bccomp function. An attacker could use this issue t...
SUSE-SU-2026:3510-1 Security update for php7
This update for php7 fixes the following issues: - CVE-2026-7260: circular symbolic links in phar archives can lead to unbounded recursion and cause C stack exhaustion bsc1273077. - CVE-2026-9672: security issues in libgd bsc1273078. - CVE-2026-17543: improper escaping of backslashes in...
Security update for php8
This update for php8 fixes the following issues: Update to version 8.3.33. Security issues fixed: CVE-2026-7260: circular symbolic links in phar archives can lead to unbounded recursion and cause C stack exhaustion bsc1273077. CVE-2026-9672: security issues in libgd bsc1273078. CVE-2026-17543:...
pgaudit v19beta3
pgAudit Open Source PostgreSQL Audit Logging Introduction The PostgreSQL Audit Extension pgAudit provides detailed session and/or object audit logging via the standard PostgreSQL logging facility. The goal of pgAudit is to provide PostgreSQL users with capability to produce audit logs often...
pgaudit v19beta2
pgAudit Open Source PostgreSQL Audit Logging Introduction The PostgreSQL Audit Extension pgAudit provides detailed session and/or object audit logging via the standard PostgreSQL logging facility. The goal of pgAudit is to provide PostgreSQL users with capability to produce audit logs often...
php: ext-pgsql: PHP: SQL injection via improper backslash escaping
A flaw was found in PHP. Improper escaping of backslashes in attacker-provided parameters can lead to a SQL injection vulnerability. A remote attacker could exploit this flaw by crafting malicious input, potentially gaining unauthorized access to sensitive information, manipulating data, or causi...
Debian dsa-6385 : postgresql-17-pgextwlist - security update
The remote Debian 13 host has a package installed that is affected by a vulnerability as referenced in the dsa-6385 advisory. - ------------------------------------------------------------------------- Debian Security Advisory DSA-6385-1 [email protected] https://www.debian.org/security/ Moritz...
Memory-Safety Vulnerability
pgx is vulnerable to a memory-safety vulnerability. The vulnerability is due to improper memory handling in the library, which allows an attacker to exploit memory corruption conditions and potentially cause unexpected behavior, denial of service, or arbitrary code execution...
php: pgsql extension does not check for errors during escaping
A flaw was found in PHP. Missing error checking could result in SQL injection, and missing error handling could lead to crashes due to null pointer dereferences...
php: pgsql extension does not check for errors during escaping
A flaw was found in PHP. Missing error checking could result in SQL injection, and missing error handling could lead to crashes due to null pointer dereferences...
ALSA-2026:1409 Important: php:8.2 security update
PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server. Security Fixes: php: pgsql extension does not check for errors during escaping CVE-2025-1735 php: NULL Pointer Dereference in PHP SOAP Extension via Large XML Namespace Prefix CVE-2025-6491 php: PHP Hostname Nul...