17731 matches found
TencentOS Server 3: postgresql:10 (TSSA-2023:0321)
The version of Tencent Linux installed on the remote TencentOS Server 3 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the TSSA-2023:0321 advisory. Package updates are available for TencentOS Server 3 that fix the following vulnerabilities:...
TencentOS Server 2: postgresql (TSSA-2024:0736)
The version of Tencent Linux installed on the remote TencentOS Server 2 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the TSSA-2024:0736 advisory. Package updates are available for TencentOS Server 2 that fix the following vulnerabilities:...
TencentOS Server 4: postgresql16 (TSSA-2024:0908)
The version of Tencent Linux installed on the remote TencentOS Server 4 host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the TSSA-2024:0908 advisory. Package updates are available for TencentOS Server 4 that fix the following vulnerabilities...
TencentOS Server 4: libpq (TSSA-2025:0367)
The version of Tencent Linux installed on the remote TencentOS Server 4 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the TSSA-2025:0367 advisory. Package updates are available for TencentOS Server 4 that fix the following vulnerabilities:...
TencentOS Server 4: postgresql (TSSA-2024:0558)
The version of Tencent Linux installed on the remote TencentOS Server 4 host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the TSSA-2024:0558 advisory. Package updates are available for TencentOS Server 4 that fix the following vulnerabilities...
TencentOS Server 3: postgresql (TSSA-2023:0121)
The version of Tencent Linux installed on the remote TencentOS Server 3 host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the TSSA-2023:0121 advisory. Package updates are available for TencentOS Server 3 that fix the following vulnerabilities...
PostgreSQL 13.x < 13.23 / 14.x < 14.20 / 15.x < 15.15 / 16.x < 16.11 / 17.x < 17.7 / 18.x < 18.1 Multiple Vulnerabilities
The version of PostgreSQL installed on the remote host is 13 prior to 13.23, 14 prior to 14.20, 15 prior to 15.15, 16 prior to 16.11, 17 prior to 17.7, or 18 prior to 18.1. As such, it is potentially affected by multiple vulnerabilities: - Integer wraparound in multiple PostgreSQL libpq client...
postgresql security update
9.2.24-9.0.7 - Restrict psql meta-commands in plain-text dumps Orabug: 38442031CVE-2025-8714 9.2.24-9.0.5 - Resolves CVE-2025-1094: Improper neutralization of quoting syntax in certain - libpq functions Orabug: 37843176...
Photon OS 5.0: Postgresql15 PHSA-2025-5.0-0683
An update of the postgresql15 package has been released. %NASLMINLEVEL 80900 C Tenable, Inc. The descriptive text and package checks in this plugin were extracted from VMware Security Advisory PHSA-2025-5.0-0683. The text itself is copyright C VMware, Inc. include'compat.inc'; if description...
Photon OS 5.0: Postgresql13 PHSA-2025-5.0-0683
An update of the postgresql13 package has been released. %NASLMINLEVEL 80900 C Tenable, Inc. The descriptive text and package checks in this plugin were extracted from VMware Security Advisory PHSA-2025-5.0-0683. The text itself is copyright C VMware, Inc. include'compat.inc'; if description...
Photon OS 5.0: Postgresql14 PHSA-2025-5.0-0683
An update of the postgresql14 package has been released. %NASLMINLEVEL 80900 C Tenable, Inc. The descriptive text and package checks in this plugin were extracted from VMware Security Advisory PHSA-2025-5.0-0683. The text itself is copyright C VMware, Inc. include'compat.inc'; if description...
MGASA-2025-0302 Updated postgresql15 & postgresql13 packages fix security vulnerabilities
PostgreSQL CREATE STATISTICS does not check for schema CREATE privilege. CVE-2025-12817 PostgreSQL libpq undersizes allocations, via integer wraparound. CVE-2025-12818...
Updated postgresql15 & postgresql13 packages fix security vulnerabilities
PostgreSQL CREATE STATISTICS does not check for schema CREATE privilege. CVE-2025-12817 PostgreSQL libpq undersizes allocations, via integer wraparound. CVE-2025-12818...
Moderate Photon OS Security Update - PHSA-2025-5.0-0683
Updates of 'postgresql15', 'postgresql14', 'postgresql13' packages of Photon OS have been released...
Moderate Photon OS Security Update - PHSA-2025-5.0-91-0683
Updates of 'postgresql13', 'postgresql14', 'postgresql15' packages of Photon OS have been released...
Mageia: Security Advisory (MGASA-2025-0302)
The remote host is missing an update for the SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
GO-2025-4119 AWS Advanced Go Wrapper: Privilege Escalation in Aurora PostgreSQL Instance in github.com/aws/aws-advanced-go-wrapper/awssql
AWS Advanced Go Wrapper: Privilege Escalation in Aurora PostgreSQL Instance in github.com/aws/aws-advanced-go-wrapper/awssql...
CVE-2025-12818
A vulnerability has been identified in PostgreSQL’s libpq client library, where integer wraparound in several allocation-size calculations allows a peer or input provider to cause an undersized buffer and then write out-of-bounds by hundreds of megabytes. This can lead to a client application...
N-able N-Central Authentication Bypass and XXE Scanner
This module scans for vulnerable N-able N-Central instances affected by CVE-2025-9316 Unauthenticated Session Bypass and CVE-2025-11700 XXE. The module attempts to exploit CVE-2025-9316 by sending a sessionHello SOAP request to the ServerMMS endpoint with various appliance IDs to obtain an...
PostgreSQL Multiple Vulnerabilities (Nov 2025) - Linux
PostgreSQL is prone to multiple vulnerabilities. SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only CPE = "cpe:/a:postgresql:postgresql";...