340 matches found
com.github.sbaudoin:sonar-ansible-api (2.0.0), com.github.sbaudoin:sonar-ansible-plugin (2.0.0) +19 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.6)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.6 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - com.github.sbaudoin:sonar-ansible-api 2.0.0 -...
org.sonarsource.sonarqube:sonar-application (6.7-rc1), org.sonarsource.sonarqube:sonar-ce (6.7-rc1) +10 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.7-rc1)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.7-rc1 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - org.sonarsource.sonarqube:sonar-application 6.7-rc1 -...
com.github.sbaudoin:sonar-ansible-api (>=2.1.0, <=2.3.0), com.github.sbaudoin:sonar-ansible-plugin (>=2.1.0, <=2.3.0) +46 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.7)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.7 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - com.github.sbaudoin:sonar-ansible-api =2.1.0, =2.1.0, =1.0.0, =2.6.3, =1.0,...
com.github.spotbugs:sonar-findbugs-plugin (>=3.7.0, <=3.9.4), io.github.sfeir-open-source:sonar-clover-plugin (4.1) +12 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.7.1)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.7.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - com.github.spotbugs:sonar-findbugs-plugin =3.7.0, =3.9.4 -...
org.sonarsource.sonarqube:sonar-application (6.7.3), org.sonarsource.sonarqube:sonar-ce (6.7.3) +10 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.7.3)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.7.3 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - org.sonarsource.sonarqube:sonar-application 6.7.3 -...
com.societegenerale.sonar.openapi:openapi-checks (>=1.2.2, <=1.2.3.41), com.societegenerale.sonar.openapi:openapi-front-end (>=1.2.2, <=1.2.3.41) +20 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.7.4)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.7.4 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - com.societegenerale.sonar.openapi:openapi-checks =1.2.2, =1.2.2, =1.2.2,...
org.sonarsource.owasp:sonar-zap-plugin (>=1.1.0, <=1.1.2), org.sonarsource.sonarqube:sonar-application (6.7.5) +11 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.7.5)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.7.5 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - org.sonarsource.owasp:sonar-zap-plugin =1.1.0, =1.1.2 -...
org.sonarsource.sonarqube:sonar-application (6.7.6), org.sonarsource.sonarqube:sonar-ce (6.7.6) +10 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.7.6)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.7.6 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - org.sonarsource.sonarqube:sonar-application 6.7.6 -...
com.github.sbaudoin:sonar-ansible-api (>=2.4.0, <=2.5.1), com.github.sbaudoin:sonar-ansible-plugin (>=2.4.0, <=2.5.1) +13 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (6.7.7)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version 6.7.7 is affected by a known vulnerability. The following packages have a transitive dependency on org.sonarsource.sonarqube:sonar-plugin-api and may be impacted: - com.github.sbaudoin:sonar-ansible-api =2.4.0, =2.4.0, =0.1.0, =0.1.3 -...
com.github.sbaudoin:sonar-shellcheck-plugin (>=2.3.0, <=2.5.0), org.sonarsource.analyzer-commons:sonar-analyzer-commons (>=1.8.0.295, <=1.10.3.509) +43 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (>=7.0-rc1, <=7.4)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version =7.0-rc1, =2.3.0, =1.8.0.295, =1.10.0.416, =7.4.0.6452, =7.4.0.6452, =7.7.0.7192, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.14.0.18788 and more Source cves:...
com.github.sbaudoin:sonar-shellcheck-plugin (>=2.3.0, <=2.5.0), org.sonarsource.analyzer-commons:sonar-analyzer-commons (>=1.8.0.295, <=1.10.3.509) +43 more potentially affected by CVE-2018-19413 via org.sonarsource.sonarqube:sonar-plugin-api (>=7.0-rc1, <=7.4)
org.sonarsource.sonarqube:sonar-plugin-api MAVEN version =7.0-rc1, =2.3.0, =1.8.0.295, =1.10.0.416, =7.4.0.6452, =7.4.0.6452, =7.7.0.7192, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.6.1.15064, =5.14.0.18788 and more Source cves:...
Apache ShenYu Authorization Bypass
The vulnerability of the Apache ShenYu software lies in the lack of authorization for critical functions. Exploiting this vulnerability allows a malicious actor to bypass established security restrictions and gain access to the /plugin API without being authorized...
GHSA-6V39-P2XQ-G5C3 Missing authentication in ShenYu
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1...
Insecure Access Control
shenyu has insecure access control. The vulnerability exists due to a lack of validation of the user access via the /plugin api allowing an attacker to access the system without authentication...
CVE-2022-23944
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1...
Authentication flaw
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1...
CVE-2022-23944
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1...
CVE-2022-23944: Missing Authorization
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1...
PT-2022-1759
Name of the Vulnerable Software and Affected Versions Apache ShenYu versions 2.4.0 through 2.4.1 Description The issue is related to the lack of authentication for a critical function, allowing a remote attacker to bypass security restrictions and access the "/plugin API" endpoint without...
[SECURITY] Fedora 33 Update: nbdkit-1.24.6-1.fc33
NBD is a protocol for accessing block devices hard disks and disk-like things over the network. nbdkit is a toolkit for creating NBD servers. The key features are: Multithreaded NBD server written in C with good performance. Minimal dependencies for the basic server. Liberal license BSD allows...