113688 matches found
phpstan v1.12.34
PHPStan - PHP Static Analysis Tool PHPStan focuses on finding errors in your code without actually running it. It catches whole classes of bugs even before you write tests for the code. It moves PHP closer to compiled languages in the sense that the correctness of each line of the code can be...
CVE-2026-56722
Dompdf is an HTML to PDF converter for PHP. In versions 3.15 and prior, aAn attacker who controls the HTML input can bypass this restriction by embedding a target file path inside an SVG image delivered through a data: URI, because dompdf processes the SVG twice and the second pass does not...
CVE-2026-55555
Dompdf is an HTML to PDF converter for PHP. Versions 3.15 and prior are vulnerable to a File Existence Oracle attack through the manipulation of the CSS @font-face directive. By providing malicious HTML that references local files via the file:// protocol repeatedly, an attacker can trigger PHP...
php: PHP SOAP extension: Remote Code Execution via use-after-free vulnerability
A flaw was found in PHP's SOAP extension. This vulnerability allows a remote attacker to execute arbitrary code on the affected system. The issue stems from a use-after-free error in the object deduplication mechanism, which can be triggered by sending a specially crafted SOAP request. This allow...
Critical: Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update
An update for Red Hat Hardened Images RPMs is now available. This update includes the following RPMs: php: php-8.5.9-1.hum1 aarch64, x8664 php-bcmath-8.5.9-1.hum1 aarch64, x8664 php-cli-8.5.9-1.hum1 aarch64, x8664 php-common-8.5.9-1.hum1 aarch64, x8664 php-dba-8.5.9-1.hum1 aarch64, x8664...
php: PHP: Denial of Service via circular symbolic links in phar archives
A flaw was found in PHP. When processing a specially crafted PHP Archive phar file containing circular symbolic links, the PHP process can enter an uncontrolled loop. This unbounded recursion exhausts the program's memory stack, causing the PHP application to crash. This vulnerability could allow...
CVE-2026-66745
Artica Proxy before 4.50.000000 Service Pack 7 fixed in hotfix 20260724-02 contains a session fixation vulnerability that allows unauthenticated attackers to hijack administrative sessions by setting a known PHPSESSID on a victim's browser prior to authentication. Attackers can pre-set a controll...
EUVD-2026-49955
Artica Proxy before 4.50.000000 Service Pack 7 fixed in hotfix 20260724-02 contains a session fixation vulnerability that allows unauthenticated attackers to hijack administrative sessions by setting a known PHPSESSID on a victim's browser prior to authentication. Attackers can pre-set a controll...
CVE-2026-59932
CVE-2026-59932 concerns PhpSpreadsheet’s Gnumeric reader. The issue arises when reading attacker-supplied .gnumeric files: if the file starts with gzip magic bytes, the reader decodes the full compressed content via gzdecode() without a decompressed-size cap, which can cause memory exhaustion and...
CVE-2026-59931 PhpSpreadsheet: SSRF bypass via HTTP redirect in WEBSERVICE() domain whitelist
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the WEBSERVICE domain whitelist can be bypassed via an HTTP redirect SSRF...
CVE-2026-59931
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the WEBSERVICE domain whitelist can be bypassed via an HTTP redirect SSRF...
SUSE CVE-2026-43871
Loop with Unreachable Exit Condition 'Infinite Loop' vulnerability in Apache Thrift Python, Go, PHP and Java bindings.This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue...
CVE-2026-45293
WordPress Coding Standards is a set of PHPCodeSniffer rules sniffs that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff active in the WordPress and WordPress-Extra rulesets reconstructed the $ver argument passed to functions such as...
CVE-2026-45293
WordPress Coding Standards (WordPressCS) contains a vulnerability in the WordPress.WP.EnqueuedResourceParameters sniff. From 0.14.1 to 3.4.1, the sniff reconstructed the $ver argument passed to functions like wp_enqueue_script() and ran it through eval() inside is_falsy(), so a crafted argument s...
CVE-2026-49332
A flaw was found in openshift/oauth-proxy. The proxy sets authenticated identity headers using only dash-variant keys X-Forwarded-User but does not strip underscore-variant keys XForwardedUser from incoming requests. WSGI and PHP frameworks normalize both variants to the same variable, allowing a...
WordPress Mailster <=1.5.4 - Cross-Site Scripting Detection
WordPress Mailster 1.5.4 and before contains a cross-site scripting vulnerability in the unsubscribe handler via the mes parameter to view/subscription/unsubscribe2.php. !/usr/bin/env python3 -- coding: utf-8 -- """WordPress Mailster 1.""" from kittysploit import from lib.protocols.http.httpclien...
Joomla! Component Visites 1.1 - MosConfig_absolute_path Remote File Inclusion Detection
A PHP remote file inclusion vulnerability in core/include/myMailer.class.php in the Visites comjoomla-visites component 1.1 RC2 for Joomla! allows remote attackers to execute arbitrary PHP code via a URL in the mosConfigabsolutepath parameter. !/usr/bin/env python3 -- coding: utf-8 -- """A PHP...
HotelDruid 2.3.0 - Cross-Site Scripting Detection
HotelDruid 2.3.0 contains a cross-site scripting vulnerability affecting nsextt, cambia1, mesefine, origine, and anno parameters in creaprezzi.php, tabella3.php, personalizza.php, and visualizzatabelle.php. !/usr/bin/env python3 -- coding: utf-8 -- """HotelDruid 2.""" from kittysploit import from...
Arcade.php - SQL Injection Detection
The arcade.php script is vulnerable to SQL injection. By exploiting this vulnerability, an attacker can manipulate the SQL queries executed by the script, potentially gaining unauthorized access to the database. !/usr/bin/env python3 -- coding: utf-8 -- """The arcade.""" from kittysploit import...
Nette Framework - Remote Code Execution Detection
Nette Framework versions before 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, and 3.0.6 are vulnerable to a code injection attack via specially formed parameters being passed to a URL. Nette is a PHP/Composer MVC Framework. !/usr/bin/env python3 -- coding: utf-8 -- """Nette Framework versions before...