113684 matches found
TikiWiki - jhot.php Upload Detection (CVE-2006-4602)
Detects CVE-2006-4602 by uploading a PHP file via /jhot.php and verifying phpinfo under /img/wiki/. !/usr/bin/env python3 -- coding: utf-8 -- """TikiWiki jhot.php arbitrary PHP upload CVE-2006-4602.""" from kittysploit import from lib.protocols.http.httpclient import Httpclient class ModuleScanne...
w-CMS - userFunctions.php RCE Detection
Detects w-CMS 2.0.1 RCE by writing phpinfo via userFunctions.php and fetching /public/. !/usr/bin/env python3 -- coding: utf-8 -- """w-CMS userFunctions.php arbitrary PHP write RCE.""" from kittysploit import from lib.protocols.http.httpclient import Httpclient class ModuleScanner, Httpclient: in...
PHPUnit - eval-stdin.php RCE Detection (CVE-2017-9841)
Detects CVE-2017-9841 by POSTing PHP to vendor phpunit Util/PHP/eval-stdin.php and checking for reflected echo output. !/usr/bin/env python3 -- coding: utf-8 -- """PHPUnit eval-stdin.php unauthenticated RCE CVE-2017-9841.""" import base64 from kittysploit import from lib.protocols.http.httpclient...
osCommerce - file_manager.php Upload RCE (CVE-2009-20006)
Exploits CVE-2009-20006 by writing PHP via admin/filemanager.php/login.php?action=save. !/usr/bin/env python3 -- coding: utf-8 -- """osCommerce filemanager.php upload RCE CVE-2009-20006.""" from random import randint from kittysploit import from lib.protocols.http.httpclient import Httpclient fro...
CVE-2026-16985 Squeeze < 1.7.12 - Author+ Arbitrary File Upload
The Squeeze WordPress plugin before 1.7.12 does not validate the file type or extension of the per-size image data written by one of its attachment-update actions, allowing users with the uploadfiles capability Author and above to write an executable PHP file into the uploads directory and achiev...
EUVD-2026-55014
The Squeeze WordPress plugin before 1.7.12 does not validate the file type or extension of the per-size image data written by one of its attachment-update actions, allowing users with the uploadfiles capability Author and above to write an executable PHP file into the uploads directory and achiev...
CVE-2026-16985
The Squeeze WordPress plugin versions prior to 1.7.12 is vulnerable to an arbitrary file upload flaw. The issue stems from a failure to validate the file type or extension of per-size image data during certain attachment-update actions. This allows users with the upload_files capability (Author l...
PT-2026-69337
Name of the Vulnerable Software and Affected Versions Eventin WordPress plugin versions prior to 4.1.20 Description Insufficient validation of a template path setting allows users with editor-level access and above to include and execute arbitrary local PHP files. This is a Local File Inclusion L...
PT-2026-80573
Updated php 8.5 packages fix some security vulnerabilities. For details see the references...
WavePlayer Plugin Arbitrary File Upload Code Execution
The vulnerability of the waveplayercreatelocalcopy function in the WordPress content management system’s plugin, WavePlayer, allows for unlimited loading of malicious files. Exploiting this vulnerability enables a remote attacker to load arbitrary files and execute arbitrary code by loading a...
Alibaba Cloud Linux 3 : 0247: php:7.4 (ALINUX3-SA-2026:0247)
The remote Alibaba Cloud Linux 3 host has packages installed that are affected by a vulnerability as referenced in the ALINUX3-SA-2026:0247 advisory. Package updates are available for Alibaba Cloud Linux 3 that fix the following vulnerabilities: CVE-2026-14355: In PHP versions 8.2. before 8.2.32,...
PT-2026-69476
Name of the Vulnerable Software and Affected Versions dulldusk/phpfm versions prior to 1.8.1 Description An unrestricted file upload issue allows an unauthenticated remote attacker to execute arbitrary PHP code on the server. The application is configured by default with an empty upload extension...
PT-2026-69854
Name of the Vulnerable Software and Affected Versions SPIP versions prior to 4.4.18 Description In installations using SQLite, the navigation menu endpoint improperly handles array-typed user input. This flaw bypasses input sanitization, allowing the input to break out of an internal quoted strin...
CVE-2026-69118: Improper Neutralization of Special Elements Used in a Template Engine
Cachet through 2.4.1 contains a server-side template injection vulnerability in incident template rendering that allows authenticated users to execute arbitrary PHP code. Attackers can create malicious incident templates with Blade directives or Twig filters that execute system commands when...
WPBookit Image Upload Code Execution
The vulnerability of the imageUploadHandle function in the WPBookit plugin of the WordPress content management system involves unlimited uploading of dangerous types of files. Exploiting this vulnerability could allow a remote attacker to execute arbitrary code...
Sneeit Framework Code Execution
The vulnerability of the sneeitarticlespaginationcallback function in the Sneeit Framework, a content management system for WordPress, is related to improper handling of code generation. Exploiting this vulnerability could allow an attacker to execute arbitrary code...
CVE-2026-72592: Unrestricted Upload of File with Dangerous Type
An unrestricted file upload vulnerability in dulldusk/phpfm through 1.8.0 allows an unauthenticated remote attacker to execute arbitrary PHP code on the server. The application ships with an empty upload extension filter = array and no authentication enabled by default authpass is empty string,...
PT-2026-80572
The updated php 8.4 packages fix some security vulnerabilities. See the references for more information...
PT-2026-69355
Name of the Vulnerable Software and Affected Versions Squeeze WordPress plugin versions prior to 1.7.12 Description Insufficient validation of file types or extensions during attachment-update actions allows users with the upload files capability, such as those with Author privileges and above, t...
PT-2026-69941
Name of the Vulnerable Software and Affected Versions Cachet versions prior to 2.4.2 Description An issue exists in incident template rendering that allows authenticated users to perform server-side template injection. By creating malicious incident templates using Blade directives or Twig filter...