Lucene search
+L

48 matches found

RedhatCVE
RedhatCVE
•added 2025/05/23 8:57 a.m.•20 views

CVE-2024-47049

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 used with PHP Composer does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files...

8.2CVSS5.9AI score0.00636EPSS
SaveExploits0References1
Github Security Blog
Github Security Blog
•added 2024/09/17 3:31 p.m.•48 views

czim/file-handling vulnerable to SSRF and directory traversal

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 used with PHP Composer does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files...

8.2CVSS5.9AI score0.00636EPSS
SaveExploits0References5Affected Software1
osv_ghsa
osv_ghsa
•added 2024/09/17 3:31 p.m.•31 views

GHSA-6RGH-R6J3-3223 czim/file-handling vulnerable to SSRF and directory traversal

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 used with PHP Composer does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files...

8.2CVSS5.9AI score0.00636EPSS
SaveExploits0References5
NVD
NVD
•added 2024/09/17 2:15 p.m.•35 views

CVE-2024-47049

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 used with PHP Composer does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files...

8.2CVSS0.00636EPSS
SaveExploits0References1
Cvelist
Cvelist
•added 2024/09/17 12:00 a.m.•32 views

CVE-2024-47049

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 used with PHP Composer does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files...

0.00636EPSS
SaveExploits0References1
CVE
CVE
•added 2024/09/17 12:00 a.m.•94 views

CVE-2024-47049

CVE-2024-47049 affects czim/file-handling <1.5.0 and 2.x

8.2CVSS5.9AI score0.00636EPSS
SaveExploits0References1Affected Software1
Vulnrichment
Vulnrichment
•added 2024/09/17 12:00 a.m.•16 views

CVE-2024-47049

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 used with PHP Composer does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files...

5.9AI score0.00636EPSS
SaveExploits0References1
osv_cve
osv_cve
•added 2024/09/17 12:00 a.m.•31 views

CVE-2024-47049

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 used with PHP Composer does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files...

8.2CVSS6.3AI score
SaveExploits0References3
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2024/09/17 12:00 a.m.•9 views

CVE-2024-47049: Improper Limitation of a Pathname to a Restricted Directory

The czim/file-handling package before 1.5.0 and 2.x before 2.3.0 used with PHP Composer does not properly validate URLs within makeFromUrl and makeFromAny, leading to SSRF, and to directory traversal for the reading of local files...

8.2CVSS5.9AI score0.00636EPSS
SaveExploits0References1
Redos
Redos
•added 2024/06/26 12:00 a.m.•48 views

ROS-20240626-10

A vulnerability in the getUnpushedChanges function of the dependency manager for PHP Composer is related to the use of the status and reinstall commands. status, reinstall and remove commands. Exploitation of the vulnerability could allow an attacker, acting remotely, to execute arbitrary command...

8.8CVSS7.9AI score0.03282EPSS
SaveExploits0
osv_opensuse
osv_opensuse
•added 2024/06/15 12:00 a.m.•21 views

OPENSUSE-SU-2024:14040-1 php-composer2-2.7.7-1.1 on GA media

These are all security issues fixed in the php-composer2-2.7.7-1.1 package on the GA media of openSUSE Tumbleweed...

8.8CVSS7.7AI score0.03282EPSS
SaveExploits0References2
Redos
Redos
•added 2024/03/29 12:00 a.m.•31 views

ROS-20240329-03

Vulnerability in InstalledVersions.php and install.php scripts of dependency manager for PHP Composer is related to the inclusion of functions from an invalid controlled scope. with the inclusion of functions from an invalid controlled scope. Exploitation of the vulnerability could allow an...

8.8CVSS8AI score0.00279EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2024/02/29 12:00 a.m.•25 views

Enumerate PHP Composer Packages (Linux / Unix)

Binary data phpcomposerenumnix.nbin...

7.3AI score
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2024/02/29 12:00 a.m.•18 views

Enumerate PHP Composer Packages (Windows)

Binary data phpcomposerenumwin.nbin...

7.3AI score
SaveExploits0
osv_suse
osv_suse
•added 2024/02/22 2:08 p.m.•7 views

SUSE-SU-2024:0592-1 Security update for php-composer2

This update for php-composer2 fixes the following issues: - CVE-2024-24821: Fixed potential arbitrary code execution when Composer is invoked within a directory with tampered files bsc1219757...

8.8CVSS7.8AI score0.00279EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2023/03/29 12:00 a.m.•43 views

Ubuntu 16.04 ESM / 18.04 LTS : Nette vulnerability (USN-5983-1)

The remote Ubuntu 16.04 ESM / 18.04 LTS host has a package installed that is affected by a vulnerability as referenced in the USN-5983-1 advisory. Cyku Hong discovered that Nette was not properly handling and validating data used for code generation. A remote attacker could possibly use this issu...

9.8CVSS8.8AI score0.34424EPSS
SaveExploits5References2
osv_suse
osv_suse
•added 2022/09/05 9:23 a.m.•8 views

SUSE-SU-2022:3020-1 Security update for php-composer2

This update for php-composer2 fixes the following issues: - CVE-2022-24828: Fixed a code injection issue that affected integrators using specific APIs to read untrusted input files bsc1198494...

8.8CVSS7.7AI score0.01886EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2022/05/11 12:00 a.m.•45 views

openSUSE 15 Security Update : php-composer (openSUSE-SU-2022:0132-1)

The remote SUSE Linux SUSE15 host has a package installed that is affected by multiple vulnerabilities as referenced in the openSUSE-SU-2022:0132-1 advisory. - Composer is an open source dependency manager for the PHP language. In affected versions windows users running Composer to install...

9.8CVSS7.5AI score0.02825EPSS
SaveExploits0References6
osv_opensuse
osv_opensuse
•added 2022/05/10 9:13 a.m.•11 views

OPENSUSE-SU-2022:0132-1 Security update for php-composer

This update for php-composer fixes the following issues: php-composer was updated to version 1.10.26: Security: Fixed command injection vulnerability in HgDriver/GitDriver: CVE-2022-24828 boo1198494 Update to version 1.10.25 Fix regression with PHP 8.1.0 and 8.1.1 Update to version 1.10.24 Fixed...

9.8CVSS7.7AI score0.02825EPSS
SaveExploits0References4
OPENSUSE Linux
OPENSUSE Linux
•added 2022/05/10 12:00 a.m.•54 views

Security update for php-composer (important)

openSUSE Security Update: Security update for php-composer Announcement ID: openSUSE-SU-2022:0132-1 Rating: important References: 1198494 Cross-References: CVE-2021-41116 CVE-2022-24828 CVSS scores: CVE-2021-41116 NVD : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVE-2022-24828 NVD : 8.8...

7CVSS7.7AI score0.02825EPSS
SaveExploits0References1
Rows per page
Query Builder