7 matches found
ruby:4.0 security update
ruby 4.0.3-33 - Fix Net::IMAP ResponseReader quadratic complexity vulnerability. CVE-2026-42245 Resolves: RHEL-181690 - Fix Net::IMAP STARTTLS stripping vulnerability. CVE-2026-42246 Resolves: RHEL-181771 - Fix Net::IMAP command injection vulnerability via unvalidated Symbol arguments...
ruby:3.3 security update
ruby 3.3.10-6 - Fix arbitrary code execution via deserialization bypass in ERB. CVE-2026-41316 Resolves: RHEL-171247 rubygem-abrt 0.4.0-1 - Update to abrt 0.4.0. Resolves: rhbz1842476 rubygem-mysql2 0.5.5-1 - Upgrade to mysql2 0.5.5. Related: RHEL-17090 rubygem-pg 1.5.4-1 - Upgrade to pg 1.5.4...
AZL-66327 CVE-2025-8715 affecting package postgresql for versions less than 14.19-1
Improper neutralization of newlines in pgdump in PostgreSQL allows a user of the origin server to inject arbitrary code for restore-time execution as the client operating system account running psql to restore the dump, via psql meta-commands inside a purpose-crafted object name. The same attacks...
ruby:3.1 security update
ruby 3.1.5-145 - Fix REXML ReDoS vulnerability. CVE-2024-49761 Resolves: RHEL-68530 3.1.5-144 - Upgrade to Ruby 3.1.5. Resolves: RHEL-33978 - Fix buffer overread vulnerability in StringIO. Resolves: RHEL-34129 - Fix RCE vulnerability with .rdocoptions in RDoc. Resolves: RHEL-34121 - Fix arbitrary...
UBUNTU-CVE-2018-16850
postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pgupgrade and pgdump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges...
PT-2018-2615
Name of the Vulnerable Software and Affected Versions PostgreSQL versions prior to 11.1 PostgreSQL versions prior to 10.6 Description The issue is related to SQL injection in pg upgrade and pg dump via CREATE TRIGGER ... REFERENCING. An attacker can cause arbitrary SQL statements to run with...
PT-2018-3137
Name of the Vulnerable Software and Affected Versions PostgreSQL versions 9.3.x through 9.3.20 PostgreSQL versions 9.4.x through 9.4.15 PostgreSQL versions 9.5.x through 9.5.10 PostgreSQL versions 9.6.x through 9.6.6 PostgreSQL versions 10.x through 10.1 Description The issue is related to the...