88 matches found
EulerOS Virtualization 2.10.0 : perl-IO-Compress (EulerOS-SA-2026-3881)
According to the versions of the perl-IO-Compress packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled...
EulerOS Virtualization 2.10.1 : perl-IO-Compress (EulerOS-SA-2026-3847)
According to the versions of the perl-IO-Compress packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled...
EulerOS Virtualization 2.12.1 : perl-IO-Compress (EulerOS-SA-2026-3607)
According to the versions of the perl-IO-Compress package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled outp...
EulerOS Virtualization 2.12.0 : perl-IO-Compress (EulerOS-SA-2026-3661)
According to the versions of the perl-IO-Compress package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled outp...
EulerOS 2.0 SP10 : perl-IO-Compress (EulerOS-SA-2026-3759)
According to the versions of the perl-IO-Compress packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob...
EulerOS 2.0 SP10 : perl-IO-Compress (EulerOS-SA-2026-3712)
According to the versions of the perl-IO-Compress packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob...
EulerOS 2.0 SP15 : perl-IO-Compress (EulerOS-SA-2026-3814)
According to the versions of the perl-IO-Compress packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob.x000D...
EulerOS 2.0 SP15 : perl-IO-Compress (EulerOS-SA-2026-3789)
According to the versions of the perl-IO-Compress packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob.x000D...
EulerOS 2.0 SP12 : perl-IO-Compress (EulerOS-SA-2026-3370)
According to the versions of the perl-IO-Compress packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob...
RHEL 8 : perl:5.32 (RHSA-2026:50262)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2026:50262 advisory. Perl is a high-level programming language that is commonly used for system administration utilities and web programming. Security Fixes:...
K000162691: Perl IO::Compress vulnerability CVE-2026-48962
Security Advisory Description IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob. parseOutputGlob wraps the caller-supplied output glob string in double quotes and stores it in the parser state; getFiles then runs the...
perl-IO-Compress security update
An update is available for perl-IO-Compress. This update affects Rocky Linux 8. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list This distribution provides a Perl interface to allow reading and...
RockyLinux 8 : perl-IO-Compress (RLSA-2026:30858)
The remote RockyLinux 8 host has a package installed that is affected by a vulnerability as referenced in the RLSA-2026:30858 advisory. perl-IO-Compress: perl-IO-Compress: Arbitrary code execution via attacker-controlled output glob CVE-2026-48962 Tenable has extracted the preceding description...
Oracle Linux 7 : perl-IO-Compress (ELSA-2026-30843)
The remote Oracle Linux 7 host has a package installed that is affected by a vulnerability as referenced in the ELSA-2026-30843 advisory. 2.061-2.0.1 - Fix for CVE-2026-48962 Orabug: 39658885 Tenable has extracted the preceding description block directly from the Oracle Linux security advisory...
perl-IO-Compress security update
2.061-2.0.1 - Fix for CVE-2026-48962 Orabug: 39658885...
Oracle Linux 10 : perl-IO-Compress (ELSA-2026-30860)
The remote Oracle Linux 10 host has a package installed that is affected by a vulnerability as referenced in the ELSA-2026-30860 advisory. - Fix CVE-2026-48962: remove use of eval in File::GlobMapper Tenable has extracted the preceding description block directly from the Oracle Linux security...
Alibaba Cloud Linux 3 : 0188: perl-IO-Compress (ALINUX3-SA-2026:0188)
The remote Alibaba Cloud Linux 3 host has packages installed that are affected by a vulnerability as referenced in the ALINUX3-SA-2026:0188 advisory. Package updates are available for Alibaba Cloud Linux 3 that fix the following vulnerabilities: CVE-2026-48962: IO::Compress versions before 2.220...
[SECURITY] Fedora 43 Update: perl-IO-Compress-2.221-1.fc43
This distribution provides a Perl interface to allow reading and writing of compressed data created with the zlib and bzip2 libraries. IO-Compress supports reading and writing of bzip2, RFC 1950, RFC 1951, RFC 1952 i.e. gzip and zip files/buffers. The following modules used to be distributed...
Fedora 43 : perl-Compress-Raw-Bzip2 / perl-IO-Compress (2026-fb1f15ce04)
The remote Fedora 43 host has packages installed that are affected by multiple vulnerabilities as referenced in the FEDORA-2026-fb1f15ce04 advisory. perl-Compress-Taw-Bzip2 - Updated to 2.218 perl-IO-Compress - Updated to 2.221 - Fix CVE-2025-15649, CVE-2026-48959, CVE-2026-48961, CVE-2026-48962...
TencentOS Server 3: perl-IO-Compress (TSSA-2026:0571)
The version of Tencent Linux installed on the remote TencentOS Server 3 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the TSSA-2026:0571 advisory. Package updates are available for TencentOS Server 3 that fix the following vulnerabilities:...