104 matches found
PT-2024-15766
Name of the Vulnerable Software and Affected Versions The Stripe Payment Plugin for WooCommerce plugin for WordPress versions up to, and including, 3.7.9 Description The issue is related to SQL Injection via the id parameter due to insufficient escaping on the user-supplied parameter and lack of...
CVE-2023-5132
The Soisy Pagamento Rateale plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the parseRemoteRequest function in versions up to, and including, 6.0.1. This makes it possible for unauthenticated attackers with knowledge of an existing WooCommerc...
Authentication flaw
The Stripe Payment Plugin for WooCommerce plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.7.7. This is due to insufficient verification on the user being supplied during a Stripe checkout through the plugin. This allows unauthenticated attackers to...
WordPress plugin Stripe Payment Plugin for WooCommerce has security vulnerabilities
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. WordPress is a blogging platform developed in the PHP language that supports personal blogs on PHP and MySQL servers.WordPress plugin is an application...
CVE-2023-3162: Authentication Bypass Using an Alternate Path or Channel
The Stripe Payment Plugin for WooCommerce plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.7.7. This is due to insufficient verification on the user being supplied during a Stripe checkout through the plugin. This allows unauthenticated attackers to...
PT-2023-27432
Name of the Vulnerable Software and Affected Versions The Stripe Payment Plugin for WooCommerce plugin for WordPress versions up to, and including, 3.7.9 Description The issue is related to unauthorized modification of data due to a missing capability check on the eh callback handler function. Th...
CVE-2023-4040: Undefined Security Weakness
The Stripe Payment Plugin for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ehcallbackhandler function in versions up to, and including, 3.7.9. This makes it possible for unauthenticated attackers to modify the order...
PT-2023-23402 · Woocommerce · Stripe Payment Plugin For Woocommerce
Name of the Vulnerable Software and Affected Versions: Stripe Payment Plugin for WooCommerce versions up to, and including, 3.7.7 Description: The issue is related to authentication bypass due to insufficient verification of the user being supplied during a Stripe checkout through the plugin. Thi...
WordPress WordPress Stripe Donation and Payment Plugin Plugin < 3.2.1 is vulnerable to Cross Site Scripting (XSS)
Software WordPress Stripe Donation and Payment Plugin Type Plugin Vulnerable versions 3.2.1 Fixed in 3.2.1 OWASP Top 10 A3: Injection Classification Cross Site Scripting XSS CVE CVE-2023-33999 Patch priority Medium CVSS severity Medium 7.1 Developer Claim ownership PSID 3e61589953b1 Credits Rafie...
WordPress Payment Page Plugin < 1.2.9 is vulnerable to Cross Site Scripting (XSS)
Software Payment Page Type Plugin Vulnerable versions 1.2.9 Fixed in 1.2.9 OWASP Top 10 A3: Injection Classification Cross Site Scripting XSS CVE CVE-2023-33999 Patch priority Medium CVSS severity Medium 7.1 Developer Claim ownership PSID e96ad7e511b5 Credits Rafie Muhammad Patchstack Required...
CVE-2022-4307
The پلاگین پرداخت دلخواه WordPress plugin before 2.9.3 does not sanitise and escape some parameters, allowing unauthenticated attackers to send a request with XSS payloads, which will be triggered when a high privilege users such as admin visits a page from the plugin...
CVE-2020-26007
An arbitrary file upload vulnerability in the upload payment plugin of ShopXO v1.9.0 allows attackers to execute arbitrary code via uploading a crafted PHP file...
CVE-2020-26007
An arbitrary file upload vulnerability in the upload payment plugin of ShopXO v1.9.0 allows attackers to execute arbitrary code via uploading a crafted PHP file...
Design/Logic Flaw
An arbitrary file upload vulnerability in the upload payment plugin of ShopXO v1.9.0 allows attackers to execute arbitrary code via uploading a crafted PHP file...
CVE-2020-26007
An arbitrary file upload vulnerability in the upload payment plugin of ShopXO v1.9.0 allows attackers to execute arbitrary code via uploading a crafted PHP file...
CVE-2020-26007
An arbitrary file upload vulnerability in the upload payment plugin of ShopXO v1.9.0 allows attackers to execute arbitrary code via uploading a crafted PHP file...
CVE-2020-26007: Unrestricted Upload of File with Dangerous Type
An arbitrary file upload vulnerability in the upload payment plugin of ShopXO v1.9.0 allows attackers to execute arbitrary code via uploading a crafted PHP file...
ShopXO code issues and vulnerabilities
ShopXO is an open source enterprise-level open source e-commerce system. A security vulnerability exists in ShopXO v1.9.0, which originates from the upload of arbitrary files in the Upload Payment plugin. An attacker can execute arbitrary code by uploading a crafted PHP file...
PT-2022-8723
Name of the Vulnerable Software and Affected Versions ShopXO version 1.9.0 Description The issue allows attackers to execute arbitrary code via uploading a crafted PHP file, exploiting an arbitrary file upload vulnerability in the upload payment plugin. Recommendations For ShopXO version 1.9.0,...