7 matches found
EUVD-2026-35479
Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATHCHALLENGE frames. Impact summary: A malicious remote peer can cause an unbounded memory allocation which can lead to an abnormal termination of the application acting as a QU...
CVE-2026-34183 Unbounded Memory Growth in the QUIC PATH_CHALLENGE Handler
Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATHCHALLENGE frames. Impact summary: A malicious remote peer can cause an unbounded memory allocation which can lead to an abnormal termination of the application acting as a QU...
CVE-2026-34183
The OpenSSL library is vulnerable to a Denial of Service (DoS) attack due to unbounded memory growth in the QUIC stack. A remote peer can exhaust heap memory by flooding the local QUIC stack with PATH_CHALLENGE frames; the stack allocates a PATH_RESPONSE frame for each request but only frees it u...
CVE-2026-34183
Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATHCHALLENGE frames. Impact summary: A malicious remote peer can cause an unbounded memory allocation which can lead to an abnormal termination of the application acting as a QU...
AZL-33285 CVE-2023-49295 affecting package coredns for versions less than 1.11.1-5
quic-go is an implementation of the QUIC protocol RFC 9000, RFC 9001, RFC 9002 in Go. An attacker can cause its peer to run out of memory sending a large number of PATHCHALLENGE frames. The receiver is supposed to respond to each PATHCHALLENGE frame with a PATHRESPONSE frame. The attacker can...
UBUNTU-CVE-2023-49295
quic-go is an implementation of the QUIC protocol RFC 9000, RFC 9001, RFC 9002 in Go. An attacker can cause its peer to run out of memory sending a large number of PATHCHALLENGE frames. The receiver is supposed to respond to each PATHCHALLENGE frame with a PATHRESPONSE frame. The attacker can...
Quic-go Resource Management Error Vulnerability
quic-go is an implementation of the QUIC protocol, RFC 9000, in Go by Lucas Clemente, a private developer. A resource management error vulnerability exists in quic-go, which stems from a potential denial of service when subjected to too many PATHCHALLENGE frames...