216 matches found
PT-2019-7543
Name of the Vulnerable Software and Affected Versions Pallets Jinja versions prior to 2.8.1 Description The issue allows a sandbox escape through the str.format function. Recommendations For versions prior to 2.8.1, update to version 2.8.1 or later to resolve the issue...
Code injection
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
CVE-2019-10906
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
PYSEC-2019-217
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
DEBIAN-CVE-2019-10906
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
PYSEC-2019-217
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
CVE-2019-10906
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
CVE-2019-10906
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
CVE-2019-10906
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
CVE-2019-10906
CVE-2019-10906 affects Pallets Jinja2 before 2.10.1. The vulnerability arises from str.format_map allowing a sandbox escape, enabling potentially untrusted template code to escape sandbox restrictions. The issue is blocked to Jinja2’s sandboxed evaluation and affects environments using Pallets Ji...
CVE-2019-10906
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
CVE-2019-10906
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
CVE-2019-10906: Undefined Security Weakness
In Pallets Jinja before 2.10.1, str.formatmap allows a sandbox escape...
PT-2019-12084
Name of the Vulnerable Software and Affected Versions Pallets Jinja versions prior to 2.10.1 Description The issue allows a sandbox escape through the str.format map method. This method could be used to bypass the sandbox, which is designed to restrict the evaluation of untrusted, user-provided...
Sandbox Escape
In Pallets Jinja, str.formatmap allows a sandbox escape...
CVE-2018-1000656
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. Th...
Flask is vulnerable to Denial of Service via incorrect encoding of JSON data
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. Th...
CVE-2018-1000656
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. Th...
CVE-2018-1000656
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. Th...
Input validation
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. Th...