27982 matches found
CVE-2026-81697: Untrusted Search Path
opensslencrypt pip package openssl-encrypt versions = 1.4.8 contain a CWD-relative configuration file resolution flaw in cryptsettings.py, where CONFIGFILE originally the absolute per-user path /.cryptsettings.json is reassigned at line 84 to the bare relative name 'cryptsettings.json'. As a...
PT-2026-82609
Name of the Vulnerable Software and Affected Versions openssl encrypt versions prior to 1.4.9 Description The enroll trust key function uses suffix-tolerant fingerprint matching when binding a plugin-signing trust anchor. This allows an operator to confirm a short, forgeable GPG key ID, potential...
PT-2026-85188
openssl encrypt versions before 1.4.9 fail to sanitize recovery-slot metadata in the desktop GUI, allowing attackers to inject control characters and line separators into the irreversible-removal confirmation dialog. Attackers can craft encrypted files with malicious slot identifiers containing...
PT-2026-85192
openssl encrypt versions before 1.4.9 fail to validate server URLs in login and register with email functions, accepting unencrypted http:// URLs and unconfigured hosts. Attackers on the network path can intercept cleartext credentials including client id, passwords, and JWTs to achieve full...
PT-2026-82602
Name of the Vulnerable Software and Affected Versions openssl encrypt versions prior to 1.4.9 Description The software uses a denylist to identify trusted built-in plugins, which allows unsigned plugins located in top-level plugins/ directories and unknown subdirectories to bypass signature...
PT-2026-82603
Name of the Vulnerable Software and Affected Versions openssl encrypt versions prior to 1.4.9 Description The software fails to re-derive and validate fingerprints when loading identities from the identity.json file. This allows attackers to substitute legitimate public keys in identity stores wi...
SUSE SLES15 Security Update : go1.26-openssl (SUSE-SU-2026:3799-1)
The remote SUSE Linux SLES15 / SLESSAP15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2026:3799-1 advisory. Update to version 1.26.7 cut from the go1.25-fips-release at the revision tagged go1.26.7-1-openssl-fips. Security issues fixed: -...
RockyLinux 8 : mingw-openssl (RLSA-2026:60329)
The remote RockyLinux 8 host has packages installed that are affected by a vulnerability as referenced in the RLSA-2026:60329 advisory. openssl: SSLselectnextproto buffer overread CVE-2024-5535 Tenable has extracted the preceding description block directly from the RockyLinux security advisory...
mingw-openssl security update
Mon Aug 17 2026 Uri Lublin - Fix CVE-2024-5535 SSLselectnextproto buffer overread Resolves: RHEL-45673 1.0.2k-3 - Rebuilt Related: rhbz1846152...
PT-2026-85194
openssl encrypt pip: openssl-encrypt versions = 1.4.8 use suffix-tolerant fingerprint matching in enroll trust key when binding a plugin-signing trust anchor. An operator who confirms a short forgeable, 32-bit GPG key id could unknowingly enroll an attacker's colliding key as a trusted anchor,...
PT-2026-85189
openssl encrypt 1.4.x before 1.4.9 contains an optional D-Bus crypto service whose org.freedesktop.DBus.Properties.Set method performs neither a polkit authorization check nor value validation. Any local user on the system bus can call Set without authorization and set MaxConcurrentOperations to...
PT-2026-82608
Name of the Vulnerable Software and Affected Versions openssl encrypt versions prior to 1.4.9 Description The software fails to sanitize the email field of imported identity documents. This allows attackers to inject ANSI escape sequences—special codes used to control terminal formatting—to forge...
PT-2026-82600
Name of the Vulnerable Software and Affected Versions openssl encrypt versions prior to 1.4.9 Description Insufficient validation of key derivation function KDF costs in crafted files allows attackers to trigger unbounded memory and CPU exhaustion during pre-authentication processing. By supplyin...
PT-2026-82588
Name of the Vulnerable Software and Affected Versions openssl encrypt versions prior to 1.4.9 Description The software fails to enforce a time ceiling on key derivation function KDF iteration counts specified in file metadata. A KDF is a cryptographic algorithm that derives one or more secret key...
PT-2026-82583
Name of the Vulnerable Software and Affected Versions openssl encrypt versions prior to 1.4.9 Description The desktop GUI writes decrypted plaintext using world-readable default permissions. This allows unprivileged local users on multi-user systems to read the decrypted output files...
PT-2026-82596
openssl encrypt versions before 1.4.9 fail to escape attacker-controlled key id values printed to stderr during decrypt auto-detection. Attackers can craft encrypted files with malicious key id containing escape sequences to repaint terminal output and forge authenticity verification blocks...
PT-2026-82601
Name of the Vulnerable Software and Affected Versions openssl encrypt versions prior to 1.4.9 Description A signature verification issue exists in the gpg runner.verify detached function. The system accepts revoked and expired keys because it only checks the VALIDSIG status and fails to inspect...
PT-2026-82611
openssl encrypt pip: openssl-encrypt versions before 1.4.9 contain a path traversal flaw in PluginSandbox. is safe path, which authorized file access using a bare string-prefix match. A sandboxed plugin without the READ FILES permission could read or write another plugin's directory that merely...
CVE-2026-81715: Insertion of Sensitive Information into Log File
opensslencrypt pip package openssl-encrypt versions = 1.4.8 do not redact the keyserver bearer token passed as the positional argument to 'keyserver set-token' in the --debug argv dump, because sanitizeargvfordebug fails to sanitize it. As a result the token is printed in cleartext to stderr unde...
CVE-2026-81694: Improper Output Neutralization for Logs
openssl-encrypt pip package, versions = 1.4.8 fails to sanitize filenames read from untrusted drive data outside the AES-GCM authenticated manifest before printing them in the verify-usb command's output. An attacker can plant filenames containing terminal cursor-movement and erase-line control...