992123 matches found
Open WebUI BOLA: `search_knowledge_files` Allows Unauthorized Knowledge Base File Enumeration
SummaryOpen WebUI has a Broken Object Level Authorization BOLA vulnerability in the builtin searchknowledgefiles tool.When native function calling is enabled and the selected model has no attached knowledge bases, an authenticated user can call searchknowledgefiles with an arbitrary knowledgeid...
Open WebUI: Sibling-Prefix Path Traversal via /cache/{path}
SummaryA path traversal vulnerability exists in open-webui's cache file serving endpoint that allows any authenticated user to read files from sibling directories outside the intended cache directory, by exploiting an incomplete startswith containment check that lacks a trailing path separator.Th...
openwebui-token-tracking (0.1.7) potentially affected by CVE-2026-54006 via open-webui (0.6.0)
open-webui PYPI version 0.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on open-webui and may be impacted: - openwebui-token-tracking 0.1.7 Source cves: CVE-2026-54006 Source advisory: OSV:PYSEC-2026-2722...
iluvatar (0.0.1), open-autotools (0.0.1) +3 more potentially affected by CVE-2026-50574 via yt-dlp (2024.8.6)
yt-dlp PYPI version 2024.8.6 is affected by a known vulnerability. The following packages have a transitive dependency on yt-dlp and may be impacted: - iluvatar 0.0.1 - open-autotools 0.0.1 - philbot-voice 2.16.0 - playlist2podcast =1.1.0, =2024.9.6.post3, =2024.9.30 Source cves: CVE-2026-50574...
iluvatar (0.0.1), open-autotools (0.0.1) +3 more potentially affected by CVE-2026-50023 via yt-dlp (2024.8.6)
yt-dlp PYPI version 2024.8.6 is affected by a known vulnerability. The following packages have a transitive dependency on yt-dlp and may be impacted: - iluvatar 0.0.1 - open-autotools 0.0.1 - philbot-voice 2.16.0 - playlist2podcast =1.1.0, =2024.9.6.post3, =2024.9.30 Source cves: CVE-2026-50023...
open-interpreter (>=0.1.8, <=0.1.9), openplugin (>=0.0.25, <=0.0.31) potentially affected by CVE-2026-47102 via litellm (0.7.10)
litellm PYPI version 0.7.10 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - open-interpreter =0.1.8, =0.0.25, =0.0.31 Source cves: CVE-2026-47102 Source advisory: OSV:PYSEC-2026-2600...
fastrepl (>=0.0.21, <=0.0.25), funcflow (0.0.3) +2 more potentially affected by CVE-2026-47102 via litellm (0.8.6)
litellm PYPI version 0.8.6 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - fastrepl =0.0.21, =0.0.5, =0.0.9 Source cves: CVE-2026-47102 Source advisory: OSV:PYSEC-2026-2600...
bavisitter (>=0.0.0, <=0.1.0rc1), cosmoai (>=0.8.8, <=0.9.1.11) +1 more potentially affected by CVE-2026-47102 via litellm (0.13.0)
litellm PYPI version 0.13.0 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - bavisitter =0.0.0, =0.8.8, =0.9.1.11 - open-interpreter 0.1.11 Source cves: CVE-2026-47102 Source advisory: OSV:PYSEC-2026-2600...
open-interpreter (>=0.1.12, <=0.1.17), promptmodel (>=0.0.25, <=0.0.31) potentially affected by CVE-2026-47102 via litellm (0.13.2)
litellm PYPI version 0.13.2 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - open-interpreter =0.1.12, =0.0.25, =0.0.31 Source cves: CVE-2026-47102 Source advisory: OSV:PYSEC-2026-2600...
open-interpreter (>=0.1.8, <=0.1.9), openplugin (>=0.0.25, <=0.0.31) potentially affected by CVE-2026-47101 via litellm (0.7.10)
litellm PYPI version 0.7.10 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - open-interpreter =0.1.8, =0.0.25, =0.0.31 Source cves: CVE-2026-47101 Source advisory: OSV:PYSEC-2026-2598...
bavisitter (>=0.0.0, <=0.1.0rc1), cosmoai (>=0.8.8, <=0.9.1.11) +1 more potentially affected by CVE-2026-47101 via litellm (0.13.0)
litellm PYPI version 0.13.0 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - bavisitter =0.0.0, =0.8.8, =0.9.1.11 - open-interpreter 0.1.11 Source cves: CVE-2026-47101 Source advisory: OSV:PYSEC-2026-2598...
open-interpreter (>=0.1.12, <=0.1.17), promptmodel (>=0.0.25, <=0.0.31) potentially affected by CVE-2026-47101 via litellm (0.13.2)
litellm PYPI version 0.13.2 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - open-interpreter =0.1.12, =0.0.25, =0.0.31 Source cves: CVE-2026-47101 Source advisory: OSV:PYSEC-2026-2598...
mcp-open-client (0.4.27), synth-mapping-helper (>=1.5.16, <=1.5.18) potentially affected by CVE-2026-45554 via nicegui (2.21.1)
nicegui PYPI version 2.21.1 is affected by a known vulnerability. The following packages have a transitive dependency on nicegui and may be impacted: - mcp-open-client 0.4.27 - synth-mapping-helper =1.5.16, =1.5.18 Source cves: CVE-2026-45554 Source advisory: OSV:PYSEC-2026-2680...
openwebui-token-tracking (0.1.7) potentially affected by CVE-2026-45672 via open-webui (0.6.0)
open-webui PYPI version 0.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on open-webui and may be impacted: - openwebui-token-tracking 0.1.7 Source cves: CVE-2026-45672 Source advisory: OSV:PYSEC-2026-2698...
openwebui-token-tracking (0.1.7) potentially affected by CVE-2026-45675 via open-webui (0.6.0)
open-webui PYPI version 0.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on open-webui and may be impacted: - openwebui-token-tracking 0.1.7 Source cves: CVE-2026-45675 Source advisory: OSV:PYSEC-2026-2730...
PYSEC-2026-2698 Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed
Summary The /api/v1/utils/code/execute endpoint executes arbitrary Python code via Jupyter for any verified user, even when the admin has set ENABLECODEEXECUTION=false. The feature gate is not enforced on the API endpoint — the configuration says "disabled" but code still executes. Details The...
mcp-open-client (0.4.27), synth-mapping-helper (>=1.5.16, <=1.5.18) potentially affected by CVE-2026-45553 via nicegui (2.21.1)
nicegui PYPI version 2.21.1 is affected by a known vulnerability. The following packages have a transitive dependency on nicegui and may be impacted: - mcp-open-client 0.4.27 - synth-mapping-helper =1.5.16, =1.5.18 Source cves: CVE-2026-45553 Source advisory: OSV:PYSEC-2026-2679...
PYSEC-2026-2755 Open WebUI has a SSRF Bypass via HTTP Redirect Following in Web-Fetch and Image-Load Endpoints (not addressed by CVE-2025-65958)
Server-Side Request Forgery SSRF Bypass via HTTP Redirect Following in Web-Fetch, Image-Load, and Chat-Completion Endpoints Summary The validateurl function in backend/openwebui/retrieval/web/utils.py only validates the initial URL submitted by the caller. The HTTP clients used downstream sync...
openwebui-token-tracking (0.1.7) potentially affected by CVE-2026-45401 via open-webui (0.6.0)
open-webui PYPI version 0.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on open-webui and may be impacted: - openwebui-token-tracking 0.1.7 Source cves: CVE-2026-45401 Source advisory: OSV:PYSEC-2026-2755...
PYSEC-2026-2706 Open WebUI Vulnerable to Unauthenticated RAG Configuration Disclosure
Vulnerability Type: Information Disclosure / Missing Authentication Severity: Medium Component: backend/openwebui/routers/retrieval.py — getstatus GET / Affected Endpoint: GET /api/v1/retrieval/ Affected Version: Open WebUI main branch — confirmed unpatched through v0.9.2 Authentication Required:...