Lucene search
+L

13181 matches found

CVE
CVE
•added 2023/02/16 5:30 p.m.•367 views

CVE-2023-24807

The CVE-2023-24807 issue is in Undici’s header normalization (headerValueNormalize) used by the Headers.fetch API, allowing a Regular Expression Denial of Service when untrusted header values are processed. Affected range is before Undici v5.19.1; the vulnerability is fixed in v5.19.1. Upgrading ...

7.5CVSS7.9AI score0.01315EPSS
SaveExploits0References5Affected Software1
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2023/02/16 12:00 a.m.•4 views

CVE-2023-23936: Improper Neutralization of CRLF Sequences

Undici is an HTTP/1.1 client for Node.js. Starting with version 2.0.0 and prior to version 5.19.1, the undici library does not protect host HTTP header from CRLF injection vulnerabilities. This issue is patched in Undici v5.19.1. As a workaround, sanitize the headers.host string before passing to...

6.5CVSS5.8AI score0.01129EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2023/02/16 12:00 a.m.•51 views

SUSE SLES15 / openSUSE 15 Security Update : nodejs18 (SUSE-SU-2023:0419-1)

The remote SUSE Linux SLES15 / SLESSAP15 / openSUSE 15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2023:0419-1 advisory. This update ships nodejs18 jscPED-2097 Update to NodejJS 18.13.0 LTS: build: disable v8 snapshot compression by defau...

9.1CVSS7.2AI score0.81832EPSS
SaveExploits5References25
Positive Technologies
Positive Technologies
•added 2023/02/16 12:00 a.m.•21 views

PT-2023-2003

Name of the Vulnerable Software and Affected Versions Node.js versions prior to 19.6.1 Node.js versions prior to 18.14.1 Node.js versions prior to 16.19.1 Node.js versions prior to 14.21.3 Description A privilege escalation issue exists, related to errors in authorization. This issue can be...

9.8CVSS7.1AI score0.02023EPSS
SaveExploits0References300
Positive Technologies
Positive Technologies
•added 2023/02/16 12:00 a.m.•26 views

PT-2023-2765

Name of the Vulnerable Software and Affected Versions Node.js versions prior to 19.6.1 Node.js versions prior to 18.14.1 Node.js versions prior to 16.19.1 Node.js versions prior to 14.21.3 Description An untrusted search path issue exists that could allow an attacker to search and potentially loa...

4.6CVSS6.4AI score0.00452EPSS
SaveExploits0References299
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2023/02/16 12:00 a.m.•6 views

CVE-2023-24807: Improper Input Validation

Undici is an HTTP/1.1 client for Node.js. Prior to version 5.19.1, the Headers.set and Headers.append methods are vulnerable to Regular Expression Denial of Service ReDoS attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normali...

7.5CVSS5.8AI score0.01315EPSS
SaveExploits0References3
osv_suse
osv_suse
•added 2023/02/15 10:45 a.m.•14 views

SUSE-SU-2023:0419-1 Security update for nodejs18

This update for nodejs18 fixes the following issues: This update ships nodejs18 jscPED-2097 Update to NodejJS 18.13.0 LTS: build: disable v8 snapshot compression by default crypto: update root certificates deps: update ICU to 72.1 doc: + add doc-only deprecation for headers/trailers setters + add...

9.1CVSS7.5AI score0.81832EPSS
SaveExploits5References18
SUSE CVE
SUSE CVE
•added 2023/02/15 5:33 a.m.•14 views

SUSE CVE-2013-7378

scripts/email.coffee in the Hubot Scripts module before 2.4.4 for Node.js allows remote attackers to execute arbitrary commands...

9.8CVSS7.6AI score0.02685EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:33 a.m.•14 views

SUSE CVE-2013-7453

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting XSS filter via vectors related to UI redressing...

6.1CVSS7.4AI score0.0185EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:28 a.m.•16 views

SUSE CVE-2014-3744

Directory traversal vulnerability in the st module before 0.2.5 for Node.js allows remote attackers to read arbitrary files via a %2e%2e encoded dot dot in an unspecified path...

7.5CVSS7AI score0.34012EPSS
SaveExploits1References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:27 a.m.•12 views

SUSE CVE-2014-5256

Node.js 0.8 before 0.8.28 and 0.10 before 0.10.30 does not consider the possibility of recursive processing that triggers V8 garbage collection in conjunction with a V8 interrupt, which allows remote attackers to cause a denial of service memory corruption and application crash via deep JSON...

5CVSS7.6AI score0.03292EPSS
SaveExploits1References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:12 a.m.•2 views

SUSE CVE-2015-8027

Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service uncaughtException and service outage via a pipelined HTTP request...

7.5CVSS9AI score0.05356EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:10 a.m.•9 views

SUSE CVE-2015-8860

The tar package before 2.0.0 for Node.js allows remote attackers to write to arbitrary files via a symlink attack in an archive...

7.5CVSS7.9AI score0.04001EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 5:06 a.m.•19 views

SUSE CVE-2016-2086

Node.js 0.10.x before 0.10.42, 0.12.x before 0.12.10, 4.x before 4.3.0, and 5.x before 5.6.0 allow remote attackers to conduct HTTP request smuggling attacks via a crafted Content-Length HTTP header...

7.5CVSS7AI score0.06257EPSS
SaveExploits0References5
SUSE CVE
SUSE CVE
•added 2023/02/15 5:06 a.m.•11 views

SUSE CVE-2016-2216

The HTTP header parsing code in Node.js 0.10.x before 0.10.42, 0.11.6 through 0.11.16, 0.12.x before 0.12.10, 4.x before 4.3.0, and 5.x before 5.6.0 allows remote attackers to bypass an HTTP response-splitting protection mechanism via UTF-8 encoded Unicode characters in the HTTP header, as...

7.5CVSS7.3AI score0.07262EPSS
SaveExploits0References5
SUSE CVE
SUSE CVE
•added 2023/02/15 5:05 a.m.•10 views

SUSE CVE-2016-2537

The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports'utc-millisec' regular expression, which allows remote attackers to cause a denial of service blocked event loop via a crafted string...

7.5CVSS8.8AI score0.01849EPSS
SaveExploits0References3
SUSE CVE
SUSE CVE
•added 2023/02/15 4:58 a.m.•9 views

SUSE CVE-2016-7099

The tls.checkServerIdentity function in Node.js 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before 4.6.0, and 6.x before 6.7.0 does not properly handle wildcards in name fields of X.509 certificates, which allows man-in-the-middle attackers to spoof servers via a crafted certificate...

5.9CVSS7.2AI score0.02841EPSS
SaveExploits0References7
SUSE CVE
SUSE CVE
•added 2023/02/15 4:39 a.m.•8 views

SUSE CVE-2017-14849

Node.js 8.5.0 before 8.6.0 allows remote attackers to access unintended files, because a change to ".." handling was incompatible with the pathname validation used by unspecified community modules...

7.5CVSS9.2AI score0.54389EPSS
SaveExploits3References4
SUSE CVE
SUSE CVE
•added 2023/02/15 4:39 a.m.•14 views

SUSE CVE-2017-14919

Node.js before 4.8.5, 6.x before 6.11.5, and 8.x before 8.8.0 allows remote attackers to cause a denial of service uncaught exception and crash by leveraging a change in the zlib module 1.2.9 making 8 an invalid value for the windowBits parameter...

7.5CVSS9AI score0.08303EPSS
SaveExploits0References6
SUSE CVE
SUSE CVE
•added 2023/02/15 4:33 a.m.•12 views

SUSE CVE-2018-3745

atob 2.0.3 and earlier allocates uninitialized Buffers when number is passed in input on Node.js 4.x and below...

9.1CVSS9.1AI score0.02141EPSS
SaveExploits1References3
Rows per page
Query Builder