Lucene search
+L

9 matches found

Mend
Mend
•added 2026/05/14 3:07 a.m.•4 views

WS-2019-0018

All versions of node-os-utils are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution...

9.8CVSS6AI score
SaveExploits0References1
vulnersOsv
vulnersOsv
•added 2026/05/14 3:07 a.m.•3 views

@condor-labs/metrics (>=1.3.0, <=1.3.5), zation (>=0.6.5, <=0.7.0) +3 more potentially affected by unknown CVE via node-os-utils (1.0.7)

node-os-utils NPM version 1.0.7 is affected by a known vulnerability. The following packages have a transitive dependency on node-os-utils and may be impacted: - @condor-labs/metrics =1.3.0, =0.6.5, =0.7.4, =0.2.2, =0.2.3 - zation-service-nodemailer 0.1.2 Source cves: unknown CVE Source advisory:...

5.8AI score
SaveExploits0
Github Security Blog
Github Security Blog
•added 2019/06/11 4:16 p.m.•19 views

Remote Code Execution in node-os-utils

Versions of node-os-utils prior to 1.1.0 are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution. Recommendation Upgrade to version 1.1.0 or later...

7.2AI score
SaveExploits0References4Affected Software1
osv_ghsa
osv_ghsa
•added 2019/06/11 4:16 p.m.•22 views

GHSA-J9F8-8H89-J69X Remote Code Execution in node-os-utils

Versions of node-os-utils prior to 1.1.0 are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution. Recommendation Upgrade to version 1.1.0 or later...

7.3CVSS7.8AI score
SaveExploits0References3
vulnersOsv
vulnersOsv
•added 2019/06/11 4:16 p.m.•3 views

@condor-labs/metrics (>=1.3.0, <=1.3.5), zation (>=0.6.5, <=0.7.0) +3 more potentially affected by unknown CVE via node-os-utils (1.0.7)

node-os-utils NPM version 1.0.7 is affected by a known vulnerability. The following packages have a transitive dependency on node-os-utils and may be impacted: - @condor-labs/metrics =1.3.0, =0.6.5, =0.7.4, =0.2.2, =0.2.3 - zation-service-nodemailer 0.1.2 Source cves: unknown CVE Source advisory:...

5.8AI score
SaveExploits0
vulnersOsv
vulnersOsv
•added 2019/06/11 4:16 p.m.•10 views

@condor-labs/metrics (>=1.3.0, <=1.3.5), zation (>=0.6.5, <=0.7.0) +3 more potentially affected by unknown CVE via node-os-utils (1.0.7)

node-os-utils NPM version 1.0.7 is affected by a known vulnerability. The following packages have a transitive dependency on node-os-utils and may be impacted: - @condor-labs/metrics =1.3.0, =0.6.5, =0.7.4, =0.2.2, =0.2.3 - zation-service-nodemailer 0.1.2 Source cves: unknown CVE Source advisory:...

5.4AI score
SaveExploits0
Positive Technologies
Positive Technologies
•added 2019/06/11 12:00 a.m.•5 views

PT-2019-20053

Name of the Vulnerable Software and Affected Versions node-os-utils versions prior to 1.1.0 Description The issue is related to insufficient input validation, which allows an attacker to run arbitrary commands on the server. This can lead to remote code execution. Recommendations Upgrade to versi...

7.3CVSS6.2AI score
SaveExploits0References4
Veracode
Veracode
•added 2019/02/15 7:27 a.m.•16 views

Remote Code Execution (RCE)

node-os-utils is vulnerable to remote code execution RCE. The attack exists because it does not properly handle the user inputs, allowing the attacker to inject malicious code...

7.7AI score
SaveExploits0
nodejs
nodejs
•added 2019/02/14 2:29 a.m.•26 views

Remote Code Execution

Overview Versions of node-os-utils prior to 1.1.0 are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution. Recommendation Upgrade to version 1.1.0 or later...

7.5AI score
SaveExploits0Affected Software1
Rows per page
Query Builder