9 matches found
@condor-labs/metrics (>=1.3.0, <=1.3.5), zation (>=0.6.5, <=0.7.0) +3 more potentially affected by unknown CVE via node-os-utils (1.0.7)
node-os-utils NPM version 1.0.7 is affected by a known vulnerability. The following packages have a transitive dependency on node-os-utils and may be impacted: - @condor-labs/metrics =1.3.0, =0.6.5, =0.7.4, =0.2.2, =0.2.3 - zation-service-nodemailer 0.1.2 Source cves: unknown CVE Source advisory:...
WS-2019-0018
All versions of node-os-utils are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution...
GHSA-J9F8-8H89-J69X Remote Code Execution in node-os-utils
Versions of node-os-utils prior to 1.1.0 are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution. Recommendation Upgrade to version 1.1.0 or later...
@condor-labs/metrics (>=1.3.0, <=1.3.5), zation (>=0.6.5, <=0.7.0) +3 more potentially affected by unknown CVE via node-os-utils (1.0.7)
node-os-utils NPM version 1.0.7 is affected by a known vulnerability. The following packages have a transitive dependency on node-os-utils and may be impacted: - @condor-labs/metrics =1.3.0, =0.6.5, =0.7.4, =0.2.2, =0.2.3 - zation-service-nodemailer 0.1.2 Source cves: unknown CVE Source advisory:...
Remote Code Execution in node-os-utils
Versions of node-os-utils prior to 1.1.0 are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution. Recommendation Upgrade to version 1.1.0 or later...
@condor-labs/metrics (>=1.3.0, <=1.3.5), zation (>=0.6.5, <=0.7.0) +3 more potentially affected by unknown CVE via node-os-utils (1.0.7)
node-os-utils NPM version 1.0.7 is affected by a known vulnerability. The following packages have a transitive dependency on node-os-utils and may be impacted: - @condor-labs/metrics =1.3.0, =0.6.5, =0.7.4, =0.2.2, =0.2.3 - zation-service-nodemailer 0.1.2 Source cves: unknown CVE Source advisory:...
PT-2019-20053
Name of the Vulnerable Software and Affected Versions node-os-utils versions prior to 1.1.0 Description The issue is related to insufficient input validation, which allows an attacker to run arbitrary commands on the server. This can lead to remote code execution. Recommendations Upgrade to versi...
Remote Code Execution (RCE)
node-os-utils is vulnerable to remote code execution RCE. The attack exists because it does not properly handle the user inputs, allowing the attacker to inject malicious code...
Remote Code Execution
Overview Versions of node-os-utils prior to 1.1.0 are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution. Recommendation Upgrade to version 1.1.0 or later...