Lucene search
+L

270 matches found

OSV
OSV
•added 2026/07/27 6:16 p.m.•10 views

DEBIAN-CVE-2026-54272

ip-address is a library for parsing and manipulating IPv4 and IPv6 addresses in JavaScript. Versions 10.1.1 through 10.2.0 are vulnerable to SSRF through misclassification of IPv4-mapped/NAT64 IPv6 addresses. Address6.getType classifies an address by matching it against a table of known IPv6...

6.9CVSS6.7AI score0.00401EPSS
SaveExploits0References1
Cvelist
Cvelist
•added 2026/07/27 5:13 p.m.•55 views

CVE-2026-54272 ip-address: Misclassification of IPv4-mapped/NAT64 IPv6 addresses can bypass SSRF and trust-boundary checks

ip-address is a library for parsing and manipulating IPv4 and IPv6 addresses in JavaScript. Versions 10.1.1 through 10.2.0 are vulnerable to SSRF through misclassification of IPv4-mapped/NAT64 IPv6 addresses. Address6.getType classifies an address by matching it against a table of known IPv6...

6.9CVSS0.00401EPSS
SaveExploits0References1
Vulnrichment
Vulnrichment
•added 2026/07/27 5:13 p.m.•16 views

CVE-2026-54272 ip-address: Misclassification of IPv4-mapped/NAT64 IPv6 addresses can bypass SSRF and trust-boundary checks

ip-address is a library for parsing and manipulating IPv4 and IPv6 addresses in JavaScript. Versions 10.1.1 through 10.2.0 are vulnerable to SSRF through misclassification of IPv4-mapped/NAT64 IPv6 addresses. Address6.getType classifies an address by matching it against a table of known IPv6...

6.9CVSS6.7AI score0.00401EPSS
SaveExploits0References1
Mend
Mend
•added 2026/07/27 5:13 p.m.•3 views

CVE-2026-54272

ip-address is a library for parsing and manipulating IPv4 and IPv6 addresses in JavaScript. Versions 10.1.1 through 10.2.0 are vulnerable to SSRF through misclassification of IPv4-mapped/NAT64 IPv6 addresses. Address6.getType classifies an address by matching it against a table of known IPv6...

6.9CVSS6.7AI score0.00401EPSS
SaveExploits0References6
Positive Technologies
Positive Technologies
•added 2026/07/27 12:00 a.m.•27 views

PT-2026-65085

Name of the Vulnerable Software and Affected Versions ip-address versions 10.1.1 through 10.2.0 Description The library is susceptible to Server-Side Request Forgery SSRF due to the misclassification of IPv4-mapped and NAT64 IPv6 addresses. The Address6.getType function classifies addresses by...

9.8CVSS6.9AI score0.00401EPSS
SaveExploits0References204
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/07/27 12:00 a.m.•5 views

CVE-2026-54272: Improper Input Validation

ip-address is a library for parsing and manipulating IPv4 and IPv6 addresses in JavaScript. Versions 10.1.1 through 10.2.0 are vulnerable to SSRF through misclassification of IPv4-mapped/NAT64 IPv6 addresses. Address6.getType classifies an address by matching it against a table of known IPv6...

6.9CVSS6.7AI score0.00401EPSS
SaveExploits0References3
NVD
NVD
•added 2026/07/21 9:16 p.m.•24 views

CVE-2026-47695

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to version 1.119.0, CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed ...

7.1CVSS0.00468EPSS
SaveExploits0References1
Vulnrichment
Vulnrichment
•added 2026/07/21 8:51 p.m.•9 views

CVE-2026-47695 CC-Tweaked has an SSRF Protection Bypass with NAT64

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to version 1.119.0, CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed ...

7.1CVSS6AI score0.00468EPSS
SaveExploits0References1
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/07/21 12:00 a.m.•4 views

CVE-2026-47695: Server-Side Request Forgery (SSRF)

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to version 1.119.0, CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed ...

7.1CVSS6AI score0.00468EPSS
SaveExploits0References2
OSV
OSV
•added 2026/07/17 7:42 p.m.•16 views

GO-2026-5996 ToolHive: SSRF guard misses IPv6 NAT64 ranges (64:ff9b::/96, 64:ff9b:1::/48), allowing metadata/internal access behind a NAT64 gateway in github.com/stacklok/toolhive

ToolHive: SSRF guard misses IPv6 NAT64 ranges 64:ff9b::/96, 64:ff9b:1::/48, allowing metadata/internal access behind a NAT64 gateway in github.com/stacklok/toolhive...

6.3CVSS8.1AI score0.00327EPSS
SaveExploits0References1
OSV
OSV
•added 2026/07/15 9:58 p.m.•25 views

GHSA-XGCH-X3MX-CM3C safeurl is Missing IPv6 CIDR Ranges in Blocklist

The privateNetworks blocklist was found to be missing newly added CIDR ranges. More specifically, the following CIDR ranges were not being blocked: - 64:ff9b:1::/48: NAT64 local-use prefix RFC 8215 - 5f00::/16: Segment Routing SRv6 SIDs RFC 9602 - 3fff::/20: documentation prefix RFC 9637 -...

6.9CVSS7.8AI score0.00521EPSS
SaveExploits0References3
Github Security Blog
Github Security Blog
•added 2026/07/15 9:51 p.m.•32 views

ToolHive: SSRF guard misses IPv6 NAT64 ranges (64:ff9b::/96, 64:ff9b:1::/48), allowing metadata/internal access behind a NAT64 gateway

Summary ToolHive's hand-rolled private/reserved-IP SSRF guard networking.IsPrivateIP in pkg/networking/utilities.go does not recognize the IPv6 NAT64 address ranges — the well-known prefix 64:ff9b::/96 RFC 6052 and the RFC 8215 local-use prefix 64:ff9b:1::/48. As a result, an address such as...

6.3CVSS7.7AI score0.00327EPSS
SaveExploits0References2Affected Software1
OSV
OSV
•added 2026/07/15 6:21 p.m.•22 views

GHSA-RJG7-R26H-CFP2 Koel: Full-read SSRF via podcast enclosure URL: isPublicHost() filter_var guard does not reject NAT64 (64:ff9b::/96) or 6to4 (2002::/16) IPv6-transition wrappers of internal IPv4

Summary Koel's outbound-URL guard App\Helpers\Network::isPublicHost classifies an IP as "public" using PHP's filtervar$ip, FILTERVALIDATEIP, FILTERFLAGNOPRIVRANGE | FILTERFLAGNORESRANGE. That flag set does not recognise IPv6 transition-address forms that embed a private/loopback/link-local IPv4:...

5.3CVSS6.2AI score0.00427EPSS
SaveExploits0References5
OSV
OSV
•added 2026/07/13 3:46 p.m.•23 views

PYSEC-2026-2977 pydantic-ai: SSRF blocklist bypass via IPv4-compatible, SIIT/IVI, and local NAT64 IPv6 addresses (incomplete fix of CVE-2026-46678)

Summary When an application using Pydantic AI opts a URL into forcedownload='allow-local' which disables the default block on private/internal IPs and runs on a network that routes the affected IPv6 transition forms NAT64- or ISATAP-configured networks, the cloud-metadata blocklist could be...

6.8CVSS5.7AI score0.00417EPSS
SaveExploits0References8
PyPA
PyPA
•added 2026/07/13 3:46 p.m.•29 views

pydantic-ai: SSRF blocklist bypass via IPv4-compatible, SIIT/IVI, and local NAT64 IPv6 addresses (incomplete fix of CVE-2026-46678)

SummaryWhen an application using Pydantic AI opts a URL into forcedownload='allow-local' which disables the default block on private/internal IPs and runs on a network that routes the affected IPv6 transition forms NAT64- or ISATAP-configured networks, the cloud-metadata blocklist could be bypass...

6.8CVSS5.7AI score0.00417EPSS
SaveExploits0References8Affected Software1
PyPA
PyPA
•added 2026/07/13 3:46 p.m.•36 views

pydantic-ai: SSRF blocklist bypass via IPv4-compatible, SIIT/IVI, and local NAT64 IPv6 addresses (incomplete fix of CVE-2026-46678)

SummaryWhen an application using Pydantic AI opts a URL into forcedownload='allow-local' which disables the default block on private/internal IPs and runs on a network that routes the affected IPv6 transition forms NAT64- or ISATAP-configured networks, the cloud-metadata blocklist could be bypass...

6.8CVSS5.7AI score0.00417EPSS
SaveExploits0References8Affected Software1
OSV
OSV
•added 2026/07/13 3:46 p.m.•24 views

PYSEC-2026-2981 pydantic-ai: SSRF blocklist bypass via IPv4-compatible, SIIT/IVI, and local NAT64 IPv6 addresses (incomplete fix of CVE-2026-46678)

Summary When an application using Pydantic AI opts a URL into forcedownload='allow-local' which disables the default block on private/internal IPs and runs on a network that routes the affected IPv6 transition forms NAT64- or ISATAP-configured networks, the cloud-metadata blocklist could be...

6.8CVSS5.7AI score0.00417EPSS
SaveExploits0References8
attackerkb
attackerkb
•added 2026/07/10 9:43 p.m.•23 views

CVE-2026-55187

Mailpit is an email testing tool and API for developers. Prior to 1.30.2, the remediation shipped for CVE-2026-27808 is incomplete because the tools.IsInternalIP deny-list in internal/tools/net.go relies on Go's standard library classification helpers and does not block IPv6 transition mechanisms...

5.8CVSS8AI score0.00384EPSS
SaveExploits0References4Affected Software1
OSV
OSV
•added 2026/07/09 1:35 p.m.•44 views

GHSA-M5X5-28JR-GPJJ pyLoad: SSRF guard bypass via IPv6 6to4/NAT64 transition wrappers of internal IPs

Summary isglobaladdress in src/pyload/core/utils/web/check.py is the central guard against SSRF-style outbound connections in pyload-ng. It tests whether a given IP is "globally routable" via Python's ipaddress.ipaddressvalue.isglobal, and callers treat not isglobal as "deny": python def...

4.9CVSS5.9AI score0.00289EPSS
SaveExploits0References2
Positive Technologies
Positive Technologies
•added 2026/07/09 12:00 a.m.•42 views

PT-2026-56836

Name of the Vulnerable Software and Affected Versions pyload-ng affected versions not specified Description An issue exists where the software is susceptible to Server-Side Request Forgery SSRF. The is global address and is global host functions in src/pyload/core/utils/web/check.py rely on...

4.9CVSS5.8AI score0.00289EPSS
SaveExploits0References8
Rows per page
Query Builder