Lucene search
+L

17 matches found

CVE
CVE
•added 2026/08/27 5:11 p.m.•30 views

CVE-2026-55758

CC: Tweaked , a mod for Minecraft adding programmable computers, has an SSRF protection bypass in its AddressPredicate.java component. Prior to 1.120.0 , the protection blocks the RFC 6052 64:ff9b::/96 NAT64 prefix but omits the RFC 8215 64:ff9b:1::/48 local-use prefix, so PrivatePattern.matches(...

6.9CVSS6AI score0.00473EPSS
SaveExploits0References2
Cvelist
Cvelist
•added 2026/08/27 5:11 p.m.•40 views

CVE-2026-55758 CC: Tweaked: Incomplete fix for GHSA-5jh9-2h63-pw4q: RFC 8215 NAT64 prefix (64:ff9b:1::/96) bypasses SSRF protection

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to 1.120.0, the SSRF protection in projects/core/src/main/java/dan200/computercraft/core/apis/http/options/AddressPredicate.java blocks the RFC 6052 64:ff9b::/96 NAT64 prefix but omits the R...

6.9CVSS0.00473EPSS
SaveExploits0References2
EUVD
EUVD
•added 2026/08/27 5:11 p.m.•19 views

EUVD-2026-67159

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to 1.120.0, the SSRF protection in projects/core/src/main/java/dan200/computercraft/core/apis/http/options/AddressPredicate.java blocks the RFC 6052 64:ff9b::/96 NAT64 prefix but omits the R...

6.9CVSS6AI score0.00473EPSS
SaveExploits0References2
osv-cve
osv-cve
•added 2026/08/27 5:11 p.m.•32 views

CVE-2026-55758 CC: Tweaked: Incomplete fix for GHSA-5jh9-2h63-pw4q: RFC 8215 NAT64 prefix (64:ff9b:1::/96) bypasses SSRF protection

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to 1.120.0, the SSRF protection in projects/core/src/main/java/dan200/computercraft/core/apis/http/options/AddressPredicate.java blocks the RFC 6052 64:ff9b::/96 NAT64 prefix but omits the R...

6.9CVSS6.1AI score
SaveExploits0References4
Positive Technologies
Positive Technologies
•added 2026/08/27 12:00 a.m.•36 views

PT-2026-82689

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to 1.120.0, the SSRF protection in projects/core/src/main/java/dan200/computercraft/core/apis/http/options/AddressPredicate.java blocks the RFC 6052 64:ff9b::/96 NAT64 prefix but omits the R...

6.9CVSS6AI score0.00473EPSS
SaveExploits0References3
CVE
CVE
•added 2026/08/12 4:31 p.m.•57 views

CVE-2026-73297

The CVE-2026-73297 entry concerns Microsoft UFO, an open-source framework for automation across devices and platforms. Before version 3.0.8, the function _is_blocked_ip in ufo/utils/url_security.py failed to block IPv6 NAT64 prefixes (64:ff9b::/96 and 64:ff9b:1::/48), the 6to4 prefix (2002::/16),...

6.9CVSS6AI score0.02903EPSS
SaveExploits0References3
Positive Technologies
Positive Technologies
•added 2026/08/12 12:00 a.m.•16 views

PT-2026-71153

Name of the Vulnerable Software and Affected Versions Microsoft UFO versions prior to 3.0.8 Description An issue exists where the is blocked ip function in ufo/utils/url security.py fails to block specific IPv6 prefixes, including NAT64 64:ff9b::/96 and 64:ff9b:1::/48, 6to4 2002::/16, and Teredo...

6.9CVSS5.9AI score0.02903EPSS
SaveExploits0References7
NVD
NVD
•added 2026/07/21 9:16 p.m.•26 views

CVE-2026-47695

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to version 1.119.0, CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed ...

7.1CVSS0.00468EPSS
SaveExploits0References1
Vulnrichment
Vulnrichment
•added 2026/07/21 8:51 p.m.•11 views

CVE-2026-47695 CC-Tweaked has an SSRF Protection Bypass with NAT64

CC: Tweaked is a mod for Minecraft which adds programmable computers, turtles, and more to the game. Prior to version 1.119.0, CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed ...

7.1CVSS6AI score0.00468EPSS
SaveExploits0References1
osv-ghsa
osv-ghsa
•added 2026/07/15 9:58 p.m.•26 views

GHSA-XGCH-X3MX-CM3C safeurl is Missing IPv6 CIDR Ranges in Blocklist

The privateNetworks blocklist was found to be missing newly added CIDR ranges. More specifically, the following CIDR ranges were not being blocked: - 64:ff9b:1::/48: NAT64 local-use prefix RFC 8215 - 5f00::/16: Segment Routing SRv6 SIDs RFC 9602 - 3fff::/20: documentation prefix RFC 9637 -...

6.9CVSS7.8AI score0.00521EPSS
SaveExploits0References3
Github Security Blog
Github Security Blog
•added 2026/07/15 9:51 p.m.•33 views

ToolHive: SSRF guard misses IPv6 NAT64 ranges (64:ff9b::/96, 64:ff9b:1::/48), allowing metadata/internal access behind a NAT64 gateway

Summary ToolHive's hand-rolled private/reserved-IP SSRF guard networking.IsPrivateIP in pkg/networking/utilities.go does not recognize the IPv6 NAT64 address ranges — the well-known prefix 64:ff9b::/96 RFC 6052 and the RFC 8215 local-use prefix 64:ff9b:1::/48. As a result, an address such as...

6.3CVSS7.7AI score0.00327EPSS
SaveExploits0References2Affected Software1
Cvelist
Cvelist
•added 2026/06/10 7:56 p.m.•54 views

CVE-2026-50127 Weblate SSRF: outbound URL guard misses the NAT64 well-known prefix (64:ff9b::/96)

Weblate is a web based localization tool. From version 5.15 to before version 2026.6, Weblate's VCSRESTRICTPRIVATE did not properly account for some transitional IPv6 ranges, multicast addresses, or some semi-private IPv4 ranges, which allowed some addresses to bypass private range restrictions...

5.9CVSS0.00471EPSS
SaveExploits0References3
osv-cve
osv-cve
•added 2026/06/10 7:56 p.m.•24 views

CVE-2026-50127 Weblate SSRF: outbound URL guard misses the NAT64 well-known prefix (64:ff9b::/96)

Weblate is a web based localization tool. From version 5.15 to before version 2026.6, Weblate's VCSRESTRICTPRIVATE did not properly account for some transitional IPv6 ranges, multicast addresses, or some semi-private IPv4 ranges, which allowed some addresses to bypass private range restrictions...

5.9CVSS5.8AI score
SaveExploits0References5
GitLab Advisory Database
GitLab Advisory Database
•added 2026/05/29 12:00 a.m.•74 views

CC-Tweaked has an SSRF Protection Bypass with NAT64

CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed on IPv6-capable servers using NAT64 well-known prefix addresses 64:ff9b::/96. An attacker who can execute Lua code can reach an...

7.1CVSS6AI score0.00468EPSS
SaveExploits0References3
GitLab Advisory Database
GitLab Advisory Database
•added 2026/05/29 12:00 a.m.•58 views

CC-Tweaked has an SSRF Protection Bypass with NAT64

CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed on IPv6-capable servers using NAT64 well-known prefix addresses 64:ff9b::/96. An attacker who can execute Lua code can reach an...

7.1CVSS6AI score0.00468EPSS
SaveExploits0References3
GitLab Advisory Database
GitLab Advisory Database
•added 2026/05/29 12:00 a.m.•33 views

CC-Tweaked has an SSRF Protection Bypass with NAT64

CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed on IPv6-capable servers using NAT64 well-known prefix addresses 64:ff9b::/96. An attacker who can execute Lua code can reach an...

7.1CVSS6AI score0.00468EPSS
SaveExploits0References3
GitLab Advisory Database
GitLab Advisory Database
•added 2026/05/29 12:00 a.m.•52 views

CC-Tweaked has an SSRF Protection Bypass with NAT64

CC-Tweaked's HTTP API http.request, http.websocket blocks requests to private network ranges to prevent server-side request forgery SSRF. This protection can be bypassed on IPv6-capable servers using NAT64 well-known prefix addresses 64:ff9b::/96. An attacker who can execute Lua code can reach an...

7.1CVSS6AI score0.00468EPSS
SaveExploits0References3
Rows per page
Query Builder