185 matches found
CVE-2022-31626
CVE-2022-31626 In PHP versions 7.4.x below 7.4.30, 8.0.x below 8.0.20, and 8.1.x below 8.1.7, when pdomysql extension with mysqlnd driver, if the third party is allowed to supply host to connect to and the password for the connection, password of excessive length can trigger a buffer overflow in...
PHP-binary-bugs
Advisory of Exploits AI POP Builder Collection of PHP binary bugs advisory Unfixed GMP Type confusion in unserialize Idea: bypass delayed wakeup and exploit unfixed GMP type confusion bug in PHP = 5.6.40 POC source: GMPtypeconfPOC.php Advisory CVE-2022-31626 analysis Idea: heap buffer overflow in...
TencentOS Server 3: php:7.4 (TSSA-2026:1210)
The version of Tencent Linux installed on the remote TencentOS Server 3 host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the TSSA-2026:1210 advisory. Package updates are available for TencentOS Server 3 that fix the following vulnerabilities...
Unity Linux 20.1050e / 20.1060e / 20.1070-8ae / 20.1070e Security Update: php (UTSA-2026-143713)
The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2026-143713 advisory. The mysqlnd wire protocol parser reads fields out of server packets before checking that the packet still holds enough bytes for them. A malicious or compromised MyS...
Alibaba Cloud Linux 3 : 0318: php (ALINUX3-SA-2026:0318)
The remote Alibaba Cloud Linux 3 host has packages installed that are affected by multiple vulnerabilities as referenced in the ALINUX3-SA-2026:0318 advisory. Package updates are available for Alibaba Cloud Linux 3 that fix the following vulnerabilities: CVE-2025-1218: The mysqlnd wire protocol...
Security update for php7
This update for php7 fixes the following issues: CVE-2025-1218: php: php: Denial of Service via out-of-bounds read in mysqlnd wire protocol parser bsc1282981. CVE-2025-14181: Integer overflow to buffer overflow in soap HTTP parsing bsc1283216. CVE-2026-6103: Archive entry injection via integer...
php: php: Denial of Service via out-of-bounds read in mysqlnd wire protocol parser
A flaw was found in PHP. The MySQL Native Driver mysqlnd wire protocol parser fails to verify that an incoming packet contains enough bytes before reading its fields. A malicious or compromised database server can send a truncated packet, causing the client application to read past the buffer...
CLSA-2026-1792502776 php: Fix of CVE-2025-1218
CVE-2025-1218: fix packet over-reads in the mysqlnd wire protocol parser GHSA-r6x9-5r99-36j7...
Ubuntu 14.04 LTS / 16.04 LTS / 18.04 LTS / 20.04 LTS / 22.04 LTS / 24.04 LTS / 26.04 LTS / 26.10 : PHP vulnerabilities (USN-8936-1)
The remote Ubuntu 14.04 LTS / 16.04 LTS / 18.04 LTS / 20.04 LTS / 22.04 LTS / 24.04 LTS / 26.04 LTS / 26.10 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-8936-1 advisory. It was discovered that PHP did not properly validate the size of MySQL...
Rocky Linux 9.6 [TuxCare] Security Update: php / php-bcmath / php-cli / php-common / php-dba / php-dbg / etc (ALMALINUX9.6:CLSA-2026:1792502776)
The Rocky Linux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1792502776 advisory. - The mysqlnd wire protocol parser reads fields out of server packets before checking that the packet still holds enough bytes for them. A...
AlmaLinux 9.6 [TuxCare] Security Update: php / php-bcmath / php-cli / php-common / php-dba / php-dbg / etc (ALMALINUX9.6:CLSA-2026:1792502776)
The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1792502776 advisory. - The mysqlnd wire protocol parser reads fields out of server packets before checking that the packet still holds enough bytes for them. A...
USN-8936-1: PHP vulnerabilities
It was discovered that PHP did not properly validate the size of MySQL server packets in the mysqlnd driver. A malicious server could possibly use this issue to cause PHP to crash, resulting in a denial of service. This issue was only addressed in Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04...
USN-8936-1 php8.5, php8.3, php8.1, php7.4, php7.2, php7.0, php5 vulnerabilities
It was discovered that PHP did not properly validate the size of MySQL server packets in the mysqlnd driver. A malicious server could possibly use this issue to cause PHP to crash, resulting in a denial of service. This issue was only addressed in Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04...
OESA-2026-4383 php security update
PHP is an HTML-embedded scripting language. PHP attempts to make it easy for developers to write dynamically generated web pages. PHP also offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled webpage with PHP is...
OESA-2026-4382 php security update
PHP is an HTML-embedded scripting language. PHP attempts to make it easy for developers to write dynamically generated web pages. PHP also offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled webpage with PHP is...
OESA-2026-4381 php security update
PHP is an HTML-embedded scripting language. PHP attempts to make it easy for developers to write dynamically generated web pages. PHP also offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled webpage with PHP is...
OESA-2026-4380 php security update
PHP is an HTML-embedded scripting language. PHP attempts to make it easy for developers to write dynamically generated web pages. PHP also offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled webpage with PHP is...
Astra Linux – vulnerability in php7.3
In PHP versions 7.4.x prior to 7.4.30, 8.0.x prior to 8.0.20, and 8.1.x prior to 8.1.7, when the pdomysql extension with the mysqlnd driver is used, if a third party is permitted to provide the host and password for the connection, an excessively long password may cause a buffer overflow in PHP,...
Security update for php8
This update for php8 fixes the following issues: CVE-2025-1218: php: php: Denial of Service via out-of-bounds read in mysqlnd wire protocol parser bsc1282981. CVE-2025-14181: Integer overflow to buffer overflow in soap HTTP parsing bsc1283216. CVE-2026-6103: Archive entry injection via integer...
SUSE-SU-2026:4651-1 Security update for php8
This update for php8 fixes the following issues: - CVE-2025-1218: php: php: Denial of Service via out-of-bounds read in mysqlnd wire protocol parser bsc1282981. - CVE-2025-14181: Integer overflow to buffer overflow in soap HTTP parsing bsc1283216. - CVE-2026-6103: Archive entry injection via...