14190 matches found
CVE-2018-11619
CVE-2018-11619 affects Foxit Reader. The vulnerability lies in the handling of the setFocus method where an object’s existence is not validated before operations, enabling a remote attacker to execute arbitrary code in the context of the current process. Exploitation requires user interaction (vi...
CVE-2018-14279
Foxit Reader CVE-2018-14279 is a remote code execution due to a type confusion in the resetForm method. Exploitation requires user interaction (visit a malicious page or open a malicious file). Affected product scope includes Foxit Reader (versions before the latest provided in advisories) and is...
CVE-2018-14269: Access of Resource Using Incompatible Type
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader 9.0.1.1049. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the prin...
CVE-2018-14242: Access of Resource Using Incompatible Type
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader 9.0.1.1049. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the...
Samsung SmartThings Hub video-core HTTP server override vulnerability
Samsung SmartThings Hub is a smart home management device from Samsung, South Korea. video-core HTTP server is one of the HTTP servers. A security vulnerability exists in the REST parser of the video-core HTTP server in the Samsung SmartThings Hub, which arises from the program's failure to...
Samsung SmartThings Hub video-core HTTP server buffer overflow vulnerability (CNVD-2018-14281)
Samsung SmartThings Hub is a smart home management device from Samsung, South Korea. video-core HTTP server is one of the HTTP servers. A security vulnerability exists in the REST parser of the video-core HTTP server in the Samsung SmartThings Hub, which arises from the program's failure to...
CVE-2018-14253: Access of Resource Using Incompatible Type
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader 9.0.1.1049. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the...
CVE-2018-14262: Access of Resource Using Incompatible Type
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader 9.0.1.1049. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the getU...
CVE-2018-14274: Access of Resource Using Incompatible Type
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader 9.0.1.1049. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the scro...
Can't install App Layering Agent, "System.MissingMethodException"
The Citrix Agent install fails because the Agent won't start. Windows says there was a timeout waiting for the service, but in reality it immediately crashes with a .Net error in the Windows Application event log. Application Log events: Log Name: Application Source: Application Error Date:...
GHSA-G36H-6R4F-3MQP Regular Expression Denial of Service in string package
Affected versions of string are vulnerable to regular expression denial of service when specifically crafted untrusted user input is passed into the underscore or unescapeHTML methods. Recommendation There is currently no direct patch for this vulnerability. Currently, the best solution is to avo...
GHSA-QX2F-477C-35RQ method-override ReDoS when untrusted user input passed into X-HTTP-Method-Override header
Affected versions of method-override are vulnerable to a regular expression denial of service vulnerability when untrusted user input is passed into the X-HTTP-Method-Override header. Recommendation Update to version 2.3.10 or later...
@sydcon/ghop (>=0.27.6, <=0.27.9), amid (>=1.2.0, <=1.2.5) +100 more potentially affected by CVE-2017-16136 via method-override (1.0.2)
method-override NPM version 1.0.2 is affected by a known vulnerability. The following packages have a transitive dependency on method-override and may be impacted: - @sydcon/ghop =0.27.6, =1.2.0, =0.0.3, =0.1.0, =0.0.0, =0.0.1, =1.3.1, =1.0.0, =0.1.0, =0.0.0, =0.0.0, =0.9.0, =0.9.1 and more Sourc...
88slot-ap (1.0.0), @andriyf/node-odata (>=0.7.15, <=0.7.1501) +467 more potentially affected by CVE-2017-16136 via method-override (>=1.0.2, <=2.3.9)
method-override NPM version =1.0.2, =0.7.15, =0.1.2-beta.1, =1.0.0, =0.13.7, =4.0.0-beta.6, =0.3.14, =0.27.6, =4.0.0, =4.2.34 and more Source cves: CVE-2017-16136 Source advisory: OSV:GHSA-QX2F-477C-35RQ...
88slot-ap (1.0.0), @andriyf/node-odata (>=0.7.15, <=0.7.1501) +370 more potentially affected by CVE-2017-16136 via method-override (>=2.0.0, <=2.3.9)
method-override NPM version =2.0.0, =0.7.15, =0.1.2-beta.1, =1.0.0, =0.13.7, =4.0.0-beta.6, =0.3.14, =4.0.0, =0.0.1, =0.0.52 and more Source cves: CVE-2017-16136 Source advisory: GHSA-QX2F-477C-35RQ...
method-override ReDoS when untrusted user input passed into X-HTTP-Method-Override header
Affected versions of method-override are vulnerable to a regular expression denial of service vulnerability when untrusted user input is passed into the X-HTTP-Method-Override header. Recommendation Update to version 2.3.10 or later...
GHSA-PVHP-V9QP-XF5R Django-piston and Django-tastypie do not properly deserialize YAML data
emitters.py in Django Piston before 0.2.3 and 0.2.x before 0.2.2.1 does not properly deserialize YAML data, which allows remote attackers to execute arbitrary Python code via vectors related to the yaml.load method. Django Tastypie has a very similar vulnerability...
OpenJDK: insufficient index validation in PatternSyntaxException getMessage() (Concurrency, 8199547)
Vulnerability in the Java SE, Java SE Embedded, JRockit component of Oracle Java SE subcomponent: Concurrency. Supported versions that are affected are Java SE: 6u191, 7u181, 8u172 and 10.0.1; Java SE Embedded: 8u171; JRockit: R28.3.18. Difficult to exploit vulnerability allows unauthenticated...
Barracuda Cloud ESS 2.x - Multiple Cross Site Vulnerabilities
Document Title: =============== Barracuda Cloud ESS 2.x - Multiple Cross Site Vulnerabilities References Source: ==================== http://www.vulnerability-lab.com/getcontent.php?id=742 Barracuda Networks Security ID: BNSEC-671 Release Date: ============= 2018-07-23 Vulnerability Laboratory ID...
PT-2018-1954
Name of the Vulnerable Software and Affected Versions GNU Libextractor versions prior to 1.8 Description The issue is related to an out-of-bounds read in the EXTRACTOR zip extract method function, located in zip extractor.c. This could potentially allow a remote attacker to impact the...