14064 matches found
CVE-2022-26320: Use of Insufficiently Random Values
The Rambus SafeZone Basic Crypto Module before 10.4.0, as used in certain Fujifilm formerly Fuji Xerox devices before 2022-03-01, Canon imagePROGRAF and imageRUNNER devices through 2022-03-14, and potentially many other devices, generates RSA keys that can be broken with Fermat's factorization...
CVE-2021-44032
TP-Link Omada SDN Software Controller before 5.0.15 does not check if the authentication method specified in a connection request is allowed. An attacker can bypass the captive portal authentication process by using the downgraded "no authentication" method, and access the protected network. For...
SUSE-SU-2022:0798-1 Security update for SUSE Manager Server 4.1
This update fixes the following issues: c3p0: - Update to version c3p0 0.9.5.5 and mchange-commons-java 0.2.19 Address CVE-2018-20433 Address CVE-2019-5427 - XML-config parsing related attacks bsc1133198 Properly implement the JDBC 4.1 abort method - Build with log4j mapper - Enhanced for RHEL8...
RUSTSEC-2022-0103 Incorrect signature verification on gzip-compressed install images
The coreos-installer is a program to fetch a disk image and stream it to a target disk. During the installation process the installation image gpg signatures are verified. The signature verification can be bypassed for gzip-compressed images due to a flaw in gzip coreos-installer wrapper. When th...
The store method allows you to store the same token twice
This issue has been created to upgrade a QA report submission to a medium severity finding. From 0x1f8b: The store method allows you to store the same token twice in NestedRecords.solL130 To do this you must first call storenftId,tokenA,0,reserve and then storenftId,tokenA,100000,reserve because ...
Cross site scripting
VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the viewcomponent gem. Data received via user input and passed as an...
CVE-2022-24722
VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the viewcomponent gem. Data received via user input and passed as an...
CVE-2022-24722: Improper Neutralization of Input During Web Page Generation
VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the viewcomponent gem. Data received via user input and passed as an...
PT-2022-16830
Name of the Vulnerable Software and Affected Versions ViewComponent versions prior to 2.31.2 ViewComponent versions prior to 2.49.1 Description The issue is related to a cross-site scripting vulnerability in the view component gem, specifically affecting translations. Data received via user input...
Image-processing security vulnerabilities
Image-Processing is an image-processing code repository that uses C. A security vulnerability exists in Image-Processing versions prior to 1.12.2 that stems from the use of unprocessed user input in the apply method, which allows an attacker to execute system commands...
CVE-2022-24712
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A vulnerability in versions prior to 4.1.9 might allow remote attackers to bypass the CodeIgniter4 Cross-Site Request Forgery CSRF protection mechanism. Users should upgrade to version 4.1.9. There are workarounds for...
Cross site request forgery (csrf)
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A vulnerability in versions prior to 4.1.9 might allow remote attackers to bypass the CodeIgniter4 Cross-Site Request Forgery CSRF protection mechanism. Users should upgrade to version 4.1.9. There are workarounds for...
CVE-2022-24712 Cross-Site Request Forgery (CSRF) Protection Bypass Vulnerability in CodeIgniter4
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A vulnerability in versions prior to 4.1.9 might allow remote attackers to bypass the CodeIgniter4 Cross-Site Request Forgery CSRF protection mechanism. Users should upgrade to version 4.1.9. There are workarounds for...
CVE-2022-24712 Cross-Site Request Forgery (CSRF) Protection Bypass Vulnerability in CodeIgniter4
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A vulnerability in versions prior to 4.1.9 might allow remote attackers to bypass the CodeIgniter4 Cross-Site Request Forgery CSRF protection mechanism. Users should upgrade to version 4.1.9. There are workarounds for...
miniOrange's Google Authenticator < 5.5 - Unauthenticated Arbitrary Options Deletion
The plugin does not have proper authorisation and CSRF checks when handling the reconfigureMethod, and does not validate the parameters passed to it properly. As a result, unauthenticated users could delete arbitrary options from the blog, making it unusable. Note: The initial issue was fixed in...
WordPress Shipping Method Display Style for WooCommerce plugin <= 3.7.4 - Sensitive Information Disclosure vulnerability
Sensitive Information Disclosure vulnerability discovered in WordPress Shipping Method Display Style for WooCommerce plugin versions = 3.7.4. Solution Update the WordPress Shipping Method Display Style for WooCommerce plugin to the latest available version at least 3.7.5...
PT-2022-16822 · Unknown · Codeigniter4
Name of the Vulnerable Software and Affected Versions: CodeIgniter4 versions prior to 4.1.9 Description: A vulnerability in CodeIgniter4 might allow remote attackers to bypass the Cross-Site Request Forgery CSRF protection mechanism. This issue can be exploited when auto-routing is enabled or...
method-crm (0.1.0) potentially affected by CVE-2021-37504 via jquery-file-upload (4.0.11)
jquery-file-upload NPM version 4.0.11 is affected by a known vulnerability. The following packages have a transitive dependency on jquery-file-upload and may be impacted: - method-crm 0.1.0 Source cves: CVE-2021-37504 Source advisory: OSV:GHSA-43X9-7HFV-MXRF...
method-crm (0.1.0) potentially affected by CVE-2021-37504 via jquery-file-upload (4.0.11)
jquery-file-upload NPM version 4.0.11 is affected by a known vulnerability. The following packages have a transitive dependency on jquery-file-upload and may be impacted: - method-crm 0.1.0 Source cves: CVE-2021-37504 Source advisory: GHSA-43X9-7HFV-MXRF...
Hive ransomware: Researchers figure out a method to decrypt files
Files encrypted by ransomware cant be recovered without obtaining the decryption key, if the encryption has been done properly. But that doesnt seem to be the case for Hive ransomware. Researchers from the Kookmin University in Korea have published a method for decrypting the data scrambled by...