21701 matches found
Apache Superset: Error verbosity exposes metadata in analytics databases
Generation of Error Message Containing analytics metadata Information in Apache Superset.This issue affects Apache Superset: before 4.1.0.Users are recommended to upgrade to version 4.1.0, which fixes the issue...
PYSEC-2026-1154 Apache Superset: Error verbosity exposes metadata in analytics databases
Generation of Error Message Containing analytics metadata Information in Apache Superset. This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue...
amundsen-metadata (>=1.0.18, <=2.5.4), amundsen-search (>=2.4.1, <=2.5.1) +8 more potentially affected by CVE-2024-49766 via werkzeug (0.15.3)
werkzeug PYPI version 0.15.3 is affected by a known vulnerability. The following packages have a transitive dependency on werkzeug and may be impacted: - amundsen-metadata =1.0.18, =2.4.1, =0.0.1, =0.0.6, =0.9.94, =0.0.1, =0.0.1, =0.0.1, =0.1.2 Source cves: CVE-2024-49766 Source advisory:...
alo7-airflow (>=1.10.0, <=1.10.0.7), amundsen-metadata (1.0.17) +65 more potentially affected by CVE-2024-49766 via werkzeug (0.14.1)
werkzeug PYPI version 0.14.1 is affected by a known vulnerability. The following packages have a transitive dependency on werkzeug and may be impacted: - alo7-airflow =1.10.0, =1.10.3b1, =0.6.7.post3, =0.1.1, =0.6.4, =0.1.0, =0.1.0, =1.0.5, =1.0.4, =0.1.3a0, =0.5.4rc0, =0.5.4rc0, =0.2.0rc0, =0.2....
celery-director (>=0.5.0, <=0.7.0), elementary-flask (>=0.0.1.dev7, <=0.0.1.dev12) +11 more potentially affected by CVE-2024-49766 via werkzeug (2.1.1)
werkzeug PYPI version 2.1.1 is affected by a known vulnerability. The following packages have a transitive dependency on werkzeug and may be impacted: - celery-director =0.5.0, =0.0.1.dev7, =0.0.1, =1.0.0, =1.3.0, =0.7.0b10, =1.1.2, =1.1.8 Source cves: CVE-2024-49766 Source advisory:...
dicgram (>=2.0.9, <=2.1.1), dsp-metadata-gui (>=1.3.2, <=8.5.0) +1 more potentially affected by CVE-2024-6345 via setuptools (67.3.1)
setuptools PYPI version 67.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - dicgram =2.0.9, =1.3.2, =8.5.0 - renku-lock 2.3.0 Source cves: CVE-2024-6345 Source advisory: OSV:PYSEC-2026-1918...
PYSEC-2026-1324 ebookmeta XML External Entity vulnerability
An XML External Entity XXE vulnerability in the ebookmeta.getmetadata function via lxml dependency allows attackers to access sensitive information or cause a Denial of Service DoS via crafted XML input...
ebookmeta XML External Entity vulnerability
An XML External Entity XXE vulnerability in the ebookmeta.getmetadata function via lxml dependency allows attackers to access sensitive information or cause a Denial of Service DoS via crafted XML input...
PYSEC-2026-1516 Server-Side Request Forgery in langchain-community.retrievers.web_research.WebResearchRetriever
A Server-Side Request Forgery SSRF vulnerability exists in the Web Research Retriever component in langchain-community langchain-community.retrievers.webresearch.WebResearchRetriever. The vulnerability arises because the Web Research Retriever does not restrict requests to remote internet...
Server-Side Request Forgery in gradio
A Server-Side Request Forgery SSRF vulnerability exists in the gradio-app/gradio and was discovered in version 4.21.0, specifically within the /queue/join endpoint and the saveurltocache function. The vulnerability arises when the path value, obtained from the user and expected to be a URL, is us...
PYSEC-2026-1413 Server-Side Request Forgery in gradio
A Server-Side Request Forgery SSRF vulnerability exists in the gradio-app/gradio and was discovered in version 4.21.0, specifically within the /queue/join endpoint and the saveurltocache function. The vulnerability arises when the path value, obtained from the user and expected to be a URL, is us...
accomate (>=1.0.4, <=2.0.0.6), aind-analysis-arch-result-access (>=0.3.0, <=1.2.0) +266 more potentially affected by CVE-2024-5629 via pymongo (>=4.0.0, <=4.6.2)
pymongo PYPI version =4.0.0, =1.0.4, =0.3.0, =0.2.0, =0.1.0, =0.0.27, =0.3.1, =0.1.19, =1.9.0, =0.0.1a0, =0.0.2, =0.4.0, =0.1.0, =0.3.1 and more Source cves: CVE-2024-5629 Source advisory: OSV:PYSEC-2026-1826...
Server-Side Request Forgery in langchain-community.retrievers.web_research.WebResearchRetriever
A Server-Side Request Forgery SSRF vulnerability exists in the Web Research Retriever component in langchain-community langchain-community.retrievers.webresearch.WebResearchRetriever. The vulnerability arises because the Web Research Retriever does not restrict requests to remote internet...
Apache Superset Incorrect Authorization vulnerability
An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request. This issue affects Apache Superset before 3.1.2.Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue...
PYSEC-2026-1153 Apache Superset Incorrect Authorization vulnerability
An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request. This issue affects Apache Superset before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue...
amundsen-metadata (>=1.0.18, <=2.5.4), amundsen-search (>=2.4.1, <=2.5.1) +8 more potentially affected by CVE-2024-34069 via werkzeug (0.15.3)
werkzeug PYPI version 0.15.3 is affected by a known vulnerability. The following packages have a transitive dependency on werkzeug and may be impacted: - amundsen-metadata =1.0.18, =2.4.1, =0.0.1, =0.0.6, =0.9.94, =0.0.1, =0.0.1, =0.0.1, =0.1.2 Source cves: CVE-2024-34069 Source advisory:...
PYSEC-2026-1144 Apache Airflow CNCF Kubernetes provider, Apache Airflow: Kubernetes configuration file saved without encryption in the Metadata and logged as plain text in the Triggerer service
Since version 5.2.0, when using deferrable mode with the path of a Kubernetes configuration file for authentication, the Airflow worker serializes this configuration file as a dictionary and sends it to the triggerer by storing it in metadata without any encryption. Additionally, if used with an...
Apache Airflow CNCF Kubernetes provider, Apache Airflow: Kubernetes configuration file saved without encryption in the Metadata and logged as plain text in the Triggerer service
Since version 5.2.0, when using deferrable mode with the path of a Kubernetes configuration file for authentication, the Airflow worker serializes this configuration file as a dictionary and sends it to the triggerer by storing it in metadata without any encryption. Additionally, if used with an...
PYSEC-2026-1190 Apache Superset Cross-site Scripting vulnerability
Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache...
Apache Superset Cross-site Scripting vulnerability
Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint.This issue affects Apache Supers...