605 matches found
CVE-2024-28000
CVE-2024-28000 CVE-2024-28000 Exploit for litespeed-cache =6.3 allows Privilege Escalation with creation of administrator account Build git clone https://github.com/JohnDoeAnonITA/CVE-2024-28000 cd CVE-2024-28000 go build . Disclaimer This PoC is for educational purposes only. Do not use this...
litespeed-cpanel-cve-2026-54420-fix
CVE-2026-54420 Mitigation Toolkit Defensive remediation, auditing, and verification toolkit for CVE-2026-54420 affecting LiteSpeed cPanel Plugin in shared hosting environments using CloudLinux / CageFS. ⚠️ Security Notice This repository is intended for system administrators, hosting providers, an...
CVE-2024-28000
CVE-2024-28000 PoC This repository contains tools for exploiting the CVE-2024-28000 vulnerability affecting WordPress sites using the LiteSpeed Cache plugin. The included scripts automate the detection of exposed debug.log files and the exploitation of a privilege escalation vulnerability that...
CVE-2026-54420-LiteSpeed-Symlink-Exploit
CVE-2026-54420 - LiteSpeed cPanel Plugin Symlink Privilege Escalation ⚠️ WARNING This code is ONLY for educational purposes and authorized security testing. Unauthorized use against systems without explicit permission is ILLEGAL. 📋 Description CVE-2026-54420 is a symlink privilege escalation...
CVE-2024-28000-Exploit-Lab
CVE-2024-28000 — WordPress LiteSpeed Cache Lab Authorized local-lab reproduction of CVE-2024-28000 , an unauthenticated privilege-escalation issue affecting vulnerable versions of the LiteSpeed Cache WordPress plugin. Scope: This repository documents testing performed only against an isolated,...
HTTP3-attacks
HTTP3-attacks CVE-2022-30592 Based on the work: E. Chatzoglou, V. Kouliaridis, G. Kambourakis, G. Karopoulos, and S. Gritzalis,"A hands-on gaze on HTTP/3 security through the lens of HTTP/2 and a public dataset", Computers & Security, p. 103051, 2022. The current repository serves the purpose of...
CVE-2024-44000
CVE-2024-44000 LiteSpeed Unauthorized Account Takeover PoC is now published. It was created for educational/research purposes only! Use it at your own risk!...
CVE-2024-28000
LiteSpeed Cache Privilege Escalation PoC - CVE-2024-28000 This repository contains a Proof of Concept PoC script for exploiting a privilege escalation vulnerability in the LiteSpeed Cache WordPress plugin. The vulnerability, identified as CVE-2024-28000 , allows unauthenticated users to gain...
CVE-2024-44000-LiteSpeed-Cache
Poc LiteSpeed Cache CVE-2024-44000 Exploit CVE-2024-44000 is a vulnerability in the LiteSpeed Cache plugin, a popular WordPress plugin. This vulnerability affects session management in LiteSpeed Cache, allowing attackers to gain unauthorized access to sensitive data. The script works in the...
CVE-2024-28000
CVE-2024-28000 - LiteSpeed Cache Privilege Escalation PoC !WARNING This repository is intended for educational and research purposes only. Use the provided PoC exclusively on systems you own or have explicit permission to test. Unauthorized access , exploitation, or misuse of any material in this...
CVE-2024-44000-LiteSpeed-Cache
CVE-2024-44000-LiteSpeed-Cache CVE-2024-44000 is a vulnerability in the LiteSpeed Cache plugin, a popular WordPress plugin. This vulnerability affects session management in LiteSpeed Cache, allowing attackers to gain unauthorized access to sensitive data. Preview How to use ? git clone...
litespeed-cpanel-cve-2026-54420-fix
CVE-2026-54420 Mitigation Toolkit Defensive remediation, auditing, and verification toolkit for CVE-2026-54420 affecting LiteSpeed cPanel Plugin in shared hosting environments using CloudLinux / CageFS. ⚠️ Security Notice This repository is intended for system administrators, hosting providers, an...
litespeed-cache-xss-poc
LiteSpeed Cache XSS PoC PoC for XSS vulnerability in the LiteSpeed Cache WordPress plugin allowing elevated privileges. This vulnerability was fixed in version 5.7.0.1 of the plugin, and was assigned CVE-2023-40000. According to the plugin's advanced view page, about 35% of users are still using ...
LiteSpeed Cache <= 5.7 - Unauthenticated Stored XSS
Improper Neutralization of Input During Web Page Generation 'Cross-site Scripting' vulnerability in LiteSpeed Technologies LiteSpeed Cache allows Stored XSS.This issue affects LiteSpeed Cache- from n/a through 5.7. id: CVE-2023-40000 info: name: LiteSpeed Cache = 5.7 - Unauthenticated Stored XSS...
WordPress LiteSpeed Cache - Unauthenticated Privilege Escalation to Admin
Incorrect Privilege Assignment vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Privilege Escalation.This issue affects LiteSpeed Cache: from 1.9 through 6.3.0.1. id: CVE-2024-28000 info: name: WordPress LiteSpeed Cache - Unauthenticated Privilege Escalation to Admin...
LiteSpeed Cache <= 6.5.0.2 - Stored XSS
LiteSpeed Technologies LiteSpeed Cache versions up to 6.5.0.2 contain a stored cross-site scripting caused by improper input neutralization during web page generation, letting attackers execute malicious scripts in victim browsers, exploit requires storing malicious input. id: CVE-2024-47374 info...
LiteSpeed Cache <= 6.4.1 - Sensitive Information Exposure
The LiteSpeed Cache plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 6.4.1 through the debug.log file that is publicly exposed. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the...
CVE-2023-40000
CVE-2023-40000 LiteSpeed Cache plugin for WordPress that could enable unauthenticated users to escalate their privileges How does this detection method work? This template looks at the following path: /wp-content/plugins/litespeed-cache/readme.txt Based on the Stable Tag listed, if the version is...
CVE-2026-48172---LiteSpeed-cPanel-Plugin-Version-Auditor
CVE-2026-48172 - LiteSpeed cPanel Plugin Vulnerability Auditor This repository contains a local security compliance and auditing tool designed to detect vulnerable installations of the LiteSpeed User-End cPanel Plugin affected by CVE-2026-48172. The goal of this project is to assist System...
CVE-2024-28000
LiteSpeed Cache Privilege Escalation Exp CVE-2024-28000Scan.py This script first identifies the version to determine if it is a vulnerable version, then attempts to confirm whether the log file exists. If it exists, it will try to send a request and then request the log file again to search for...