37 matches found
Arbitrary Command Injection
Overview librenms/librenms is a fully featured network monitoring system that provides a wealth of features and device support. Affected versions of this package are vulnerable to Arbitrary Command Injection in the deliverAlert process due to insufficient escaping of user-supplied input in the ex...
WS-2023-0340
Cross-site Scripting XSS - Stored in GitHub repository librenms/librenms prior to 22.11.0...
Cross site scripting
Cross-site Scripting XSS - Stored in GitHub repository librenms/librenms prior to 23.9.0...
CVE-2023-4981 Cross-site Scripting (XSS) - DOM in librenms/librenms
Cross-site Scripting XSS - DOM in GitHub repository librenms/librenms prior to 23.9.0...
CVE-2023-4980 Cross-site Scripting (XSS) - Generic in librenms/librenms
Cross-site Scripting XSS - Generic in GitHub repository librenms/librenms prior to 23.9.0...
CVE-2023-4978 Cross-site Scripting (XSS) - DOM in librenms/librenms
Cross-site Scripting XSS - DOM in GitHub repository librenms/librenms prior to 23.9.0...
CVE-2023-4978 Cross-site Scripting (XSS) - DOM in librenms/librenms
Cross-site Scripting XSS - DOM in GitHub repository librenms/librenms prior to 23.9.0...
CVE-2023-4979 Cross-site Scripting (XSS) - Reflected in librenms/librenms
Cross-site Scripting XSS - Reflected in GitHub repository librenms/librenms prior to 23.9.0...
CVE-2023-4979
Cross-site Scripting XSS - Reflected in GitHub repository librenms/librenms prior to 23.9.0...
CVE-2023-4979: Improper Neutralization of Input During Web Page Generation
Cross-site Scripting XSS - Reflected in GitHub repository librenms/librenms prior to 23.9.0...
PT-2023-31339
Name of the Vulnerable Software and Affected Versions librenms/librenms versions prior to 23.9.0 Description The issue concerns a code injection problem in the librenms/librenms GitHub repository. Recommendations For versions prior to 23.9.0, update to version 23.9.0 or later to resolve the issue...
CVE-2023-4347
Cross-site Scripting XSS - Reflected in GitHub repository librenms/librenms prior to 23.8.0...
CVE-2023-4347
CVE-2023-4347 is a reflected Cross-site Scripting (XSS) vulnerability in the LibreNMS project. The issue affects librenms/librenms versions prior to 23.8.0, arising from insufficient input filtering/escaping for user-controlled data, enabling arbitrary JavaScript in responses. Multiple connected ...
CVE-2022-4069
Cross-site Scripting XSS - Generic in GitHub repository librenms/librenms prior to 22.10.0...
CVE-2022-4067 Cross-site Scripting (XSS) - Stored in librenms/librenms
Cross-site Scripting XSS - Stored in GitHub repository librenms/librenms prior to 22.10.0...
CVE-2022-3516
Cross-site Scripting XSS - Stored in GitHub repository librenms/librenms prior to 22.10.0...
CVE-2022-3231
Cross-site Scripting XSS - Stored in GitHub repository librenms/librenms prior to 22.9.0...
CVE-2022-3231 Cross-site Scripting (XSS) - Stored in librenms/librenms
Cross-site Scripting XSS - Stored in GitHub repository librenms/librenms prior to 22.9.0...