Lucene search
+L

21 matches found

osv_cve
osv_cve
•added 2025/12/08 12:00 a.m.•16 views

CVE-2025-59391

A memory disclosure vulnerability exists in libcoap's OSCORE configuration parser in libcoap before release-4.3.5-patches. An out-of-bounds read may occur when parsing certain configuration values, allowing an attacker to infer or read memory beyond string boundaries in the .rodata section. This...

6.5CVSS6AI score
SaveExploits0References4
Cvelist
Cvelist
•added 2025/12/08 12:00 a.m.•44 views

CVE-2025-59391

A memory disclosure vulnerability exists in libcoap's OSCORE configuration parser in libcoap before release-4.3.5-patches. An out-of-bounds read may occur when parsing certain configuration values, allowing an attacker to infer or read memory beyond string boundaries in the .rodata section. This...

0.00261EPSS
SaveExploits0References2
osv_ubuntu
osv_ubuntu
•added 2025/11/24 2:15 p.m.•36 views

UBUNTU-CVE-2025-65495

Integer signedness error in tlsverifycallback in src/coapopenssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted TLS certificate that causes i2dX509 to return -1 and be misused as a malloc size parameter...

7.5CVSS5.8AI score0.00258EPSS
SaveExploits0References4
Positive Technologies
Positive Technologies
•added 2025/11/24 12:00 a.m.•15 views

PT-2025-47907

Name of the Vulnerable Software and Affected Versions libcoap version 4.3.5 Description A flaw exists in libcoap where a NULL pointer dereference in src/coap openssl.c can lead to a denial of service. This occurs when a crafted DTLS/TLS connection triggers the BIO get data function to return NULL...

7.5CVSS5.6AI score0.00405EPSS
SaveExploits0References28
osv_cve
osv_cve
•added 2025/11/24 12:00 a.m.•19 views

CVE-2025-65500

NULL pointer dereference in coapdtlsgeneratecookie in src/coapopenssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted DTLS handshake that triggers SSLgetSSLCTX to return NULL...

4.3CVSS5.6AI score0.00284EPSS
SaveExploits0References4
EUVD
EUVD
•added 2025/10/03 8:07 p.m.•20 views

EUVD-2023-34783

Malicious code in bioql PyPI...

7.5CVSS7.3AI score0.00754EPSS
SaveExploits1References2
Tenable Nessus
Tenable Nessus
•added 2025/08/31 12:00 a.m.•13 views

Linux Distros Unpatched Vulnerability : CVE-2025-50518

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A use-after-free vulnerability exists in the coapdeletepdulkd function within coappdu.c of the libcoap library. This issue occurs due to improper handling of...

9.8CVSS6.9AI score0.00462EPSS
SaveExploits0References2
SUSE CVE
SUSE CVE
•added 2025/08/15 11:22 p.m.•14 views

SUSE CVE-2025-50518

A use-after-free vulnerability exists in the coapdeletepdulkd function within coappdu.c of the libcoap library. This issue occurs due to improper handling of memory after the freeing of a PDU object, leading to potential memory corruption or the possibility of executing arbitrary code. NOTE: this...

9.8CVSS7AI score0.00462EPSS
SaveExploits0References3
CVE
CVE
•added 2025/08/14 12:00 a.m.•61 views

CVE-2025-50518

A use-after-free vulnerability exists in the coap_delete_pdu_lkd function within coap_pdu.c of the libcoap library. This flaw is caused by improper memory handling after a Packet Data Unit (PDU) object is freed, which can lead to memory corruption or the execution of arbitrary code . While the su...

9.8CVSS7AI score0.00462EPSS
SaveExploits0References4
Vulnrichment
Vulnrichment
•added 2025/08/14 12:00 a.m.•7 views

CVE-2025-50518

A use-after-free vulnerability exists in the coapdeletepdulkd function within coappdu.c of the libcoap library. This issue occurs due to improper handling of memory after the freeing of a PDU object, leading to potential memory corruption or the possibility of executing arbitrary code. NOTE: this...

7AI score0.00462EPSS
SaveExploits0References4
Cvelist
Cvelist
•added 2025/08/14 12:00 a.m.•29 views

CVE-2025-50518

A use-after-free vulnerability exists in the coapdeletepdulkd function within coappdu.c of the libcoap library. This issue occurs due to improper handling of memory after the freeing of a PDU object, leading to potential memory corruption or the possibility of executing arbitrary code. NOTE: this...

0.00462EPSS
SaveExploits0References4
Tenable Nessus
Tenable Nessus
•added 2025/03/05 12:00 a.m.•16 views

Linux Distros Unpatched Vulnerability : CVE-2023-30362

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Buffer Overflow vulnerability in coapsend function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive...

7.5CVSS7.2AI score0.00754EPSS
SaveExploits1References3
osv_debian
osv_debian
•added 2024/01/27 1:15 p.m.•16 views

DEBIAN-CVE-2024-0962

A vulnerability was found in obgm libcoap 4.3.4. It has been rated as critical. Affected by this issue is the function getsplitentry of the file src/coaposcore.c of the component Configuration File Handler. The manipulation leads to stack-based buffer overflow. The attack may be launched remotely...

7.8CVSS6.7AI score0.00757EPSS
SaveExploits1References1
osv_oesa
osv_oesa
•added 2023/09/28 11:06 a.m.•26 views

OESA-2023-1701 dsoftbus security update

Security Fixes: Buffer Overflow vulnerability in coapsend function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.CVE-2023-30362...

7.5CVSS6.7AI score0.00754EPSS
SaveExploits1References2
osv_cve
osv_cve
•added 2023/06/23 12:15 p.m.•17 views

CVE-2023-30362

Buffer Overflow vulnerability in coapsend function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu...

7.5CVSS6.2AI score0.00754EPSS
SaveExploits1References2
UbuntuCve
UbuntuCve
•added 2023/06/23 12:15 p.m.•25 views

CVE-2023-30362

Buffer Overflow vulnerability in coapsend function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu...

7.5CVSS7.1AI score0.00754EPSS
SaveExploits1References3
osv_ubuntu
osv_ubuntu
•added 2023/06/23 12:15 p.m.•22 views

UBUNTU-CVE-2023-30362

Buffer Overflow vulnerability in coapsend function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu...

7.5CVSS5.8AI score0.00754EPSS
SaveExploits1References4
CVE
CVE
•added 2023/06/23 12:00 a.m.•94 views

CVE-2023-30362

The CVE-2023-30362 vulnerability affects the libcoap library, specifically the coap_send function in version 4.3.1-103-g52cfd56. A Buffer Overflow in this function allows attackers to obtain sensitive information via malformed PDUs. The issue is fixed in version 4.3.1-120-ge242200. Several adviso...

7.5CVSS7.3AI score0.00754EPSS
SaveExploits1References2Affected Software1
Vulnrichment
Vulnrichment
•added 2023/06/23 12:00 a.m.•14 views

CVE-2023-30362

Buffer Overflow vulnerability in coapsend function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu...

6.3AI score0.00754EPSS
SaveExploits1References2
Debian CVE
Debian CVE
•added 2023/06/23 12:00 a.m.•67 views

CVE-2023-30362

Buffer Overflow vulnerability in coapsend function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu...

7.5CVSS7.3AI score0.00754EPSS
SaveExploits1
Rows per page
Query Builder