1022 matches found
CVE-2020-4038: Improper Neutralization of Input During Web Page Generation
GraphQL Playground graphql-playground-html NPM package before version 1.6.22 have a severe XSS Reflection attack vulnerability. All unsanitized user input passed into renderPlaygroundPage method could trigger this vulnerability. This has been patched in graphql-playground-html version 1.6.22. Not...
PT-2020-17846
Name of the Vulnerable Software and Affected Versions graphql-playground-html versions prior to 1.6.22 graphql-playground-middleware-express versions prior to 1.7.16 graphql-playground-middleware-koa versions prior to 1.6.15 graphql-playground-middleware-lambda versions prior to 1.7.17...
Information Exposure
Overview Versions of apollo-server-lambda prior to 2.14.2 are vulnerable to Information Exposure. The package does not properly enforce validation rules when creating subscription servers, which includes a NoInstrospection rule for the Websocket. This leaks the GraphQL schema types, their relatio...
@forecastr/api (>=0.0.4, <=0.0.5), @hammerframework/api (>=0.0.1-alpha.13, <=0.0.1-alpha.14) +8 more potentially affected by unknown CVE via apollo-server-lambda (>=2.0.0-xrc.11, <=2.11.0)
apollo-server-lambda NPM version =2.0.0-xrc.11, =0.0.4, =0.0.1-alpha.13, =0.0.1-alpha.12, =1.1.0, =0.0.1-alpha.27, =1.0.0, =1.2.1 - photos-production-api 1.0.0 - redwood-express-api 0.8.1 Source cves: unknown CVE Source advisory: OSV:GHSA-W42G-7VFC-XF37...
@forecastr/api (>=0.0.4, <=0.0.5), @hammerframework/api (>=0.0.1-alpha.13, <=0.0.1-alpha.14) +8 more potentially affected by unknown CVE via apollo-server-lambda (>=2.0.0-xrc.11, <=2.11.0)
apollo-server-lambda NPM version =2.0.0-xrc.11, =0.0.4, =0.0.1-alpha.13, =0.0.1-alpha.12, =1.1.0, =0.0.1-alpha.27, =1.0.0, =1.2.1 - photos-production-api 1.0.0 - redwood-express-api 0.8.1 Source cves: unknown CVE Source advisory: GHSA-W42G-7VFC-XF37...
lambda-tdk.ru Cross Site Scripting vulnerability
Open Bug Bounty ID: OBB-1154958 Security Researcher geeknik Helped patch 8815 vulnerabilities Received 8 Coordinated Disclosure badges Received 20 recommendations , a holder of 8 badges for responsible and coordinated disclosure, found a security vulnerability affecting lambda-tdk.ru website and...
@xapp/stentor (>=1.13.9, <=1.15.0) potentially affected by CVE-2019-10777 via aws-lambda (>=1.0.0, <=1.0.4)
aws-lambda NPM version =1.0.0, =1.13.9, =1.15.0 Source cves: CVE-2019-10777 Source advisory: GHSA-934X-72XH-5HRG...
@xapp/stentor (>=1.13.9, <=1.15.0) potentially affected by CVE-2019-10777 via aws-lambda (>=1.0.0, <=1.0.4)
aws-lambda NPM version =1.0.0, =1.13.9, =1.15.0 Source cves: CVE-2019-10777 Source advisory: OSV:GHSA-934X-72XH-5HRG...
GHSA-934X-72XH-5HRG OS command injection in aws-lambda
In aws-lambda versions prior to version 1.0.5, the "config.FunctioName" is used to construct the argument used within the "exec" function without any sanitization. It is possible for a user to inject arbitrary commands to the "zipCmd" used within "config.FunctionName"...
OS command injection in aws-lambda
In aws-lambda versions prior to version 1.0.5, the "config.FunctioName" is used to construct the argument used within the "exec" function without any sanitization. It is possible for a user to inject arbitrary commands to the "zipCmd" used within "config.FunctionName"...
Automating API Security in the Cloud
These days, the most common way for services to communicate and transfer data is by using APIs. However, broken, exposed, or hacked APIs are the cause of some of the latest major data breaches, as they have the potential to expose sensitive data for public consumption. Securing your APIs is...
aws-lambda operating system command injection vulnerability
AWS-Lambda is a computing service that runs code without pre-configured or managed servers. An operating system command injection vulnerability exists in versions of aws-lambda prior to 1.0.5, which stems from a program that fails to perform any cleanup operations before using config.FunctioName ...
Arbitrary Command Injection
aws-lambda is vulnerable to arbitrary command injection. The vulnerability exists due to the lack of sanitization on the value of config.FunctionName, allowing injection payloads to reach the exec function...
CVE-2019-10777
In aws-lambda versions prior to version 1.0.5, the "config.FunctioName" is used to construct the argument used within the "exec" function without any sanitization. It is possible for a user to inject arbitrary commands to the "zipCmd" used within "config.FunctionName"...
CVE-2019-10777
In aws-lambda versions prior to version 1.0.5, the "config.FunctioName" is used to construct the argument used within the "exec" function without any sanitization. It is possible for a user to inject arbitrary commands to the "zipCmd" used within "config.FunctionName"...
Design/Logic Flaw
In aws-lambda versions prior to version 1.0.5, the "config.FunctioName" is used to construct the argument used within the "exec" function without any sanitization. It is possible for a user to inject arbitrary commands to the "zipCmd" used within "config.FunctionName"...
CVE-2019-10777
In aws-lambda versions prior to version 1.0.5, the "config.FunctioName" is used to construct the argument used within the "exec" function without any sanitization. It is possible for a user to inject arbitrary commands to the "zipCmd" used within "config.FunctionName"...
CVE-2019-10777
In aws-lambda versions prior to version 1.0.5, the "config.FunctioName" is used to construct the argument used within the "exec" function without any sanitization. It is possible for a user to inject arbitrary commands to the "zipCmd" used within "config.FunctionName"...
CVE-2019-10777
CVE-2019-10777 affects aws-lambda prior to v1.0.5. The vulnerability arises because config.FunctioName is used to assemble the argument for exec without sanitization, enabling an attacker to inject arbitrary commands into the zipCmd executed via config.FunctionName. Impact ranges from partial to ...
@bitcoin-miles/base-service (>=1.0.3, <=1.1.4), @botsbotsbots/api (>=0.1.0-latest.30e51283, <=0.1.0-latest.d90c50ea) +96 more potentially affected by CVE-2019-10777 via aws-lambda (>=0.1.2, <=1.0.4)
aws-lambda NPM version =0.1.2, =1.0.3, =0.1.0-latest.30e51283, =1.0.0, =0.5.0, =0.1.0, =0.0.1, =1.0.0-alpha.30, =1.0.0-alpha.12, =1.2.0-alpha.1, =1.0.0, =0.0.1, =1.7.0, =3.0.0 - @graphcool/lambda-helpers 0.2.2 and more Source cves: CVE-2019-10777 Source advisory: MEND:CVE-2019-10777...