1071 matches found
better-lambda-deploy (>=0.2.2, <=0.5.9) potentially affected by CVE-2025-3047 via aws-sam-cli (0.41.0)
aws-sam-cli PYPI version 0.41.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - better-lambda-deploy =0.2.2, =0.5.9 Source cves: CVE-2025-3047 Source advisory: OSV:GHSA-PX37-JPQX-97Q9...
better-lambda-deploy (>=0.6.0, <=0.6.9) potentially affected by CVE-2025-3047 via aws-sam-cli (0.53.0)
aws-sam-cli PYPI version 0.53.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - better-lambda-deploy =0.6.0, =0.6.9 Source cves: CVE-2025-3047 Source advisory: OSV:GHSA-PX37-JPQX-97Q9...
better-lambda-deploy (>=0.7.0, <=0.8.5), localambda (0.0.1) potentially affected by CVE-2025-3047 via aws-sam-cli (>=1.12.0, <=1.38.1)
aws-sam-cli PYPI version =1.12.0, =0.7.0, =0.8.5 - localambda 0.0.1 Source cves: CVE-2025-3047 Source advisory: OSV:GHSA-PX37-JPQX-97Q9...
better-lambda-deploy (>=0.7.0, <=0.8.5), localambda (0.0.1) potentially affected by CVE-2025-3047 via aws-sam-cli (>=1.12.0, <=1.38.1)
aws-sam-cli PYPI version =1.12.0, =0.7.0, =0.8.5 - localambda 0.0.1 Source cves: CVE-2025-3047 Source advisory: GHSA-PX37-JPQX-97Q9...
better-lambda-deploy (>=0.0.4, <=0.8.5), localambda (0.0.1) +1 more potentially affected by CVE-2025-3048 via aws-sam-cli (>=0.17.0, <=1.38.1)
aws-sam-cli PYPI version =0.17.0, =0.0.4, =0.0.7, =0.0.12 Source cves: CVE-2025-3048 Source advisory: MEND:CVE-2025-3048...
better-lambda-deploy (>=0.0.4, <=0.8.5), localambda (0.0.1) +1 more potentially affected by CVE-2025-3047 via aws-sam-cli (>=0.17.0, <=1.38.1)
aws-sam-cli PYPI version =0.17.0, =0.0.4, =0.0.7, =0.0.12 Source cves: CVE-2025-3047 Source advisory: MEND:CVE-2025-3047...
io.jenkins.plugins:aws-lambda-cloud (>=0.3, <=0.4), org.jenkins-ci.main:jenkins-test-harness (1.635) +2 more potentially affected by CVE-2025-27625 via org.jenkins-ci.main:jenkins-core (1.635)
org.jenkins-ci.main:jenkins-core MAVEN version 1.635 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - io.jenkins.plugins:aws-lambda-cloud =0.3, =0.4 - org.jenkins-ci.main:jenkins-test-harness 1.635...
io.jenkins.plugins:aws-lambda-cloud (>=0.3, <=0.4), org.jenkins-ci.main:jenkins-test-harness (1.635) +2 more potentially affected by CVE-2025-27622 via org.jenkins-ci.main:jenkins-core (1.635)
org.jenkins-ci.main:jenkins-core MAVEN version 1.635 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - io.jenkins.plugins:aws-lambda-cloud =0.3, =0.4 - org.jenkins-ci.main:jenkins-test-harness 1.635...
io.jenkins.plugins:aws-lambda-cloud (>=0.3, <=0.4), org.jenkins-ci.main:jenkins-test-harness (1.635) +2 more potentially affected by CVE-2025-27623 via org.jenkins-ci.main:jenkins-core (1.635)
org.jenkins-ci.main:jenkins-core MAVEN version 1.635 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - io.jenkins.plugins:aws-lambda-cloud =0.3, =0.4 - org.jenkins-ci.main:jenkins-test-harness 1.635...
com.xti.jenkins.plugins:aws-lambda-jenkins-plugin (0.0.1), org.jenkins-ci.main:jenkins-test-harness (1.599) +7 more potentially affected by CVE-2025-27624 via org.jenkins-ci.main:jenkins-core (1.599)
org.jenkins-ci.main:jenkins-core MAVEN version 1.599 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.xti.jenkins.plugins:aws-lambda-jenkins-plugin 0.0.1 -...
io.quarkus:quarkus-amazon-lambda (0.13.0), io.quarkus:quarkus-amazon-lambda-deployment (0.13.0) +8 more potentially affected by CVE-2025-1634 via io.quarkus:quarkus-resteasy (0.13.0)
io.quarkus:quarkus-resteasy MAVEN version 0.13.0 is affected by a known vulnerability. The following packages have a transitive dependency on io.quarkus:quarkus-resteasy and may be impacted: - io.quarkus:quarkus-amazon-lambda 0.13.0 - io.quarkus:quarkus-amazon-lambda-deployment 0.13.0 -...
io.quarkus:quarkus-amazon-lambda (0.13.1), io.quarkus:quarkus-amazon-lambda-deployment (0.13.1) +8 more potentially affected by CVE-2025-1634 via io.quarkus:quarkus-resteasy (0.13.1)
io.quarkus:quarkus-resteasy MAVEN version 0.13.1 is affected by a known vulnerability. The following packages have a transitive dependency on io.quarkus:quarkus-resteasy and may be impacted: - io.quarkus:quarkus-amazon-lambda 0.13.1 - io.quarkus:quarkus-amazon-lambda-deployment 0.13.1 -...
@mrmtech/splice-lambda (>=0.1.0, <=6.4.0) potentially affected by unknown CVE via @sentry/aws-serverless (>=8.26.0, <=8.30.0)
@sentry/aws-serverless NPM version =8.26.0, =0.1.0, =6.4.0 Source cves: unknown CVE Source advisory: OSV:GHSA-R5W7-F542-Q2J4...
@mrmtech/splice-lambda (>=0.1.0, <=6.4.0) potentially affected by unknown CVE via @sentry/aws-serverless (>=8.26.0, <=8.30.0)
@sentry/aws-serverless NPM version =8.26.0, =0.1.0, =6.4.0 Source cves: unknown CVE Source advisory: GHSA-R5W7-F542-Q2J4...
Malware in lambda-sns-dynatrace-sdk
Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outsid...
Malware in lambda-demo
Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outsid...
AWS VDP: A potential risk in the aws-lambda-ecs-run-task which can be used to privilege escalation.
The aws-lambda-ecs-run-task application created a function with a role that had excessive permissions, including the AdministratorAccess policy. This allowed for potential privilege escalation by an attacker...
OPENSUSE-SU-2024:0384-1 Security update for zabbix
This update for zabbix fixes the following issues: Zabbix was updated to 6.0.33: - this version fixes CVE-2024-36461 and CVE-2024-22114 - New Features and Improvements + ZBXNEXT-9000 Changed query table for ASM disk group metrics in Oracle Database plugin and Oracle by ODBC template Agent Templat...
The Future of Serverless Security in 2025: From Logs to Runtime Protection
Serverless environments, leveraging services such as AWS Lambda, offer incredible benefits in terms of scalability, efficiency, and reduced operational overhead. However, securing these environments is extremely challenging. The core of current serverless security practices often revolves around...
com.cloudera.oryx:oryx-lambda-serving (2.4.0), org.apache.tomcat:tomcat-catalina-ha (8.5.14) +7 more potentially affected by CVE-2024-52316 via org.apache.tomcat:tomcat-catalina (8.5.14)
org.apache.tomcat:tomcat-catalina MAVEN version 8.5.14 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.tomcat:tomcat-catalina and may be impacted: - com.cloudera.oryx:oryx-lambda-serving 2.4.0 - org.apache.tomcat:tomcat-catalina-ha 8.5.14 -...