498 matches found
CLEANSTART-2025-SF33121 Security fix for CVE-2020-15250 applied in: junit 4.13.1-r0
Security vulnerability affects the junit package. This issue is resolved in later releases. See references for vulnerability details...
PT-2026-100036
Security vulnerability affects the junit package. This issue is resolved in later releases. See references for vulnerability details...
Linux Distros Unpatched Vulnerability : CVE-2026-55847
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Allure 2 is the version 2.x branch of Allure Report, a multi-language test reporting tool. Prior to 2.39.0, the ansi.js helper at...
CVE-2026-55847
Allure 2 (a multi-language test reporting tool) is vulnerable to stored XSS in the ansi.js Handlebars helper within allure-generator. Prior to 2.39.0 , attacker-controlled statusMessage and statusTrace values (sourced from JUnit XML, TRX, xUnit, xctest, or Allure1/2 plugins) are passed through th...
CVE-2026-55847 Allure: Stored XSS via unescaped ANSI helper in Allure report status message/trace rendering
Allure 2 is the version 2.x branch of Allure Report, a multi-language test reporting tool. Prior to 2.39.0, the ansi.js helper at allure-generator/src/main/javascript/helpers/ansi.js passes attacker-influenced statusMessage and statusTrace values through AnsiToHtml without HTML escaping and wraps...
Astra Linux – Vulnerability in junit4
In JUnit 4, versions starting from 4.7 and before 4.13.1, the TemporaryFolder test rule contains a local information disclosure vulnerability. On Unix-like systems, the system’s temporary directory is shared among all users on that system. As a result, when files and directories are written to th...
org.eclipse.hawkbit:hawkbit-dmf-rabbitmq-test (1.1.0), org.springframework.amqp:spring-rabbit-test (4.1.0) +1 more potentially affected by CVE-2026-59271 via org.springframework.amqp:spring-rabbit-junit (4.1.0)
org.springframework.amqp:spring-rabbit-junit MAVEN version 4.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework.amqp:spring-rabbit-junit and may be impacted: - org.eclipse.hawkbit:hawkbit-dmf-rabbitmq-test 1.1.0 -...
org.springframework.amqp:spring-rabbit-test (>=4.0.0, <=4.0.4), org.springframework.boot:spring-boot-starter-amqp-test (>=4.0.0, <=4.0.7) potentially affected by CVE-2026-59271 via org.springframework.amqp:spring-rabbit-junit (>=4.0.0, <=4.0.4)
org.springframework.amqp:spring-rabbit-junit MAVEN version =4.0.0, =4.0.0, =4.0.0, =4.0.7 Source cves: CVE-2026-59271 Source advisory: MEND:CVE-2026-59271...
org.springframework.amqp:spring-rabbit-test (>=4.0.0-m1, <=4.0.4), org.springframework.boot:spring-boot-starter-amqp-test (>=4.0.0-rc2, <=4.0.7) potentially affected by CVE-2026-59271 via org.springframework.amqp:spring-rabbit-junit (>=4.0.0-m1, <=4.0.4)
org.springframework.amqp:spring-rabbit-junit MAVEN version =4.0.0-m1, =4.0.0-m1, =4.0.0-rc2, =4.0.7 Source cves: CVE-2026-59271 Source advisory: SNYK:JAVA-ORGSPRINGFRAMEWORKAMQP-19267402...
org.eclipse.hawkbit:hawkbit-dmf-rabbitmq-test (1.1.0), org.springframework.amqp:spring-rabbit-test (4.1.0) +1 more potentially affected by CVE-2026-59271 via org.springframework.amqp:spring-rabbit-junit (4.1.0)
org.springframework.amqp:spring-rabbit-junit MAVEN version 4.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework.amqp:spring-rabbit-junit and may be impacted: - org.eclipse.hawkbit:hawkbit-dmf-rabbitmq-test 1.1.0 -...
Insertion of Sensitive Information into Log File
Overview Affected versions of this package are vulnerable to Insertion of Sensitive Information into Log File via the BrokerNotAliveException message when the RabbitMQ management aliveness check fails. An attacker can obtain sensitive credentials by accessing exception messages that are logged,...
MAL-2026-11621 Malicious code in @onereach/pnpm-audit-junit (npm)
npm/@onereach/pnpm-audit-junit is affected by the large-scale, self-propagating npm supply-chain worm of 2026-08-04 the "Shai-Hulud: Here We Go Again" wave — the same campaign that began with the compromise of the keyv and cacheable maintainer account. The listed versions were trojanized and...
Malicious code in @onereach/pnpm-audit-junit (npm)
npm/@onereach/pnpm-audit-junit is affected by the large-scale, self-propagating npm supply-chain worm of 2026-08-04 the "Shai-Hulud: Here We Go Again" wave — the same campaign that began with the compromise of the keyv and cacheable maintainer account. The listed versions were trojanized and...
CLSA-2026-1779151613 TuxCare security update for junit:junit (1 CVE)
TuxCare rebuilt junit:junit to address 1 CVE. Fixed in 4.13-tuxcare.1...
CLEANSTART-2026-WE99006 Security fixes in junit 4.13.1-r0
Package junit version 4.13.1-r0 fixes 1 vulnerabilities: CVE-2020-15250...
javapackages-tools:201801 security update
An update is available for module.apache-commons-parent, module.maven-plugins-pom, xmlunit, felix-utils, module.ant, maven-common-artifact-filters, module.maven-assembly-plugin, module.maven-archiver, module.jvnet-parent, module.xml-commons-apis, module.jboss-parent, module.felix-osgi-compendium,...
org.jenkins-ci.plugins:extreme-notification (>=1.5, <=1.6), org.jenkins-ci.plugins:junit-realtime-test-reporter (>=0.5, <=0.6) +1 more potentially affected by CVE-2026-57281 via org.jenkins-ci.plugins:script-security (1.33)
org.jenkins-ci.plugins:script-security MAVEN version 1.33 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - org.jenkins-ci.plugins:extreme-notification =1.5, =0.5, =3.4.0-beta-1, =3.5.12 Sourc...
io.jenkins.plugins:tricentis-ci (>=1.0, <=1.3), org.jenkins-ci.plugins.workflow:workflow-cps (>=2.37, <=2.38) +3 more potentially affected by CVE-2026-57281 via org.jenkins-ci.plugins:script-security (1.30)
org.jenkins-ci.plugins:script-security MAVEN version 1.30 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - io.jenkins.plugins:tricentis-ci =1.0, =2.37, =1.22-beta-1, =1.10, =1.5, =1.6 Source...
io.jenkins.plugins:tricentis-ci (>=1.0, <=1.3), org.jenkins-ci.plugins.workflow:workflow-cps (>=2.37, <=2.38) +3 more potentially affected by CVE-2026-57280 via org.jenkins-ci.plugins:script-security (1.30)
org.jenkins-ci.plugins:script-security MAVEN version 1.30 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - io.jenkins.plugins:tricentis-ci =1.0, =2.37, =1.22-beta-1, =1.10, =1.5, =1.6 Source...
org.jenkins-ci.plugins:extreme-notification (>=1.5, <=1.6), org.jenkins-ci.plugins:junit-realtime-test-reporter (>=0.5, <=0.6) +1 more potentially affected by CVE-2026-57280 via org.jenkins-ci.plugins:script-security (1.33)
org.jenkins-ci.plugins:script-security MAVEN version 1.33 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - org.jenkins-ci.plugins:extreme-notification =1.5, =0.5, =3.4.0-beta-1, =3.5.12 Sourc...