75889 matches found
retire.js v5.5.0
Retire.js What you require you must also retire There is a vast ecosystem of JavaScript libraries available for both web and Node.js applications. While these libraries significantly accelerate development, they also require ongoing maintenance to ensure security vulnerabilities are addressed...
EUVD-2026-63998
Jet Admin allows an authenticated attacker to inject JavaScript via the sign-in page's scripts and styles option. Injected script is executed in the context of any visiting user's domain...
CVE-2026-75933
Jet Admin is vulnerable to a stored cross-site scripting (XSS) flaw in the sign-in page's scripts and styles option. An authenticated attacker can inject arbitrary JavaScript that executes in the context of any visiting user's domain, enabling session hijacking, data exfiltration, or further comp...
CVE-2026-75933 Jet Admin Stored XSS
Jet Admin allows an authenticated attacker to inject JavaScript via the sign-in page's scripts and styles option. Injected script is executed in the context of any visiting user's domain...
Discourse: XSS
Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, an unauthenticated attacker could send a single request with a crafted colorschemeid or darkschemeid cookie to inject arbitrary HTML into a Discourse page. Because the cookie value was rendered...
MSC-2026-11393
Malicious cryptocurrency wallet-drainer disguised as a JavaScript utility. index.js auto-executes on require/import, reads the host .env for PRIVATEKEY/SECRET/MNEMONIC values, and attempts to transfer funds to hardcoded attacker-controlled wallets across 26 chains via ethers.Wallet.sendTransactio...
MSC-2026-11394
Malicious cryptocurrency wallet-drainer disguised as a JavaScript utility. index.js auto-executes on require/import, reads the host .env for PRIVATEKEY/SECRET/MNEMONIC values, and attempts to transfer funds to hardcoded attacker-controlled wallets across 26 chains via ethers.Wallet.sendTransactio...
CVE-2026-77682
A code injection vulnerability exists in Epiphany when the user invokes form autofill from the context menu on a page containing a malicious HTML form. In embed/web-process-extension/resources/js/ephyautofill.js, getSelector builds a CSS selector by directly interpolating an element's id attribut...
CVE-2026-18409 WPForms Pro <= 2.0.0.2 - Unauthenticated Stored Cross-Site Scripting via Single Line Text and Paragraph Text Field Values
The WPForms Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Single Line Text and Paragraph Text Field Values in all versions up to, and including, 2.0.0.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to...
SUSE CVE-2026-74936
Use-after-free in the JavaScript: WebAssembly component. This vulnerability was fixed in Firefox 154, Firefox ESR 140.14, Firefox ESR 153.1, Thunderbird 154, Thunderbird 140.14, and Thunderbird 153.1...
SUSE CVE-2026-74937
Use-after-free in the JavaScript: GC component. This vulnerability was fixed in Firefox 154, Firefox ESR 153.1, Thunderbird 154, and Thunderbird 153.1...
SUSE CVE-2026-74938
Mitigation bypass in the JavaScript: GC component. This vulnerability was fixed in Firefox 154, Firefox ESR 153.1, Thunderbird 154, and Thunderbird 153.1...
SUSE CVE-2026-74976
JIT miscompilation in the JavaScript Engine: JIT component. This vulnerability was fixed in Firefox 154, Firefox ESR 140.14, Firefox ESR 153.1, Thunderbird 154, Thunderbird 140.14, and Thunderbird 153.1...
SUSE CVE-2026-74984
Race condition in the JavaScript Engine component. This vulnerability was fixed in Firefox 154, Firefox ESR 153.1, Thunderbird 154, and Thunderbird 153.1...
PT-2026-79467
Name of the Vulnerable Software and Affected Versions Esri Portal for ArcGIS versions prior to 11.6 Description A stored cross site scripting issue exists that allows a remote, privileged attacker to inject malicious code. This could lead to the execution of arbitrary JavaScript within the browse...
CVE-2026-69232: Improper Neutralization of Input During Web Page Generation
There is a stored cross site scripting issue in Esri Portal for ArcGIS versions 11.5 and prior that may allow a remote, privileged attacker to inject malicious code that could potentially execute arbitrary JavaScript in a victim’s browser. Users working with ArcGIS Enterprise 11.1, 11.3, 11.5 are...
CVE-2026-77811: Improper Neutralization of Input During Web Page Generation
Improper input validation in the dashboards-observability plugin in OpenSearch Dashboards allows a remote authenticated user with write permissions to OpenSearch Dashboards saved objects to execute arbitrary JavaScript in the context of other users' browser sessions by uploading a saved asset wit...
Zabbix 7.0.x < 7.0.28 / 7.4.x < 7.4.12 OOB Read (ZBX-28073)
The version of Zabbix Server installed on the remote host is 7.0.x prior to 7.0.28, or 7.4.x prior to 7.4.12. It is, therefore, affected by an out-of-bounds read vulnerability: - A Zabbix administrator is able to read out of bounds memory by utilizing a flaw in script item/preprocessing JavaScrip...
PT-2026-79469
Name of the Vulnerable Software and Affected Versions Esri Portal for ArcGIS versions prior to 12.2 Description A stored cross site scripting issue exists that allows a remote, privileged attacker to inject malicious code. This could lead to the execution of arbitrary JavaScript within the browse...
PT-2026-79485
Name of the Vulnerable Software and Affected Versions Esri Portal for ArcGIS versions prior to 11.6 Description A reflected cross site scripting issue exists that allows a remote, unauthenticated attacker to create a crafted link. If a victim clicks this link, arbitrary JavaScript code may be...