67785 matches found
[SECURITY] Fedora 44 Update: ongres-scram-3.3-1.fc44
This is a Java implementation of SCRAM Salted Challenge Response Authentication Mechanism which is part of the family of Simple Authentication and Security Layer SASL, RFC 4422 authentication mechanisms. It is described as part of RFC 5802 and RFC7677...
[SECURITY] Fedora 44 Update: postgresql-jdbc-42.7.8-6.fc44
PostgreSQL is an advanced Object-Relational database management system. The postgresql-jdbc package includes the .jar files needed for Java programs to access a PostgreSQL database...
SUSE SLES12 Security Update : java-1_8_0-ibm (SUSE-SU-2026:2453-1)
The remote SUSE Linux SLES12 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2026:2453-1 advisory. This update for java-180-ibm fixes the following issues - CVE-2026-22007: APIs in the specified component can lead to an unauthorized read acce...
ghost-bits-toolkit
Ghost Bits Toolkit Java Ghost Bits Vulnerability Detection an...
CedarJava has policy injection vulnerability
Summary CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. Under certain circumstances, improper input handling could allow policy injection. Impact Cedar-expression injection via unescaped toCedarExpr The toCedarExpr metho...
com.primust:primust-cedar (>=1.0.2, <=1.0.3), io.github.devnico:cedar4s-client_2.13 (>=0.1.0, <=0.1.6) +12 more potentially affected by CVE-2026-55773 via com.cedarpolicy:cedar-java (>=4.3.0, <=4.8.0)
com.cedarpolicy:cedar-java MAVEN version =4.3.0, =1.0.2, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.6 Source cves: CVE-2026-55773 Source advisory: OSV:GHSA-QMCH-V2Q9-WG4P...
com.primust:primust-cedar (>=1.0.2, <=1.0.3), io.github.devnico:cedar4s-client_2.13 (>=0.1.0, <=0.1.6) +12 more potentially affected by CVE-2026-55773 via com.cedarpolicy:cedar-java (>=4.3.0, <=4.8.0)
com.cedarpolicy:cedar-java MAVEN version =4.3.0, =1.0.2, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.6 Source cves: CVE-2026-55773 Source advisory: GHSA-QMCH-V2Q9-WG4P...
com.primust:primust-cedar (>=1.0.2, <=1.0.3), io.github.devnico:cedar4s-client_2.13 (>=0.1.0, <=0.1.6) +12 more potentially affected by CVE-2026-55773 via com.cedarpolicy:cedar-java (>=4.3.0, <=4.8.0)
com.cedarpolicy:cedar-java MAVEN version =4.3.0, =1.0.2, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.6 Source cves: CVE-2026-55773 Source advisory: SNYK:JAVA-COMCEDARPOLICY-17732795...
Arbitrary Code Injection
Overview Affected versions of this package are vulnerable to Arbitrary Code Injection via the toCedarExpr method, which does not escape special characters when converting values to source code. An attacker can inject arbitrary expressions by supplying specially crafted input, potentially altering...
com.primust:primust-cedar (>=1.0.2, <=1.0.3), io.github.devnico:cedar4s-client_2.13 (>=0.1.0, <=0.1.6) +12 more potentially affected by CVE-2026-55772 via com.cedarpolicy:cedar-java (>=4.3.0, <=4.8.0)
com.cedarpolicy:cedar-java MAVEN version =4.3.0, =1.0.2, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.6 Source cves: CVE-2026-55772 Source advisory: SNYK:JAVA-COMCEDARPOLICY-17732794...
com.primust:primust-cedar (>=1.0.2, <=1.0.3), io.github.devnico:cedar4s-client_2.13 (>=0.1.0, <=0.1.6) +12 more potentially affected by CVE-2026-55772 via com.cedarpolicy:cedar-java (>=4.3.0, <=4.8.0)
com.cedarpolicy:cedar-java MAVEN version =4.3.0, =1.0.2, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.6 Source cves: CVE-2026-55772 Source advisory: GHSA-93G4-M6XV-CMVR...
Access of Resource Using Incompatible Type ('Type Confusion')
Overview Affected versions of this package are vulnerable to Access of Resource Using Incompatible Type 'Type Confusion' through improper handling of reserved keys in the JSON protocol when serializing CedarMap. An attacker can cause unauthorized access or manipulation of data by supplying...
CedarJava has type confusion vulnerability
Summary CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. Under certain circumstances, improper input handling could allow type confusion across the Java-Rust FFI boundary. Impact Record-to-Entity type confusion across the...
GHSA-93G4-M6XV-CMVR CedarJava has type confusion vulnerability
Summary CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. Under certain circumstances, improper input handling could allow type confusion across the Java-Rust FFI boundary. Impact Record-to-Entity type confusion across the...
com.primust:primust-cedar (>=1.0.2, <=1.0.3), io.github.devnico:cedar4s-client_2.13 (>=0.1.0, <=0.1.6) +12 more potentially affected by CVE-2026-55772 via com.cedarpolicy:cedar-java (>=4.3.0, <=4.8.0)
com.cedarpolicy:cedar-java MAVEN version =4.3.0, =1.0.2, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.6 Source cves: CVE-2026-55772 Source advisory: OSV:GHSA-93G4-M6XV-CMVR...
Security Bulletin: Multiple vulnerabilities in IBM Java SDK affect IBM Tivoli System Automation Application Manager (CVE-2026-22016, CVE-2026-22021, CVE-2026-22013, CVE-2026-22018, CVE-2026-34268, CVE-2026-22007)
Summary There are multiple vulnerabilities in IBM SDK Java Technology Edition used by IBM Tivoli System Automation Application Manager. Vulnerability Details CVEID:CVE-2026-22016 DESCRIPTION: Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protoco...
Security Bulletin: Multiple vulnerabilities in IBM Java SDK affect IBM Tivoli System Automation for Multiplatforms (CVE-2026-22016, CVE-2026-22021, CVE-2026-22013, CVE-2026-22018, CVE-2026-34268, CVE-2026-22007)
Summary There are multiple vulnerabilities in IBM SDK Java Technology Edition, Version 8 used by IBM Tivoli System Automation for Multiplatforms. Vulnerability Details CVEID:CVE-2026-22016 DESCRIPTION: Easily exploitable vulnerability allows unauthenticated attacker with network access via multip...
Security Bulletin: Multiple vulnerabilities affect IBM Db2® on Cloud Pak for Data, and Db2 Warehouse on Cloud Pak for Data.
Summary IBM has released the below fix for IBM Db2® on Cloud Pak for Data and Db2 Warehouse on Cloud Pak for Data in response to multiple vulnerabilities found in multiple components. This bulletin identifies the steps to take to address the vulnerabilities. Vulnerability Details...
com.linecorp.centraldogma:centraldogma-client-java-armeria-xds (>=0.81.0, <=0.83.0) potentially affected by CVE-2026-11752 via com.linecorp.armeria:armeria-xds (>=1.37.0, <=1.39.0)
com.linecorp.armeria:armeria-xds MAVEN version =1.37.0, =0.81.0, =0.83.0 Source cves: CVE-2026-11752 Source advisory: SNYK:JAVA-COMLINECORPARMERIA-17391817...
com.linecorp.centraldogma:centraldogma-client-java-armeria-xds (>=0.69.0, <=0.83.0) potentially affected by CVE-2026-11752 via com.linecorp.armeria:armeria-xds (>=1.30.0, <=1.39.0)
com.linecorp.armeria:armeria-xds MAVEN version =1.30.0, =0.69.0, =0.83.0 Source cves: CVE-2026-11752 Source advisory: MEND:CVE-2026-11752...