67673 matches found
CedarJava has type confusion vulnerability
Summary CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. Under certain circumstances, improper input handling could allow type confusion across the Java-Rust FFI boundary. Impact Record-to-Entity type confusion across the...
GHSA-93G4-M6XV-CMVR CedarJava has type confusion vulnerability
Summary CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. Under certain circumstances, improper input handling could allow type confusion across the Java-Rust FFI boundary. Impact Record-to-Entity type confusion across the...
com.primust:primust-cedar (>=1.0.2, <=1.0.3), io.github.devnico:cedar4s-client_2.13 (>=0.1.0, <=0.1.6) +12 more potentially affected by CVE-2026-55772 via com.cedarpolicy:cedar-java (>=4.3.0, <=4.8.0)
com.cedarpolicy:cedar-java MAVEN version =4.3.0, =1.0.2, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.6 Source cves: CVE-2026-55772 Source advisory: OSV:GHSA-93G4-M6XV-CMVR...
Security Bulletin: Multiple vulnerabilities in IBM Java SDK affect IBM Tivoli System Automation Application Manager (CVE-2026-22016, CVE-2026-22021, CVE-2026-22013, CVE-2026-22018, CVE-2026-34268, CVE-2026-22007)
Summary There are multiple vulnerabilities in IBM SDK Java Technology Edition used by IBM Tivoli System Automation Application Manager. Vulnerability Details CVEID:CVE-2026-22016 DESCRIPTION: Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protoco...
Security Bulletin: Multiple vulnerabilities in IBM Java SDK affect IBM Tivoli System Automation for Multiplatforms (CVE-2026-22016, CVE-2026-22021, CVE-2026-22013, CVE-2026-22018, CVE-2026-34268, CVE-2026-22007)
Summary There are multiple vulnerabilities in IBM SDK Java Technology Edition, Version 8 used by IBM Tivoli System Automation for Multiplatforms. Vulnerability Details CVEID:CVE-2026-22016 DESCRIPTION: Easily exploitable vulnerability allows unauthenticated attacker with network access via multip...
Security Bulletin: Multiple vulnerabilities affect IBM Db2® on Cloud Pak for Data, and Db2 Warehouse on Cloud Pak for Data.
Summary IBM has released the below fix for IBM Db2® on Cloud Pak for Data and Db2 Warehouse on Cloud Pak for Data in response to multiple vulnerabilities found in multiple components. This bulletin identifies the steps to take to address the vulnerabilities. Vulnerability Details...
com.linecorp.centraldogma:centraldogma-client-java-armeria-xds (>=0.81.0, <=0.83.0) potentially affected by CVE-2026-11752 via com.linecorp.armeria:armeria-xds (>=1.37.0, <=1.39.0)
com.linecorp.armeria:armeria-xds MAVEN version =1.37.0, =0.81.0, =0.83.0 Source cves: CVE-2026-11752 Source advisory: SNYK:JAVA-COMLINECORPARMERIA-17391817...
com.linecorp.centraldogma:centraldogma-client-java-armeria-xds (>=0.69.0, <=0.83.0) potentially affected by CVE-2026-11752 via com.linecorp.armeria:armeria-xds (>=1.30.0, <=1.39.0)
com.linecorp.armeria:armeria-xds MAVEN version =1.30.0, =0.69.0, =0.83.0 Source cves: CVE-2026-11752 Source advisory: MEND:CVE-2026-11752...
[SECURITY] Fedora 43 Update: ongres-scram-3.3-1.fc43
This is a Java implementation of SCRAM Salted Challenge Response Authentication Mechanism which is part of the family of Simple Authentication and Security Layer SASL, RFC 4422 authentication mechanisms. It is described as part of RFC 5802 and RFC7677...
PT-2026-50975
Name of the Vulnerable Software and Affected Versions CedarJava versions prior to 2.3.6 CedarJava versions prior to 3.4.1 CedarJava versions prior to 4.9 Description Improper input handling allows Record-to-Entity type confusion across the Java-Rust FFI Foreign Function Interface boundary...
com.linecorp.centraldogma:centraldogma-client-java-armeria-xds (>=0.69.0, <=0.83.0) potentially affected by CVE-2026-11752 via com.linecorp.armeria:armeria-xds (>=1.30.0, <=1.39.0)
com.linecorp.armeria:armeria-xds MAVEN version =1.30.0, =0.69.0, =0.83.0 Source cves: CVE-2026-11752 Source advisory: GHSA-HGW6-8C77-V4GQ...
com.linecorp.centraldogma:centraldogma-client-java-armeria-xds (>=0.69.0, <=0.83.0) potentially affected by CVE-2026-11752 via com.linecorp.armeria:armeria-xds (>=1.30.0, <=1.39.0)
com.linecorp.armeria:armeria-xds MAVEN version =1.30.0, =0.69.0, =0.83.0 Source cves: CVE-2026-11752 Source advisory: OSV:GHSA-HGW6-8C77-V4GQ...
org.cometd.java:cometd-java-annotation-server (>=5.0.0, <=5.0.22), org.cometd.java:cometd-java-benchmark-server (>=5.0.0, <=5.0.22) +8 more potentially affected by CVE-2025-53114 via org.cometd.java:cometd-java-server-common (>=5.0.0, <=5.0.22)
org.cometd.java:cometd-java-server-common MAVEN version =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.0, =5.0.2, =5.0.22 Source cves: CVE-2025-53114 Source advisory: MEND:CVE-2025-53114...
org.apache.camel.quarkus:camel-quarkus-cometd (>=3.0.0-m1, <=3.6.0), org.apache.camel.quarkus:camel-quarkus-cometd-deployment (>=3.0.0-m1, <=3.6.0) +13 more potentially affected by CVE-2025-53114 via org.cometd.java:cometd-java-server-common (>=7.0.0, <=7.0.18)
org.cometd.java:cometd-java-server-common MAVEN version =7.0.0, =3.0.0-m1, =3.0.0-m1, =3.0.0-m1, =4.0.0-m1, =4.0.0-m1, =7.0.0, =7.0.0, =7.0.0, =7.0.11, =7.0.0, =7.0.0, =7.0.0, =7.0.0, =7.0.0, =7.0.0, =7.0.18 Source cves: CVE-2025-53114 Source advisory: MEND:CVE-2025-53114...
org.apache.camel.karaf:camel-cometd (>=4.7.0, <=4.10.7), org.apache.camel.quarkus:camel-quarkus-cometd (>=3.13.0, <=3.25.0) +13 more potentially affected by CVE-2025-53114 via org.cometd.java:cometd-java-server-common (>=8.0.0, <=8.0.8)
org.cometd.java:cometd-java-server-common MAVEN version =8.0.0, =4.7.0, =3.13.0, =3.13.0, =4.7.0, =4.7.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.8 Source cves: CVE-2025-53114 Source advisory: MEND:CVE-2025-53114...
org.cometd.java:cometd-java-annotation-server (>=6.0.0, <=6.0.18), org.cometd.java:cometd-java-benchmark-server (>=6.0.0, <=6.0.18) +8 more potentially affected by CVE-2025-53114 via org.cometd.java:cometd-java-server-common (>=6.0.0, <=6.0.18)
org.cometd.java:cometd-java-server-common MAVEN version =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.18 Source cves: CVE-2025-53114 Source advisory: MEND:CVE-2025-53114...
EUVD-2025-210276
GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.27.0 of the GeoServer DB2 DataStore Extension, an administrator can perform a JNDI attack through specially crafted DB2 jdbc url leading to to Remote Code Execution RCE. Version 2.27.0 fixes...
Security Bulletin: IBM Tivoli Monitoring is included with IBM Tivoli Composite Application Manager for Applications WebSphere MQ Monitoring Agent
Summary IBM Tivoli Monitoring is included with IBM Tivoli Composite Application Manager for Applications WebSphere MQ Monitoring Agent Vulnerability Details CVEID:CVE-2026-22016 DESCRIPTION: Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocol...
Security update for java-1_8_0-ibm
This update for java-180-ibm fixes the following issues CVE-2026-22007: APIs in the specified component can lead to an unauthorized read access bsc1262490. CVE-2026-22013: unauthenticated attacker with network access can access to critical data bsc1262494. CVE-2026-22016: APIs in the specified...
SUSE-SU-2026:2453-1 Security update for java-1_8_0-ibm
This update for java-180-ibm fixes the following issues - CVE-2026-22007: APIs in the specified component can lead to an unauthorized read access bsc1262490. - CVE-2026-22013: unauthenticated attacker with network access can access to critical data bsc1262494. - CVE-2026-22016: APIs in the...