13682 matches found
kernel: ipv6: fix possible UAF in icmpv6_rcv()
A flaw was found in the Linux kernel's IPv6 Internet Protocol version 6 implementation. This vulnerability, a Use-After-Free UAF error, occurs due to incorrect caching of network packet addresses before a memory operation. An attacker could potentially exploit this flaw to cause memory corruption...
ALSA-2026:66180 Important: kernel security, bug fix, and enhancement update
The kernel packages contain the Linux kernel, the core of any Linux operating system. Security Fixes: kernel: KVM: nSVM: Always use vmcb01 in VMLOAD/VMSAVE emulation CVE-2026-43133 kernel: ipv6: prevent possible UaF in addrconfpermanentaddr CVE-2026-43339 kernel: crypto: pcrypt - Fix handling of...
Linux Kernel IPv6 Multicast Routing Use-After-Free Local Privilege Escalation Vulnerability
This vulnerability allows local attackers to escalate privileges on affected installations of Linux Kernel. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the handling of skbuff...
RockyLinux 10 : kernel (RLSA-2026:64775)
The remote RockyLinux 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the RLSA-2026:64775 advisory. kernel: can: bcm: add locking for bcmop runtime updates CVE-2025-38004 kernel: ipv6: add NULL checks for idev in SRv6 paths CVE-2026-23442 kernel: udp:...
The vulnerability of the vti6_siocdevprivate() function in the net/ipv6/ip6_vti.c module of the IPv6 protocol implementation in the Linux operating system allows a attacker to compromise the confidentiality, integrity, and accessibility of the protected information.
The vulnerability of the vti6siocdevprivate function in the net/ipv6/ip6vti.c module of the Linux operating system’s IPv6 kernel implementation is related to insufficient spatial partitioning. Exploiting this vulnerability could allow an attacker to compromise the confidentiality, integrity, and...
The vulnerability of the ip6_parse_tlv() function in the net/ipv6/exthdrs.c module of the Linux operating system’s IPv6 kernel implementation allows a attacker to compromise the confidentiality, integrity, and accessibility of the protected information.
The vulnerability of the ip6parsetlv function in the net/ipv6/exthdrs.c module of the Linux operating system’s IPv6 kernel implementation is related to the dereferencing of a pointer with an expired validity period. Exploiting this vulnerability could allow an attacker to compromise the...
The vulnerability of the rt6_fill_node() function in the net/ipv6/route.c module of the IPv6 protocol implementation in the Linux operating system allows a attacker to cause a service failure.
The vulnerability of the rt6fillnode function in the net/ipv6/route.c module of the IPv6 protocol implementation in the Linux operating system is related to the execution of a loop with an unreachable exit condition an “infinite loop”. Exploitation of this vulnerability could allow a remote...
The vulnerability of the ipv6_hop_ioam() function in the net/ipv6/exthdrs.c module of the Linux operating system’s IPv6 kernel implementation allows a attacker to compromise the confidentiality, integrity, and accessibility of the protected information.
The vulnerability of the ipv6hopioam function in the net/ipv6/exthdrs.c module of the Linux operating system’s IPv6 kernel implementation is related to the dereferencing of a pointer whose validity has expired. Exploiting this vulnerability could allow an attacker to compromise the confidentialit...
The vulnerability of the ip6_parse_tlv() function in the net/ipv6/exthdrs.c module of the Linux operating system’s IPv6 kernel implementation allows a attacker to compromise the confidentiality, integrity, and accessibility of the protected information.
The vulnerability of the ip6parsetlv function in the net/ipv6/exthdrs.c module of the Linux operating system’s IPv6 kernel implementation is related to the dereferencing of a pointer with an expired validity period. Exploiting this vulnerability could allow an attacker to compromise the...
EUVD-2026-56556
Dozzle: SSRF guard bypass via IPv6 transition addresses 6to4/NAT64/Teredo in webhook notification dispatcher...
GHSA-P2W3-6X73-2F6X Dozzle: SSRF guard bypass via IPv6 transition addresses (6to4/NAT64/Teredo) in webhook notification dispatcher
Summary The isBlockedIP SSRF guard in Dozzle's webhook notification dispatcher blocks loopback, link-local, multicast, and unspecified addresses but does not recognize IPv6 transition mechanism addresses RFC 3056 6to4, RFC 6052 NAT64, RFC 4380 Teredo that embed arbitrary IPv4 addresses. An...
Dozzle: SSRF guard bypass via IPv6 transition addresses (6to4/NAT64/Teredo) in webhook notification dispatcher
Summary The isBlockedIP SSRF guard in Dozzle's webhook notification dispatcher blocks loopback, link-local, multicast, and unspecified addresses but does not recognize IPv6 transition mechanism addresses RFC 3056 6to4, RFC 6052 NAT64, RFC 4380 Teredo that embed arbitrary IPv4 addresses. An...
CVE-2026-86735
snipe-it versions before 8.7.0 contain a server-side request forgery vulnerability in the ExternalUrl validation rule that fails to detect IPv6 transition addresses encoding private IPv4 targets. Attackers with super-admin privileges can configure webhook URLs using NAT64, 6to4, or Teredo...
Server-side Request Forgery (SSRF)
Overview snipe/snipe-it is an asset management system built on Laravel. Affected versions of this package are vulnerable to Server-side Request Forgery SSRF in the ExternalUrl validation process. An attacker can access internal services or cloud metadata endpoints by configuring webhook URLs with...
CVE-2026-86735 snipe-it before 8.7.0 SSRF via IPv6 transition address bypass
snipe-it versions before 8.7.0 contain a server-side request forgery vulnerability in the ExternalUrl validation rule that fails to detect IPv6 transition addresses encoding private IPv4 targets. Attackers with super-admin privileges can configure webhook URLs using NAT64, 6to4, or Teredo...
EUVD-2026-72871
snipe-it versions before 8.7.0 contain a server-side request forgery vulnerability in the ExternalUrl validation rule that fails to detect IPv6 transition addresses encoding private IPv4 targets. Attackers with super-admin privileges can configure webhook URLs using NAT64, 6to4, or Teredo...
CVE-2026-86735 snipe-it before 8.7.0 SSRF via IPv6 transition address bypass
snipe-it versions before 8.7.0 contain a server-side request forgery vulnerability in the ExternalUrl validation rule that fails to detect IPv6 transition addresses encoding private IPv4 targets. Attackers with super-admin privileges can configure webhook URLs using NAT64, 6to4, or Teredo...
CVE-2026-86735 snipe-it before 8.7.0 SSRF via IPv6 transition address bypass
snipe-it versions before 8.7.0 contain a server-side request forgery vulnerability in the ExternalUrl validation rule that fails to detect IPv6 transition addresses encoding private IPv4 targets. Attackers with super-admin privileges can configure webhook URLs using NAT64, 6to4, or Teredo...
CVE-2026-86735
snipe-it versions before 8.7.0 contain a server-side request forgery (SSRF) vulnerability in the ExternalUrl validation rule , which fails to detect IPv6 transition addresses (NAT64, 6to4, or Teredo) that encode private IPv4 targets. An attacker with super-admin privileges can configure webhook U...
kernel: ipv6: add NULL checks for idev in SRv6 paths
A flaw was found in the Linux kernel. Missing null pointer checks in the IPv6 Segment Routing SRv6 implementation, specifically within the seg6hmacvalidateskb and ipv6srhrcv functions, can occur when an IPv6 device lacks proper configuration. This oversight may allow an attacker to trigger a null...