7 matches found
CVE-2026-98275 net: ethernet: cortina: Ack RX overrun interrupt correctly
In the Linux kernel, the following vulnerability has been resolved: net: ethernet: cortina: Ack RX overrun interrupt correctly The RX overrun interrupt is reported in interrupt status register 4, but gmacirq acknowledges it using the RX descriptor error bit from status register 0. For GMAC0 this...
PT-2026-106604
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 7.2.10-1.1 Description An issue exists in the ethernet driver for Cortina where the RX overrun interrupt is incorrectly acknowledged. The interrupt is reported in interrupt status register 4, but the gmac irq...
CVE-2022-49214
In the Linux kernel, the following vulnerability has been resolved: powerpc/64s: Don't use DSISR for SLB faults Since commit 46ddcb3950a2 "powerpc/mm: Show if a bad page fault on data is read or write." we use pagefaultiswriteregs-dsisr in badpagefault to determine if the fault is for a read or...
CVE-2022-49214
CVE-2022-49214 pertains to the Linux kernel on PowerPC 64s where Data SLB (Data Segment) faults do not set DSISR to a useful value, causing misclassification of read vs. write faults. The fix reworks the printing logic to treat SLB faults separately and only print read/write when the fault type c...
GSD-2022-1006014 RDMA/hns: Fix incorrect clearing of interrupt status register
RDMA/hns: Fix incorrect clearing of interrupt status register This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v5.4.211 by commit...
PT-2022-34106 · Linux · Linux Kernel
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions 4.16 through 5.10.136 Description: The issue is related to the incorrect clearing of the interrupt status register in RDMA/hns. The actual impact and attack plausibility have not yet been proven. Recommendations: For Lin...
PT-2022-33499 · Linux · Linux Kernel
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions v4.16 through v5.19.1 Description: The issue is related to the incorrect clearing of the interrupt status register in RDMA/hns. The actual impact and attack plausibility have not yet been proven. Recommendations: For Lin...