90703 matches found
CVE-2026-71401
A flaw was found in wicked, specifically in its DHCPv4 packet capture code. An integer underflow vulnerability exists where the nicaptureinspectudpheader function fails to validate the IP total length field against the IP header length before performing a subtraction. This oversight allows an...
Exploit for Integer Overflow or Wraparound in Postgresql
CVE-2026-14662 – Out-of-bounds write vulnerability in PostgreS...
CVE-2026-15534
A flaw was found in Perl. An integer overflow vulnerability in the regular expression engine's superlinear cache calculation can lead to out-of-bounds memory reads and writes. A remote attacker could exploit this by providing a specially crafted, large input string during regular expression...
CVE-2026-82737
Integer Overflow or Wraparound vulnerability in ash-project ash lets an attacker corrupt a stored vector and crash later reads of it by submitting a vector with more than 65,535 elements. Ash.Vector.new/1 lib/ash/vector.ex encodes a vector as followed by the element floats, packing the element...
CVE-2026-82737 Ash.Vector wraps the 16-bit dimension header for vectors over 65,535 elements, corrupting data and crashing reads
Integer Overflow or Wraparound vulnerability in ash-project ash lets an attacker corrupt a stored vector and crash later reads of it by submitting a vector with more than 65,535 elements. Ash.Vector.new/1 lib/ash/vector.ex encodes a vector as followed by the element floats, packing the element...
EUVD-2026-68964
Integer Overflow or Wraparound vulnerability in ash-project ash lets an attacker corrupt a stored vector and crash later reads of it by submitting a vector with more than 65,535 elements. Ash.Vector.new/1 lib/ash/vector.ex encodes a vector as followed by the element floats, packing the element...
CVE-2026-82737 Ash.Vector wraps the 16-bit dimension header for vectors over 65,535 elements, corrupting data and crashing reads
Integer Overflow or Wraparound vulnerability in ash-project ash lets an attacker corrupt a stored vector and crash later reads of it by submitting a vector with more than 65,535 elements. Ash.Vector.new/1 lib/ash/vector.ex encodes a vector as followed by the element floats, packing the element...
CVE-2026-82737 Ash.Vector wraps the 16-bit dimension header for vectors over 65,535 elements, corrupting data and crashing reads
Integer Overflow or Wraparound vulnerability in ash-project ash lets an attacker corrupt a stored vector and crash later reads of it by submitting a vector with more than 65,535 elements. Ash.Vector.new/1 lib/ash/vector.ex encodes a vector as followed by the element floats, packing the element...
CVE-2026-82737
Integer Overflow or Wraparound vulnerability in ash-project ash lets an attacker corrupt a stored vector and crash later reads of it by submitting a vector with more than 65,535 elements. Ash.Vector.new/1 lib/ash/vector.ex encodes a vector as followed by the element floats, packing the element...
CVE-2026-82737
CVE-2026-82737 is an integer overflow in Ash.Vector.new/1 (lib/ash/vector.ex) in the ash-project ash Elixir library. The dimension field is packed into a 16-bit unsigned integer without a range check, so a vector with more than 65,535 elements wraps modulo 65,536, producing a header that disagree...
EEF-CVE-2026-82737 Ash.Vector wraps the 16-bit dimension header for vectors over 65,535 elements, corrupting data and crashing reads
Summary Integer Overflow or Wraparound vulnerability in ash-project ash lets an attacker corrupt a stored vector and crash later reads of it by submitting a vector with more than 65,535 elements. Ash.Vector.new/1 lib/ash/vector.ex encodes a vector as followed by the element floats, packing the...
SUSE CVE-2025-70290
An issue was discovered in Denx U-Boot before 2026.04. An integer overflow vulnerability in the ZFS filesystem support can be triggered by malformed on-disk metadata. The issue may result in incorrect memory allocation followed by out-of-bounds memory access, potentially leading to a crash or...
SUSE CVE-2025-70293
An issue was discovered in Denx U-Boot before 2026.04. An integer overflow vulnerability exists in function ext4fsgetbgdtable, the size calculation can lead to under allocation and this underallocated buffer will be used in memcpy which could lead to arbitrary code execution, a denial of service,...
TencentOS Server 2: gstreamer1-plugins-good (TSSA-2026:0934)
The version of Tencent Linux installed on the remote TencentOS Server 2 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the TSSA-2026:0934 advisory. Package updates are available for TencentOS Server 2 that fix the following vulnerabilities:...
openSUSE 16 Security Update : 389-ds (openSUSE-SU-2026:21691-1)
The remote openSUSE 16 host has packages installed that are affected by multiple vulnerabilities as referenced in the openSUSE-SU-2026:21691-1 advisory. Update to version 3.0.6git382.7a51ea5f5. Security issues fixed: - CVE-2026-11610: heap buffer overflow in the SASL I/O layer via a crafted...
PostgreSQL 14.x < 14.24 / 15.x < 15.19 / 16.x < 16.15 / 17.x < 17.11 / 18.x < 18.6 Multiple Vulnerabilities
The version of PostgreSQL installed on the remote host is 14 prior to 14.24, 15 prior to 15.19, 16 prior to 16.15, 17 prior to 17.11, or 18 prior to 18.6. As such, it is potentially affected by multiple vulnerabilities: - Type confusion with PostgreSQL 'internal' data type arguments allows any us...
Alibaba Cloud Linux 3 : 0270: gstreamer1-plugins-bad-free (ALINUX3-SA-2026:0270)
The remote Alibaba Cloud Linux 3 host has packages installed that are affected by multiple vulnerabilities as referenced in the ALINUX3-SA-2026:0270 advisory. Package updates are available for Alibaba Cloud Linux 3 that fix the following vulnerabilities: CVE-2026-19387: A heap out-of-bounds write...
openSUSE 16: postgresql17 / postgresql17-contrib / postgresql17-devel / etc (openSUSE-SU-2026:21702-1)
The remote openSUSE 16 host has packages installed that are affected by multiple vulnerabilities as referenced in the openSUSE-SU-2026:21702-1 advisory. - CVE-2026-6464: psql COPY FROM STDIN early failure processes data lines as psql commands bsc1275046. - CVE-2026-6469: ALTER TABLE ALTER TYPE...
Alibaba Cloud Linux 3 : 0266: pcp (ALINUX3-SA-2026:0266)
The remote Alibaba Cloud Linux 3 host has packages installed that are affected by multiple vulnerabilities as referenced in the ALINUX3-SA-2026:0266 advisory. Package updates are available for Alibaba Cloud Linux 3 that fix the following vulnerabilities: CVE-2026-16524: A command injection flaw i...
PT-2026-84261
Name of the Vulnerable Software and Affected Versions Erlang/OTP versions 17.0 through 27.3.4.16 Erlang/OTP versions 28.0 through 28.5.0.5 Erlang/OTP versions 29.0 through 29.0.5 Description Improper validation of input quantity in the eldap module allows a malicious or compromised LDAP server to...