73891 matches found
CVE-2026-106062: Improper Restriction of Operations within the Bounds of a Memory Buffer
A heap-based buffer overflow was found in GIMP’s DirectDraw Surface DDS loader. When loading a crafted DDS image, buffer sizes derived from width, height, and pitch can be computed using 32-bit arithmetic that overflows. The allocated buffer is too small for the amount of pixel data written throu...
PT-2026-115788
In the Linux kernel, the following vulnerability has been resolved: neighbour: Enforce min/max to NDTPA INTERVAL PROBE TIME MS. NDTPA INTERVAL PROBE TIME MS sets .type and .min but misses .validation type, so no validation is applied: ynl --family rt-neigh --do setneightbl --json '"name": "arp...
PT-2026-115708
In the Linux kernel, the following vulnerability has been resolved: KEYS: encrypted: fix integer overflow of datablob len encrypted key alloc stores datablob len in a u16. It is computed from multiple string and payload lengths. If the result exceeds U16 MAX, the assignment truncates the allocati...
CVE-2026-106063: Improper Restriction of Operations within the Bounds of a Memory Buffer
A heap-based buffer overflow was found in GIMP’s DICOM export plug-in. When exporting an image with extremely large width and height, the export path allocates a buffer using a 32-bit width height and bytes-per-pixel product that can overflow. GEGL then writes the full uncompressed extent into th...
RockyLinux 10 : libvirt (RLSA-2026:75583)
The remote RockyLinux 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the RLSA-2026:75583 advisory. libvirt: swtpm privilege escalation via symlink following CVE-2026-63622 libvirt: Integer overflow in NodeGetFreePages RPC handler leading to heap buff...
Wireshark 1.10.x < 1.10.13 Multiple Vulnerabilities
The version of Wireshark installed on the remote Windows host is prior to 1.10.13. It is, therefore, affected by multiple vulnerabilities as referenced in the wireshark-1.10.13 advisory. - Integer overflow in the dissecttnef function in epan/dissectors/packet-tnef.c in the TNEF dissector in...
CVE-2026-98222: Undefined Security Weakness
In the Linux kernel, the following vulnerability has been resolved: KEYS: encrypted: fix integer overflow of databloblen encryptedkeyalloc stores databloblen in a u16. It is computed from multiple string and payload lengths. If the result exceeds U16MAX, the assignment truncates the allocation...
SUSE SLES15 Security Update : kernel (Live Patch 19 for SUSE Linux Enterprise 15 SP7) (SUSE-SU-2026:4513-1)
The remote SUSE Linux SLES15 host has a package installed that is affected by multiple vulnerabilities as referenced in the SUSE-SU-2026:4513-1 advisory. This update for the SUSE Linux Enterprise Kernel 6.4.0-150700.53.73 fixes various security issues: The following security issues were fixed: -...
CentOS 9 : pcre2-10.40-7.el9
The remote CentOS Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the pcre2-10.40-7.el9 build changelog. - In PCRE2 before 10.48, pcre2jitmatch mishandles a previously copied subject being passed in as a context. An incorrect free operation can...
Rocky Linux 10.1 [CIQ] Security Update: glibc / glibc-all-langpacks / glibc-benchtests / etc Multiple Vulnerabilities (crlsa-2026_1334)
The Rocky Linux 10.1 host has packages installed that are affected by multiple vulnerabilities as referenced in the CIQ crlsa-20261334 advisory. glibc: Integer overflow in memalign leads to heap corruption CVE-2026-0861 glibc: glibc: Information disclosure via zero-valued network query...
AlmaLinux 9.6 [TuxCare] Security Update: gimp / gimp-devel / gimp-devel-tools / gimp-libs Multiple Vulnerabilities (ALMALINUX9.6:CLSA-2026:1791296305)
The AlmaLinux 9.6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1791296305 advisory. - A flaw was found in GIMP's PSP Paint Shop Pro file parser. A remote attacker could exploit an integer overflow vulnerability in th...
AlmaLinux 9 : gimp (ALSA-2026:75575)
The remote AlmaLinux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the ALSA-2026:75575 advisory. gimp: gimp: out-of-bounds write in lighting effects plugin via crafted preset file CVE-2026-90947 gimp: gimp: heap-based buffer overflow in ICO loader vi...
Fedora 45 : chromium (2026-53c8aca50a)
The remote Fedora 45 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2026-53c8aca50a advisory. Update to 154.0.8037.97, includes 11 security fixes CVE-2026-103621: Integer overflow in Compositing CVE-2026-103622: Use after free in SVG...
Rocky Linux 9.6 [TuxCare] Security Update: gimp / gimp-devel / gimp-devel-tools / gimp-libs Multiple Vulnerabilities (ALMALINUX9.6:CLSA-2026:1791296305)
The Rocky Linux 9.6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1791296305 advisory. - A flaw was found in GIMP's PSP Paint Shop Pro file parser. A remote attacker could exploit an integer overflow vulnerability in...
SUSE SLES15 Security Update : kernel (Live Patch 20 for SUSE Linux Enterprise 15 SP7) (SUSE-SU-2026:4514-1)
The remote SUSE Linux SLES15 host has a package installed that is affected by multiple vulnerabilities as referenced in the SUSE-SU-2026:4514-1 advisory. This update for the SUSE Linux Enterprise Kernel 6.4.0-150700.53.78 fixes various security issues: The following security issues were fixed: -...
SUSE SLES15 Security Update : kernel (Live Patch 29 for SUSE Linux Enterprise 15 SP6) (SUSE-SU-2026:4498-1)
The remote SUSE Linux SLES15 host has a package installed that is affected by multiple vulnerabilities as referenced in the SUSE-SU-2026:4498-1 advisory. This update for the SUSE Linux Enterprise Kernel 6.4.0-150600.23.125 fixes various security issues: The following security issues were fixed: -...
FreeBSD : rabbitmq-c -- multiple vulnerabilities (03306014-c15d-11f1-acb8-107c611e671e)
The version of FreeBSD installed on the remote host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the 03306014-c15d-11f1-acb8-107c611e671e advisory. The rabbitmq-c project reports: CVE-2026-61547: A heap buffer overflow exists when the...
Linux Distros Unpatched Vulnerability : CVE-2026-98222
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - KEYS: encrypted: fix integer overflow of databloblen encryptedkeyalloc stores databloblen in a u16. It is computed from multiple string and payload lengths. If...
Linux Distros Unpatched Vulnerability : CVE-2026-98317
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - neighbour: Enforce min/max to NDTPAINTERVALPROBETIMEMS. NDTPAINTERVALPROBETIMEMS sets .type and .min but misses .validationtype, so no validation is applied: yn...
PT-2026-106694
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description An integer overflow exists in the mr check range function within the RDMA/rxe component. The function uses wraparound-prone arithmetic to validate that the range iova, iova+length falls...