74542 matches found
EUVD-2026-89535
A vulnerability was detected in Nothings stb up to 2c980bb59875b0d32144a71867fbdebb2f77cd20. The impacted element is the function hexwaveinit in the library stbhexwave.h. Performing a manipulation of the argument width/oversample results in integer overflow. Remote exploitation of the attack is...
CVE-2026-102804
A vulnerability exists in the Nothings stb library (versions up to 2c980bb59875b0d32144a71867fbdebb2f77cd20 ) within the stb_hexwave.h file. Specifically, the hexwave_init function is susceptible to an integer overflow when an attacker manipulates the width/oversample arguments. This flaw allows ...
CVE-2026-102804 Nothings stb stb_hexwave.h hexwave_init integer overflow
A vulnerability was detected in Nothings stb up to 2c980bb59875b0d32144a71867fbdebb2f77cd20. The impacted element is the function hexwaveinit in the library stbhexwave.h. Performing a manipulation of the argument width/oversample results in integer overflow. Remote exploitation of the attack is...
CVE-2026-47510: Integer Overflow or Wraparound
NVIDIA GPU Display Driver for Windows and Linux contains a vulnerability in the kernel mode layer, where a user could cause an integer overflow leading to an out-of-bounds write to GPU memory. A successful exploit of this vulnerability might lead to code execution, denial of service, escalation o...
CVE-2026-95616: Integer Overflow or Wraparound
An integer overflow in WSS4J's DER bounds check lets an oversized allocation pass validation. An unauthenticated attacker can send a SOAP message carrying an X.509 certificate whose SubjectKeyIdentifier extension declares a length of 0x7FFFFFFF; WSS4J decodes this while resolving the signature's...
PT-2026-103083
Name of the Vulnerable Software and Affected Versions Apache PLC4X versions 0.11.0 through 0.13.1 Description The Go implementation of Apache PLC4X PLC4Go contains multiple flaws including integer overflow, improper validation of array indices, uncontrolled recursion, and memory allocation with...
PT-2026-103282
A vulnerability was determined in Blosc C-Blosc2 up to 3.3.2. This impacts the function blosclz decompress of the file blosc/blosclz.c of the component blosclz Decompression. Executing a manipulation can lead to integer overflow. The attack may be launched remotely. A high complexity level is...
PT-2026-103423
NVIDIA GPU Display Driver for Windows contains a vulnerability in the display driver DIAG escape handler where a local unprivileged attacker may cause an integer overflow and out-of-bounds write. A successful exploit of this vulnerability might lead to denial of service, and code execution...
CentOS Linux 7 [TuxCare] Security Update: gawk (CENTOS7:CLSA-2026:1784131550)
The CentOS Linux 7 host has a package installed that is affected by a vulnerability as referenced in the TuxCare CENTOS7:CLSA-2026:1784131550 advisory. - Integer overflow vulnerability has been found in builtin.c program file of gawk. This issue may lead to memory exhaustion on the hosting...
AlmaLinux 9.6 [TuxCare] Security Update: coreutils / coreutils-common / coreutils-single (ALMALINUX9.6:CLSA-2026:1788177078)
The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1788177078 advisory. - GNU coreutils unexpand is vulnerable to a heap-based buffer overflow due to an integer overflow during buffer allocation when processing...
AlmaLinux 9.2 [TuxCare] Security Update: gimp / gimp-devel / gimp-devel-tools / gimp-libs Multiple Vulnerabilities (ALMALINUX9.2:CLSA-2025:1757691801)
The AlmaLinux 9.2 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.2:CLSA-2025:1757691801 advisory. - GIMP PSD File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers t...
AlmaLinux 9.6 [TuxCare] Security Update: mod_md (ALMALINUX9.6:CLSA-2026:1767629031)
The AlmaLinux 9.6 host has a package installed that is affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1767629031 advisory. - An integer overflow in the case of failed ACME certificate renewal leads, after a number of failures 30 days in default configurations, to...
CentOS Linux 6 [TuxCare] Security Update: php / php-bcmath / php-cli / php-common / php-dba / php-devel / etc Multiple Vulnerabilities (CENTOS6:CLSA-2026:1777540774)
The CentOS Linux 6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare CENTOS6:CLSA-2026:1777540774 advisory. - An issue was discovered in PHP before 5.6.37, 7.0.x before 7.0.31, 7.1.x before 7.1.20, and 7.2.x before 7.2.8. An Integer Overflow...
CentOS Linux 6 [TuxCare] Security Update: libssh2 / libssh2-devel / libssh2-docs Multiple Vulnerabilities (CENTOS6:CLSA-2026:1778159627)
The CentOS Linux 6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare CENTOS6:CLSA-2026:1778159627 advisory. - In libssh2 before 1.9.0, kexmethoddiffiehellmangroupexchangesha256keyexchange in kex.c has an integer overflow that could lead to an...
Rocky Linux 9.6 [TuxCare] Security Update: openexr / openexr-devel / openexr-libs (ALMALINUX9.6:CLSA-2026:1773831456)
The Rocky Linux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1773831456 advisory. - OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture...
CentOS Linux 8.5 [TuxCare] Security Update: expat / expat-devel / expat-static (CENTOS8.5:CLSA-2026:1773927217)
The CentOS Linux 8.5 host has packages installed that are affected by a vulnerability as referenced in the TuxCare CENTOS8.5:CLSA-2026:1773927217 advisory. - In libexpat before 2.7.4, the doContent function does not properly determine the buffer size bufSize because there is no integer overflow...
AlmaLinux 9.2 [TuxCare] Security Update: expat / expat-devel / expat-static Multiple Vulnerabilities (ALMALINUX9.2:CLSA-2026:1785887332)
The AlmaLinux 9.2 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.2:CLSA-2026:1785887332 advisory. - libexpat before 2.8.2 has an integer overflow in doProlog that is related to storeEntityValue and entity textLen. CVE-2026-56407 -...
AlmaLinux 9.6 [TuxCare] Security Update: gimp / gimp-devel / gimp-devel-tools / gimp-libs (ALMALINUX9.6:CLSA-2026:1787058577)
The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1787058577 advisory. - A flaw was found in the file-sgi plugin in GIMP. When processing an RLE-compressed SGI image, the plugin allocates memory for a row table...
CentOS Linux 8.4 [TuxCare] Security Update: rsync / rsync-daemon (CENTOS8.4:CLSA-2026:1779369649)
The CentOS Linux 8.4 host has packages installed that are affected by a vulnerability as referenced in the TuxCare CENTOS8.4:CLSA-2026:1779369649 advisory. - Rsync version 3.4.2 and prior contain an integer overflow vulnerability in the compressed-token decoder where a 32-bit signed counter is no...
AlmaLinux 9.2 [TuxCare] Security Update: jq / jq-devel (ALMALINUX9.2:CLSA-2026:1776354546)
The AlmaLinux 9.2 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.2:CLSA-2026:1776354546 advisory. - jq is a command-line JSON processor. In versions up to and including 1.7.1, an integer overflow arises when assigning value using an index ...