12104 matches found
Malicious Package in donotinstallthis
The package donotinstallthis contained malicious code. The package contained a script that was run as part of the install script. The script contacted a remote service tracking how many installations were done. There is no further compromise. Recommendation Remove the package from your environmen...
GHSA-2HQF-QQMQ-PGPP Malicious Package in commander-js
All versions of commander-js are considered malicious. The package is malware designed to take advantage of users making a mistake when typing the name of a module to install. When installed, the package downloads an arbitrary file and executes its contents as a post-install script. Recommendatio...
openSIS Remote Code Execution Vulnerability (CNVD-2020-50534)
openSIS is a free, open source student information system/school management software. A remote code execution vulnerability exists in the install function in openSIS 7.4. An attacker can exploit this vulnerability by sending an HTTP request to inject PHP code into the Data.php file via the userna...
PT-2020-20959
Name of the Vulnerable Software and Affected Versions commander-js versions all Description The commander-js package is malicious, designed to exploit typing mistakes when installing modules. Upon installation, it downloads and executes an arbitrary file as a post-install script. Recommendations...
CVE-2020-6143
A remote code execution vulnerability exists in the install functionality of OS4Ed openSIS 7.4. The password variable which is set at line 122 in install/Step5.php allows for injection of PHP code into the Data.php file that it writes. An attacker can send an HTTP request to trigger this...
CVE-2020-6144
A remote code execution vulnerability exists in the install functionality of OS4Ed openSIS 7.4. The username variable which is set at line 121 in install/Step5.php allows for injection of PHP code into the Data.php file that it writes. An attacker can send an HTTP request to trigger this...
Remote code execution
A remote code execution vulnerability exists in the install functionality of OS4Ed openSIS 7.4. The username variable which is set at line 121 in install/Step5.php allows for injection of PHP code into the Data.php file that it writes. An attacker can send an HTTP request to trigger this...
CVE-2020-6143
A remote code execution vulnerability exists in the install functionality of OS4Ed openSIS 7.4. The password variable which is set at line 122 in install/Step5.php allows for injection of PHP code into the Data.php file that it writes. An attacker can send an HTTP request to trigger this...
CVE-2020-6143
CVE-2020-6143 affects OS4Ed openSIS 7.4 install functionality. The install/Step5.php writes Data.php using user-provided values, and the password field (line 122) can inject PHP code, enabling remote code execution via a crafted HTTP request. Exploitation results in arbitrary code execution on th...
CVE-2020-6143
A remote code execution vulnerability exists in the install functionality of OS4Ed openSIS 7.4. The password variable which is set at line 122 in install/Step5.php allows for injection of PHP code into the Data.php file that it writes. An attacker can send an HTTP request to trigger this...
Important: Red Hat Security Advisory: Ansible security and bug fix update (2.8.15)
An update for ansible is now available for Ansible Engine 2.8 Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE...
CVE-2020-6144: Improper Neutralization of Directives in Statically Saved Code
A remote code execution vulnerability exists in the install functionality of OS4Ed openSIS 7.4. The username variable which is set at line 121 in install/Step5.php allows for injection of PHP code into the Data.php file that it writes. An attacker can send an HTTP request to trigger this...
PT-2020-18958
Name of the Vulnerable Software and Affected Versions OS4Ed openSIS version 7.4 Description A remote code execution issue exists in the install functionality. The username variable, set at line 121 in install/Step5.php, allows for injection of PHP code into the Data.php file. An attacker can send...
CVE-2020-6143: Improper Neutralization of Directives in Statically Saved Code
A remote code execution vulnerability exists in the install functionality of OS4Ed openSIS 7.4. The password variable which is set at line 122 in install/Step5.php allows for injection of PHP code into the Data.php file that it writes. An attacker can send an HTTP request to trigger this...
PT-2020-18957
Name of the Vulnerable Software and Affected Versions OS4Ed openSIS version 7.4 Description A remote code execution issue exists in the install functionality. The password variable, set at line 122 in install/Step5.php, allows for injection of PHP code into the Data.php file. An attacker can send...
OS4Ed openSIS install remote code execution vulnerability
Summary A remote code execution vulnerability exists in the install functionality of OS4Ed openSIS 7.4. A specially crafted HTTP request can lead to remote code execution. An attacker can send an HTTP request to trigger this vulnerability. Tested Versions OS4Ed openSIS 7.4 Product URLs...
It was found that some PostgreSQL extensions did not use search_path safely in their installation script. An attacker with sufficient privileges could use this flaw to trick an administrator into executing a specially crafted script during the installation or update of such extension. This affects PostgreSQL versions before 12.4 before 11.9 before 10.14 before 9.6.19 and before 9.5.23.
...
Mozilla: Attacker-induced prompt for extension installation
By holding a reference to the eval function from an about:blank window, a malicious webpage could have gained access to the InstallTrigger object which would allow them to prompt the user to install an extension. Combined with user confusion, this could result in an unintended or malicious...
Mozilla: Attacker-induced prompt for extension installation
By holding a reference to the eval function from an about:blank window, a malicious webpage could have gained access to the InstallTrigger object which would allow them to prompt the user to install an extension. Combined with user confusion, this could result in an unintended or malicious...
CVE-2020-14044
PRODUCT NOT SUPPORTED WHEN ASSIGNED A Server-Side Request Forgery SSRF vulnerability was found in Codiad v1.7.8 and later. A user with admin privileges could use the plugin install feature to make the server request any URL via components/market/class.market.php. This could potentially result in...