94627 matches found
MariaDB Server has a vulnerability related to input validation errors.
MariaDB Server versions prior to 10.6.28 10.6.x series, 10.11.19 10.11.x series, 11.4.13 11.4.x series, 11.8.9 11.8.x series, 12.3.3 12.3.x series, and 13.0.2 13.0.x series have a input validation vulnerability. This vulnerability arises from the ability of the mysql50 prefix to bypass the...
Anthropic Claude Agent SDK for Python: Input validation vulnerability
The Anthropic Claude Agent SDK for Python versions prior to 0.2.121 contain security vulnerabilities. These vulnerabilities stem from the resumption option being passed as an independent token to the Claude CLI without verification. Values starting with a dash are interpreted as independent CLI...
FreeRDP has a vulnerability related to input validation errors
FreeRDP versions 3.30.0 to 3.32.0 previously had a vulnerability related to input validation errors. This vulnerability stemmed from a resource exhaustion issue in the rdpecam client. A malicious RDP server could request unannounced camera media types. Attackers could send requests with extremely...
Devolutions Server has a vulnerability related to input validation errors.
Devolutions Server 2026.3.8.0 and earlier versions have a vulnerability related to input validation errors. This vulnerability stems from improper control over the JIT privilege settings in the PAM checkout process. It may allow authenticated users with PAM checkout access to delete any Active...
Joe Smart-SSO: Input validation vulnerability
Joe Smart-SSO versions 2.1.1 and earlier have a vulnerability in input validation. This vulnerability stems from the /login handler not verifying the redirectUri parameter properly. An open redirection exists, which may allow unauthenticated attackers to steal OAuth2 authorization codes and obtai...
Nezhahq Nezha: Input validation error vulnerability
Versions of Nezhahq Nezha from 2.1.0 to 2.3.15 had a vulnerability related to input validation errors. This vulnerability occurred because the mintTransferTool never validated the construction of Host headers for the fs.downloadurl and fs.uploadurl URLs. This could allow attackers to redirect fil...
sgl-project SGLang Input Validation Vulnerability
The sgl-project SGLang version 0.5.21 and earlier have a vulnerability related to input validation errors. This vulnerability arises from using the mmhashes value provided by the trusted caller as a multi-modal prefix for caching keys. A remote attacker can send different images with known or...
Astra Linux – Vulnerability in Tomcat9
There is a vulnerability related to improper input validation in Apache Tomcat. This issue affects Apache Tomcat versions as follows: 11.0.0-M1 through 11.0.21, 10.1.0-M1 through 10.1.54, 9.0.0.M1 through 9.0.117, and 10.0.0-M1 through 10.0.27. Older, end-of-support versions may also be affected...
Astra Linux – Vulnerability in Chromium
Improper input validation in the Network in Google Chrome prior to version 153.0.8010.36 allowed a remote attacker to bypass web origin policies through a crafted HTML page. Chromium security severity: Medium...
Astra Linux – vulnerability in golang-google-grpc
gRPC-Go is the Go language implementation of gRPC. Versions prior to 1.79.3 contain an authorization bypass vulnerability caused by improper input validation of the HTTP/2 :path pseudo-header. The gRPC-Go server was too lenient in its routing logic, accepting requests where the :path omitted the...
Astra Linux – Vulnerability in Chromium
Insufficient validation of untrusted input in the Reading Mode of Google Chrome prior to 149.0.7827.53 allowed a remote attacker who had compromised the renderer process to potentially perform a sandbox escape via a crafted HTML page. Chromium security severity: Medium...
Astra Linux – vulnerability in Chromium
Insufficient validation of untrusted input in DevTools in Google Chrome prior to 150.0.7871.47 allowed a remote attacker who convinced a user to engage in specific UI gestures to leak cross-origin data via a crafted HTML page. Chromium security severity: Low...
Astra Linux – Vulnerability in Linux 6.1
In the Linux kernel, the following vulnerabilities have been resolved: Bluetooth: hcisock: Fixed an issue where user input was not validated. The length of user input was checked before copying data...
Astra Linux – vulnerability in intel-microcode
Improper input validation in UEFI firmware for certain IntelR processors may allow a privileged user to potentially enable information disclosure via local access...
Astra Linux – Vulnerability in Linux-Firmware
Improper input validation in some IntelR Graphics Drivers for Windows before version 26.20.100.7212 and before the Linux kernel version 5.5 may allow a privileged user to potentially enable a denial of service via local access...
Astra Linux – Vulnerability in WebKit2GTK
A cross-origin issue in the IndexDB API has been resolved through improved input validation. This issue is fixed in iOS 15.3, iPadOS 15.3, watchOS 8.4, tvOS 15.3, Safari 15.3, and macOS Monterey 12.2. It is possible for a website to track sensitive user information...
Astra Linux – vulnerability in rabbitmq-server
RabbitMQ versions prior to 3.8.16 are vulnerable to a denial-of-service issue due to improper input validation in the AMQP 1.0 client connection endpoint. A malicious user can exploit this vulnerability by sending malicious AMQP messages to a target RabbitMQ instance that has the AMQP 1.0 plugin...
Astra Linux – Vulnerability in WebKit2GTK
A vulnerability related to out-of-bounds reads has been addressed through improved input validation. This issue is fixed in watchOS 9.5, tvOS 16.5, macOS Ventura 13.4, iOS 15.7.6, and iPadOS 15.7.6, Safari 16.5, iOS 16.5, and iPadOS 16.5. Processing web content may disclose sensitive information...
Astra Linux – vulnerability in intel-microcode
Improper input validation in UEFI firmware for certain IntelR processors may allow a privileged user to potentially enable privilege escalation via local access...
Astra Linux – vulnerability in linux-6.1, linux, linux-5.10, linux-5.15
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: RFCOMM: Fix not validating setsockopt user input syzbot reported that rfcommsocksetsockoptold copies data without checking the length of user input. BUG: KASAN: slab-out-of-bounds in copyfromsockptroffset...