4517 matches found
PT-2023-27496
Name of the Vulnerable Software and Affected Versions OpenLiteSpeed versions prior to 1.7.18 Description The issue arises from the software not strictly validating HTTP request headers. Recommendations For versions prior to 1.7.18, update to version 1.7.18 or later to resolve the issue...
CVE-2022-48503: Improper Validation of Array Index
The issue was addressed with improved bounds checks. This issue is fixed in tvOS 15.6, watchOS 8.7, iOS 15.6 and iPadOS 15.6, macOS Monterey 12.5, Safari 15.6. Processing web content may lead to arbitrary code execution...
Improper validation of intent data received in TextViewerActivity allows opening of arbitrary files
Description Tested on Build87 of the Inure application. It was discovered that the application had an exported activity .activities.association.TextViewerActivity which accepted intent data via the file scheme + text/ mime type and opened the associated files from provided URI data string. It is...
Input validation
Improper URL validation vulnerability in Samsung Members prior to version 14.0.07.1 allows attackers to access sensitive information...
Hospital Management System SQL Injection Vulnerability
A Hospital Management System HMS is a computerized system that helps manage healthcare-related information and helps healthcare providers do their jobs effectively. A SQL injection vulnerability exists in Hospital Management System version V1.0, which stems from the application's inability to...
Improper Validation
code.gitea.io/gitea is vulnerable to Improper Validation. The vulnerability exists because Migration Downloaders can change the CloneURL which is improperly validated, allowing an attacker to redirect users to a malicious clone URL...
CVE-2023-23903: Improper Validation of Syntactic Correctness of Input
An authenticated administrator can upload a SAML configuration file with the wrong format, with the application not checking the correct file format. Every subsequent application request will return an error. The whole application in rendered unusable until a console intervention...
Improper Validation
libreoffice is vulnerable to Improper Validation. The vulnerability exists in the spreadsheet component of The Document Foundation LibreOffice which allows an attacker to craft a spreadsheet document that will cause an array index underflow when loaded...
Cross-site Scripting (XSS)
gitlab is vulnerable to Cross-site Scripting XSS. The vulnerability exists due to the improper validation in the ipynb files of the library, which allows an attacker to inject and execute malicious javascript...
CVE-2023-37558 CODESYS Improper Validation of Consistency within Input in multiple products
After successful authentication as a user in multiple Codesys products in multiple versions, specific crafted network communication requests with inconsistent content can cause the CmpAppForce component to read internally from an invalid address, potentially leading to a denial-of-service...
CVE-2023-38744
Denial-of-service DoS vulnerability due to improper validation of specified type of input issue exists in the built-in EtherNet/IP port of the CJ Series CJ2 CPU unit and the communication function of the CS/CJ Series EtherNet/IP unit. If an affected product receives a packet which is specially...
Input validation
Denial-of-service DoS vulnerability due to improper validation of specified type of input issue exists in the built-in EtherNet/IP port of the CJ Series CJ2 CPU unit and the communication function of the CS/CJ Series EtherNet/IP unit. If an affected product receives a packet which is specially...
CVE-2023-38744
Denial-of-service DoS vulnerability due to improper validation of specified type of input issue exists in the built-in EtherNet/IP port of the CJ Series CJ2 CPU unit and the communication function of the CS/CJ Series EtherNet/IP unit. If an affected product receives a packet which is specially...
CVE-2023-38744
CVE-2023-38744 affects Omron CJ Series EtherNet/IP components: CJ2M CPU Unit (2.18 or earlier), CJ2H CPU Unit (3.04 or earlier), CS/CJ EtherNet/IP Units CS1W-EIP21 (3.04 or earlier) and CJ1W-EIP21 (3.04 or earlier). Root cause is improper validation of a specific input type in the built-in EtherN...
EulerOS Virtualization 3.0.6.6 : vim (EulerOS-SA-2023-2442)
According to the versions of the vim packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - NULL Pointer Dereference in GitHub repository vim/vim prior to 8.2.4959. CVE-2022-1725 - Buffer Over-read in GitHub repository vim/v...
EulerOS Virtualization 3.0.6.6 : ppp (EulerOS-SA-2023-2433)
According to the versions of the ppp package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - A vulnerability classified as problematic has been found in ppp. Affected is the function dumpppp of the file pppdump/pppdump.c of th...
Cisco NX-OS Software IPv6 Denial of Service (CVE-2019-1964)
A vulnerability in the IPv6 traffic processing of Cisco NX-OS Software could allow an unauthenticated, remote attacker to cause an unexpected restart of the netstack process on an affected device. The vulnerability is due to improper validation of IPv6 traffic sent through an affected device. An...
Linux Kernel Buffer Overflow Vulnerability
Linux kernel is the kernel used by Linux, the open source operating system of the Linux Foundation in the United States. An out-of-bounds read vulnerability exists in the Linux kernel, which stems from improper validation of user-supplied data and can be exploited by an attacker to cause an...
funds can be stolen in InterchainGovernance, Multisig and AxelarServiceGovernance contracts
Lines of code Vulnerability details Impact In InterchainGovernance users can execute the proposal by passing required data and the amount of native value they want to send with executeProposal function, this function calls call function in Caller contract, but this function insted of checking...
Improper Validation
agpt is vulnerable to Improper Validation. The vulnerability exists due to a lack of validated ANSI escape sequences in logs.py, which allow an attacker to publish false messages to the terminal by tricking the LLM into reciting JSON-encoded ANSI escape sequences...