20575 matches found
Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') in puma
Impact Prior to version 6.3.1, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies and zero-length Content-Length headers in a way that allowed HTTP request smuggling. The following vulnerabilities are addressed by this advisory: - Incorrect parsing of trailing fields ...
PT-2023-6141
Name of the Vulnerable Software and Affected Versions Puma versions prior to 6.3.1 Puma versions prior to 5.6.7 Description The issue is related to incorrect behavior when parsing chunked transfer encoding bodies and zero-length Content-Length headers, allowing HTTP request smuggling. This could ...
Fedora 37 : llhttp / python-aiohttp (2023-105880e618)
The remote Fedora 37 host has packages installed that are affected by a vulnerability as referenced in the FEDORA-2023-105880e618 advisory. Update llhttp to 8.1.1 including a SONAME version bump and ABI break, https://pagure.io/fesco/issue/3049 and python-aiohttp to 3.8.5. Fixes CVE-2023-30589...
CVE-2023-20232
A vulnerability in the Tomcat implementation for Cisco Unified Contact Center Express Unified CCX could allow an unauthenticated, remote attacker to cause a web cache poisoning attack on an affected device. This vulnerability is due to improper input validation of HTTP requests. An attacker could...
HTTP Request Smuggling
tornado is vulnerable to HTTP Request Smuggling. Tornado deviates from HTTP RFCs by interpreting the characters -, +, and in chunk length and Content-Length values. When used behind proxies that interpret non-standard characters differently, which can lead to request smuggling...
Zyxel NBG6604 Command Injection Vulnerability (CNVD-2023-64085)
The Zyxel NBG6604 is a dual-band wireless router from China's Hopkins Zyxel. The Zyxel NBG6604 V1.01ABIR.1C0 suffers from a command injection vulnerability that stems from a failure to properly filter constructed command special characters, commands, etc. in the NTP function. An attacker can...
Oracle Linux 8 : nodejs:16 (ELSA-2023-4537)
The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2023-4537 advisory. - Rebase to 16.20.1 Resolves: rhbz2188289 Resolves: CVE-2023-30581 CVE-2023-30588 CVE-2023-30589 CVE-2023-30590 Tenable has extracted the preceding...
Design/Logic Flaw
LiteSpeed OpenLiteSpeed before 1.7.18 does not strictly validate HTTP request headers...
Command injection
A post-authentication command injection vulnerability in the NTP feature of Zyxel NBG6604 firmware version V1.01ABIR.1C0 could allow an authenticated attacker to execute some OS commands remotely by sending a crafted HTTP request...
CVE-2023-33013
A post-authentication command injection vulnerability in the NTP feature of Zyxel NBG6604 firmware version V1.01ABIR.1C0 could allow an authenticated attacker to execute some OS commands remotely by sending a crafted HTTP request...
CVE-2023-33013
A post-authentication command injection vulnerability in the NTP feature of Zyxel NBG6604 firmware version V1.01ABIR.1C0 could allow an authenticated attacker to execute some OS commands remotely by sending a crafted HTTP request...
SUSE-SU-2023:3306-1 Security update for nodejs14
This update for nodejs14 fixes the following issues: - CVE-2023-32002: Fixed permissions policies bypass via Module.load bsc1214150. - CVE-2023-32006: Fixed permissions policies impersonation using module.constructor.createRequire bsc1214156. - CVE-2023-32559: Fixed permissions policies bypass vi...
CVE-2023-40518
LiteSpeed OpenLiteSpeed before 1.7.18 does not strictly validate HTTP request headers...
CVE-2023-40518
LiteSpeed OpenLiteSpeed before 1.7.18 does not strictly validate HTTP request headers...
CVE-2023-33013: Improper Neutralization of Special Elements used in an OS Command
A post-authentication command injection vulnerability in the NTP feature of Zyxel NBG6604 firmware version V1.01ABIR.1C0 could allow an authenticated attacker to execute some OS commands remotely by sending a crafted HTTP request...
CVE-2023-40518: Undefined Security Weakness
LiteSpeed OpenLiteSpeed before 1.7.18 does not strictly validate HTTP request headers...
PT-2026-92037
Name of the Vulnerable Software and Affected Versions Tornado versions prior to 6.3.3 Description Improper parsing of Content-Length headers and chunk lengths allows the acceptance of non-standard characters such as -, +, and . This occurs because the int constructor is used to parse these values...
PT-2023-27496
Name of the Vulnerable Software and Affected Versions OpenLiteSpeed versions prior to 1.7.18 Description The issue arises from the software not strictly validating HTTP request headers. Recommendations For versions prior to 1.7.18, update to version 1.7.18 or later to resolve the issue...