149071 matches found
CVE-2026-112103 f3-factory fatfree-core HTTP Client web.php _curl certificate validation
A vulnerability has been found in f3-factory fatfree-core up to 3.9.2. This vulnerability affects the function curl of the file web.php of the component HTTP Client. Such manipulation leads to improper certificate validation. The attack may be performed from remote. Attacks of this nature are...
CVE-2026-112103
A vulnerability exists in f3-factory fatfree-core up to version 3.9.2 within the HTTP Client component. Specifically, the _curl function in the web.php file is susceptible to improper certificate validation . While the attack can be performed remotely, it is noted as highly complex with difficult...
SUSE-SU-2026:24279-1 Security update for docker
This update for docker fixes the following issues: Security issues fixed: - CVE-2026-33814: golang.org/x/net/http2: infinite loop in HTTP/2 transport when given bad SETTINGSMAXFRAMESIZE bsc1265782. - CVE-2026-39821: golang.org/x/net/idna: failure to reject ASCII-only Punycode-encoded labels allow...
Exploit for CVE-2026-84180
CVE-2026-84180 — camel-knative: HTTP consumer information disc...
Exploit for CVE-2026-84176
CVE-2026-84176 — camel-platform-http-vertx: CORS credential ex...
Astra Linux – vulnerability in Apache2
A memory allocation vulnerability with an excessively large value in Apache HTTP Server’s modhttp module can lead to denial of service via malicious HTTP requests. This issue affects Apache HTTP Server versions 2.4.17 through 2.4.67...
Astra Linux – vulnerability in containerd-app
Due to a missing null check, sending HTTP/2 frames with values 0x0a–0x0f can cause a running server to panic...
Astra Linux – vulnerability in Apache2
A buffer underwrite vulnerability exists in the Apache HTTP Server due to specially crafted regular expressions in the configuration. This issue affects Apache HTTP Server versions 2.4.0 through 2.4.67. Users are advised to upgrade to version 2.4.68, which resolves the issue...
Astra Linux – vulnerability in Firefox and Thunderbird
Use-after-free in the Networking: HTTP component. This vulnerability has been fixed in Firefox 152, Firefox ESR 140.12, Firefox ESR 115.37, Thunderbird 152, and Thunderbird 140.12...
Astra Linux – vulnerability in Node.js
A memory leak occurs in Node.js HTTP/2 servers when a client sends WINDOWUPDATE frames on stream 0 connection-level that cause the flow control window to exceed the maximum value of 2³¹-1. The server correctly sends a GOAWAY frame, but the Http2Session object is never cleaned up. This vulnerabili...
Astra Linux – vulnerability in libhttp-daemon-perl
HTTP::Daemon versions prior to 6.17 for Perl allow OS command injection via sendfile. sendfile opens its string argument using Perl’s two-argument open mechanism. The two-argument form interprets special prefixes: ‘| cmd’ and ‘cmd |’ open a pipe to a subprocess; ‘ path’ and ‘ path’ open the...
Astra Linux – vulnerability in Apache2
A cross-site scripting vulnerability exists in modproxyftp’s HTML directory list generation in Apache HTTP Server 2.4.67 and earlier when listing FTP directory contents via forward or reverse proxy configuration. Users are recommended to upgrade to version 2.4.68, which fixes this issue...
Astra Linux – vulnerability in Apache2
A buffer overflow in modproxyhtml in Apache HTTP Server 2.4.67 and earlier allows an attack by an untrusted backend. Users are recommended to upgrade to version 2.4.68, which fixes this issue...
Astra Linux – vulnerability in Apache2
The Loop with Unreachable Exit Condition ‘Infinite Loop’ vulnerability exists in the modproxyftp module of the Apache HTTP Server when an attacker controls a backend FTP server. This issue affects versions 2.4.0 through 2.4.67. Users are advised to upgrade to version 2.4.68, which resolves the...
Astra Linux – vulnerability in Apache2
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with modxml2enc, xml2StartParse, and untrusted content This issue affects Apache HTTP Server versions 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue...
Astra Linux – vulnerability in Apache2
The Use After Free vulnerability in the modhttp2 module of the Apache HTTP Server occurs when file handles have already been exhausted. This issue affects Apache HTTP Server versions 2.4.55 through 2.4.67...
Astra Linux – vulnerability in dovecot
Doveadm credentials are verified via direct comparison, which is vulnerable to timing oracle attacks. An attacker can exploit this to determine the configured credentials. Knowing these credentials grants full access to the affected component. Access to the Doveadm HTTP service port must be...
Astra Linux – vulnerability in Apache2
Buffer over-read vulnerability in Apache HTTP Server caused by outbound OCSP requests to an attacker-controlled OCSP server This issue affects Apache HTTP Server versions 2.4.0 through 2.4.67. Users are advised to upgrade to version 2.4.68, which resolves the issue...
Astra Linux – vulnerability in Apache2
Buffer over-read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server versions up to and including 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue...
Astra Linux – vulnerability in Apache2
Out-of-bounds read vulnerability in modproxyajp of Apache HTTP Server. This issue affects Apache HTTP Server versions up to and including 2.4.66. Users are advised to upgrade to version 2.4.67, which fixes the issue...