149071 matches found
org.apache.camel.quarkus:camel-quarkus-integration-test-knative (>=3.35.0, <=3.39.0), org.apache.camel.quarkus:camel-quarkus-knative (>=3.35.0, <=3.39.0) +5 more potentially affected by CVE-2026-84180 via org.apache.camel:camel-knative-http (>=4.20.0, <=4.22.0)
org.apache.camel:camel-knative-http MAVEN version =4.20.0, =3.35.0, =3.35.0, =3.35.0, =3.35.0, =3.35.0, =3.35.0, =3.35.0, =3.39.0 Source cves: CVE-2026-84180 Source advisory: SNYK:JAVA-ORGAPACHECAMEL-21430453...
org.apache.camel.quarkus:camel-quarkus-integration-test-knative (>=3.35.0, <=3.39.0), org.apache.camel.quarkus:camel-quarkus-knative (>=3.35.0, <=3.39.0) +7 more potentially affected by CVE-2026-84180 via org.apache.camel:camel-knative (>=4.19.0, <=4.22.0)
org.apache.camel:camel-knative MAVEN version =4.19.0, =3.35.0, =3.35.0, =3.35.0, =3.35.0, =3.35.0, =3.35.0, =3.35.0, =4.19.0, =4.19.0, =4.22.0 Source cves: CVE-2026-84180 Source advisory: SNYK:JAVA-ORGAPACHECAMEL-21430451...
Information Exposure
Overview Affected versions of this package are vulnerable to Information Exposure via the KnativeHttpConsumer in the camel-knative HTTP consumer. An external sender can trigger a consumer-side route failure by sending a request that causes exchange processing to fail, then read the exception clas...
Important: Red Hat Security Advisory: pcs security update
An update for pcs is now available for Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions and Red Hat Enterprise Linux 8.8 Telecommunications Update Service. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System...
python-tornado: Tornado before 6.4.1 HTTP Request Smuggling via Transfer-Encoding
A vulnerability was discovered in Tornado where it improperly handles HTTP requests containing duplicate Transfer-Encoding: chunked headers. When duplicate Transfer-Encoding headers are present in an incoming request, Tornado ignores them and treats the request as body-less, leaving the chunked...
`wasi-http`: Guests can add conflicting content lengths to messages
This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-r8xh-cgf7-392j For more information see the GitHub-hosted security advisory...
`wasi-http` p3: Guests can set incorrect content-length for spliced response bodies
This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-9prg-84vf-g5fc For more information see the GitHub-hosted security advisory...
`wasi-http` p3: forwarded trailers aren't checked against `is_forbidden_header` hook
This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-jxcf-8qw5-5c33 For more information see the GitHub-hosted security advisory...
python-tornado: Tornado before 6.4.1 HTTP Request Smuggling via Transfer-Encoding
A vulnerability was discovered in Tornado where it improperly handles HTTP requests containing duplicate Transfer-Encoding: chunked headers. When duplicate Transfer-Encoding headers are present in an incoming request, Tornado ignores them and treats the request as body-less, leaving the chunked...
Important: Red Hat Security Advisory: pcs security update
An update for pcs is now available for Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support and Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability...
USN-8935-1 golang-1.22 vulnerabilities
It was discovered that Go did not enforce a maximum recursion depth when parsing deeply nested ASN.1 structures. An attacker could possibly use this issue to cause Go to crash, resulting in a denial of service. CVE-2026-33818 It was discovered that Go incorrectly reset the depth counter when...
USN-8935-1: Go vulnerabilities
It was discovered that Go did not enforce a maximum recursion depth when parsing deeply nested ASN.1 structures. An attacker could possibly use this issue to cause Go to crash, resulting in a denial of service. CVE-2026-33818 It was discovered that Go incorrectly reset the depth counter when...
BIT-ASPNET-CORE-2026-88092 ASP.NET Core Tampering Vulnerability
Inconsistent interpretation of http requests 'http request/response smuggling' in ASP.NET Core allows an unauthorized attacker to perform tampering over a network...
Security Bulletin: Platform Navigator and Automation Assets in IBM Integration are vulnerable to multiple vulnerabilities in undici
Summary Platform Navigator and Automation Assets in IBM Integration are vulnerable to multiple vulnerabilities in undici. CVE-2026-18540, CVE-2026-19534, CVE-2026-85024 Theses vulnerabilities have been addressed. Vulnerability Details CVEID:CVE-2026-18540 DESCRIPTION: undici's retry interceptor c...
CVE-2026-85317
Use of Cache Containing Sensitive Information vulnerability in Apache Camel HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The OAuth2 client token cache is global to the JVM, and its key omitted several of the fields that determine what a tok...
CVE-2026-85316
Insufficient Granularity of Access Control vulnerability in Apache Camel Platform HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The component decided whether an endpoint ran in proxy mode by testing whether its configured path started with t...
CVE-2026-85254
Improper Handling of Case Sensitivity vulnerability in Apache Camel Platform HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The guard that prevents a request header being reflected into the response compared header names case sensitively, whi...
CVE-2026-85251
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Camel HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. Two paths handed credentials to a redirect target, which is a host chosen by the remote server rather than...
CVE-2026-84180
Generation of Error Message Containing Sensitive Information vulnerability in Apache Camel Knative component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. When processing of an exchange failed on the consumer side, the Knative HTTP consumer wrote the...
CVE-2026-80343
Improper Handling of Case Sensitivity vulnerability in Apache Camel Netty HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The camel-netty-http security constraint compared the request path against the configured context path using a...