50131 matches found
CVE-2026-61666
websocket-driver is a WebSocket protocol handler with pluggable I/O. Prior to 0.8.2, WebSocket::Driver.server passes a malformed Host header to URI.parse in lib/websocket/http/request.rb without catching URI::InvalidURIError, allowing a remote client to crash a TCP-backed WebSocket server when th...
CVE-2026-61666
CVE-2026-61666 affects the Ruby gem websocket-driver (a WebSocket protocol handler with pluggable I/O). In versions prior to 0.8.2 , WebSocket::Driver.server() passes a malformed Host header to URI.parse in lib/websocket/http/request.rb without catching URI::InvalidURIError. A remote client can e...
kernel: netfilter: nft_inner: Fix IPv6 inner_thoff desync
A flaw was found in the Linux kernel's netfilter subsystem, specifically within the nftinner module. This vulnerability arises from an incorrect handling of IPv6 inner packet processing, where the transport header offset innerthoff becomes desynchronized from the Layer 4 protocol l4proto. A remot...
kernel: netfilter: nft_inner: Fix IPv6 inner_thoff desync
A flaw was found in the Linux kernel's netfilter subsystem, specifically within the nftinner module. This vulnerability arises from an incorrect handling of IPv6 inner packet processing, where the transport header offset innerthoff becomes desynchronized from the Layer 4 protocol l4proto. A remot...
CVE-2026-72296
A flaw was found in the Linux kernel's In-band Flow Engine IFE component. A remote attacker could send a specially crafted IFE frame with a malformed inner Ethernet header. This improper handling of the packet structure could lead to a system crash, resulting in a Denial of Service DoS. Mitigatio...
CVE-2026-74882
opensslencrypt versions before 1.4.0 contain an insecure default configuration that trusts the entire RFC 1918 private address space in IntegrityProxyConfig trustedproxies. Attackers on private networks can forge client certificate headers to bypass mTLS authentication when ProxyAuth validation i...
CVE-2026-74894
The PHP package openssl_encrypt before version 1.4.0 has a broken verify_api_token function that accepts any non-empty Bearer token, allowing unauthenticated attackers to upload arbitrary public keys, enumerate all keys, and revoke any user's keys. CVSS 9.8 Critical. Upgrade to 1.4.0. No in-the-w...
CVE-2026-74894
opensslencrypt before 1.4.0 contains an authentication bypass vulnerability in the verifyapitoken function that accepts any non-empty Bearer token string without validation. Attackers can upload arbitrary public keys, enumerate all keys, and revoke keys belonging to any user by providing any Bear...
CVE-2026-74882 openssl_encrypt before 1.4.0 Insecure Default Configuration
opensslencrypt versions before 1.4.0 contain an insecure default configuration that trusts the entire RFC 1918 private address space in IntegrityProxyConfig trustedproxies. Attackers on private networks can forge client certificate headers to bypass mTLS authentication when ProxyAuth validation i...
CVE-2026-74882
opensslencrypt versions before 1.4.0 contain an insecure default configuration that trusts the entire RFC 1918 private address space in IntegrityProxyConfig trustedproxies. Attackers on private networks can forge client certificate headers to bypass mTLS authentication when ProxyAuth validation i...
Signature Bypass
Apache CXF is vulnerable to signature Bypass. The vulnerability is due to insufficient verification of metadata signatures, where the JwsJsonContainerRequestFilter processes metadata without confirming it was authenticated by the accepted signature, and attackers can supply unauthenticated...
BIT-NODE-MIN-2026-58044
A flaw in Node.js HTTP client can cause a request desynchronization for Node.js-based forwarding proxies that rebuild outbound headers from the visible IncomingMessage headers while piping the original body to a reused backend connection. Node.js can omit headers beyond maxHeadersCount /...
BIT-NODE-2026-58044
A flaw in Node.js HTTP client can cause a request desynchronization for Node.js-based forwarding proxies that rebuild outbound headers from the visible IncomingMessage headers while piping the original body to a reused backend connection. Node.js can omit headers beyond maxHeadersCount /...
BIT-OPENBAO-2026-46358 OpenBao's Inline Auth Incorrectly Redacted Headers
OpenBao is an open source identity-based secrets management system. Prior to version 2.5.4, OpenBao's inline auth functionality incorrectly redacted audit log entries, resulting in non-auth headers being removed and auth-related headers being retained in cleartext. This requires an attacker to...
K000162941: NodeJS vulnerability CVE-2026-58044
Security Advisory Description A flaw in Node.js HTTP client can cause a request desynchronization for Node.js-based forwarding proxies that rebuild outbound headers from the visible IncomingMessage headers while piping the original body to a reused backend connection. Node.js can omit headers...
CVE-2026-12630: Out-of-bounds Read
Zephyr's 6LoWPAN IP Header Compression IPHC uncompression code contains an out-of-bounds read in getihpcinlinedsize subsys/net/ip/6lo.c. The destination inline size is looked up in dainlinesizetable, which has 13 entries, using an index built from the M, DAC and DAM bits of the received IPHC...
PT-2026-73402
A flaw in Node.js HTTP client can cause a request desynchronization for Node.js-based forwarding proxies that rebuild outbound headers from the visible IncomingMessage headers while piping the original body to a reused backend connection. Node.js can omit headers beyond maxHeadersCount /...
CVE-2026-68005
An issue in ACME mini_httpd 1.30 and prior versions allows a remote attacker to cause a denial of service (DoS). The vulnerability is located in the HTTP request header parser specifically within the handle_request() function. While several sources confirm the existence of this vulnerability, the...
PT-2026-76774
Name of the Vulnerable Software and Affected Versions ACME mini httpd versions prior to 1.31 Description A remote attacker can cause a denial of service through the HTTP request header parser within the handle request function. Recommendations Update ACME mini httpd to version 1.31 or later. As a...