45498 matches found
NewStart CGSL MAIN 7.02 : python-webob Vulnerability (NS-SA-2026-0107)
The remote NewStart CGSL host, running version MAIN 7.02, has python-webob packages installed that are affected by a vulnerability: - WebOb provides objects for HTTP requests and responses. When WebOb normalizes the HTTP Location header to include the request hostname, it does so by parsing the U...
EulerOS 2.0 SP12 : nmap (EulerOS-SA-2026-3362)
According to the versions of the nmap packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : Nmap through 7.99 does not keep the IPv6 extension-header walk within the captured packet in ipv6getdataprimitive libnetutil/netutil.cc, so the...
RHCOS 4 : OpenShift Container Platform 4.22.13 (RHSA-2026:63091)
The remote Red Hat Enterprise Linux CoreOS 4 host has a package installed that is affected by multiple vulnerabilities as referenced in the RHSA-2026:63091 advisory. - net/http/internal/http2: golang: golang.org/x/net: Go HTTP/2: Denial of Service via malformed SETTINGSMAXFRAMESIZE frame...
NewStart CGSL MAIN 7.02 : python-PyJWT Multiple Vulnerabilities (NS-SA-2026-0091)
The remote NewStart CGSL host, running version MAIN 7.02, has python-PyJWT packages installed that are affected by multiple vulnerabilities: - PyJWT is a JSON Web Token implementation in Python. Prior to 2.12.0, PyJWT does not validate the crit Critical Header Parameter defined in RFC 7515 4.1.11...
EulerOS 2.0 SP12 : python-pip (EulerOS-SA-2026-3301)
According to the versions of the python-pip packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : pip would treat consolescripts and guiscripts as paths instead of file names without sanitizing the resolved absolute path to the installation...
CVE-2026-44756: Buffer Copy without Checking Size of Input
A memory safety vulnerability exists in the Extended Passport Protocol EPP processing library. Under specific conditions, an unauthenticated attacker could exploit a crafted network request containing a malformed EPP header, potentially resulting in undefined behavior and abnormal program...
PT-2026-87187
Name of the Vulnerable Software and Affected Versions DeepSeek Harness versions prior to 0.1.2-alpha.1 Description An authentication bypass exists in the local HTTP agent-control API. The system grants unauthenticated access by accepting a client-supplied loopback Host header instead of validatin...
PT-2026-86947
Name of the Vulnerable Software and Affected Versions SAP affected versions not specified Description A memory safety issue exists in the Extended Passport Protocol EPP processing library within the shared SAP kernel code. An unauthenticated attacker can exploit this by sending a crafted network...
NewStart CGSL MAIN 7.02 : perl-Archive-Tar Multiple Vulnerabilities (NS-SA-2026-0090)
The remote NewStart CGSL host, running version MAIN 7.02, has perl-Archive-Tar packages installed that are affected by multiple vulnerabilities: - Archive::Tar versions before 3.08 for Perl extract symlinks with attacker controlled targets outside the extraction directory. makespecialfile passes...
NewStart CGSL MAIN 7.02 : libsoup Multiple Vulnerabilities (NS-SA-2026-0100)
The remote NewStart CGSL host, running version MAIN 7.02, has libsoup packages installed that are affected by multiple vulnerabilities: - A flaw was found in libsoup. An integer underflow vulnerability occurs when processing content with a zero-length resource, leading to a buffer overread. This...
EulerOS 2.0 SP12 : nghttp2 (EulerOS-SA-2026-3361)
According to the versions of the nghttp2 package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : nghttp2's nghttpx proxy through 1.69.0 forwards an HTTP/1.1 Upgrade request that also carries a Content- Length header and body onto reusable...
CVE-2026-82756
Improper Encoding or Escaping of Output vulnerability in ash-project ashauthenticationoauth2server allows an unauthenticated attacker to inject arbitrary authentication parameters into the WWW-Authenticate challenge header. BearerPlug and RequireScopePlug built the Bearer resourcemetadata="..."...
CVE-2026-82756 ash_authentication_oauth2_server interpolates a tenant-derived value into the WWW-Authenticate challenge without escaping, allowing header parameter injection
Improper Encoding or Escaping of Output vulnerability in ash-project ashauthenticationoauth2server allows an unauthenticated attacker to inject arbitrary authentication parameters into the WWW-Authenticate challenge header. BearerPlug and RequireScopePlug built the Bearer resourcemetadata="..."...
CVE-2026-82756
ash_authentication_oauth2_server (ash-project) is vulnerable to header parameter injection in its BearerPlug and RequireScopePlug. A tenant-derived resource_metadata URL is interpolated directly into the WWW-Authenticate challenge without escaping, allowing an unauthenticated attacker in a multi-...
CVE-2026-82756 ash_authentication_oauth2_server interpolates a tenant-derived value into the WWW-Authenticate challenge without escaping, allowing header parameter injection
Improper Encoding or Escaping of Output vulnerability in ash-project ashauthenticationoauth2server allows an unauthenticated attacker to inject arbitrary authentication parameters into the WWW-Authenticate challenge header. BearerPlug and RequireScopePlug built the Bearer resourcemetadata="..."...
EEF-CVE-2026-82756 ash_authentication_oauth2_server interpolates a tenant-derived value into the WWW-Authenticate challenge without escaping, allowing header parameter injection
Summary Improper Encoding or Escaping of Output vulnerability in ash-project ashauthenticationoauth2server allows an unauthenticated attacker to inject arbitrary authentication parameters into the WWW-Authenticate challenge header. BearerPlug and RequireScopePlug built the Bearer...
CVE-2026-82756 ash_authentication_oauth2_server interpolates a tenant-derived value into the WWW-Authenticate challenge without escaping, allowing header parameter injection
Improper Encoding or Escaping of Output vulnerability in ash-project ashauthenticationoauth2server allows an unauthenticated attacker to inject arbitrary authentication parameters into the WWW-Authenticate challenge header. BearerPlug and RequireScopePlug built the Bearer resourcemetadata="..."...
EUVD-2026-72538
Improper Encoding or Escaping of Output vulnerability in ash-project ashauthenticationoauth2server allows an unauthenticated attacker to inject arbitrary authentication parameters into the WWW-Authenticate challenge header. BearerPlug and RequireScopePlug built the Bearer resourcemetadata="..."...
CVE-2026-82755
ash_authentication_oauth2_server (ash-project, versions 0.1.3 through before 0.3.1) suffers from a cache-poisoning issue in its RFC 8414 / RFC 9728 metadata endpoints (AshAuthentication.Phoenix.Oauth2Server.ProtocolRouter). When a tenant is derived from a header or Host value rather than the URL,...
CVE-2026-82755 ash_authentication_oauth2_server serves tenant-specific OAuth metadata as publicly cacheable without Vary, enabling cross-tenant confusion
Use of Cache Containing Sensitive Information vulnerability in ash-project ashauthenticationoauth2server allows a shared HTTP cache to serve one tenant's OAuth discovery metadata to another tenant's clients. The RFC 8414 and RFC 9728 metadata endpoints in...