273 matches found
untitledgoosetool
Untitled Goose Tool The Goose is loose. Table of Contents About Getting Started Prerequisites Requirements Installing Usage Config GUI Auth Csv Honk Messagetrace Recommended Default Workflow Recommended Workflow for UAL Call with Time Bounds Considerations Known Issues Acknowledgements Contributi...
CVE-2026-52134-libiec61850
CVE-2026-52134: GOOSE replay and message-freshness handling in libiec61850 v1.6 Status CVE-2026-52134 has been assigned. Publication of the corresponding CVE Record is pending. Affected product Vendor: MZ Automation GmbH Product: libiec61850 Tested version: 1.6 Status of other versions: Not...
OPENSUSE-SU-2026:12288-1 goose-1.56.0-1.1 on GA media
These are all security issues fixed in the goose-1.56.0-1.1 package on the GA media of openSUSE Tumbleweed...
SUSE CVE-2026-111079
A flaw was found in Goose. When the terminal integration feature is enabled, the application captures shell command history and sends it verbatim without sanitization to configured Large Language Model LLM provider endpoints during queries. If a user enters sensitive data-such as API tokens,...
CVE-2026-111079
A flaw was found in Goose. When the terminal integration feature is enabled, the application captures shell command history and sends it verbatim without sanitization to configured Large Language Model LLM provider endpoints during queries. If a user enters sensitive data—such as API tokens,...
CVE-2026-111079 Goose: goose: shell history and environment leak via terminal integration
A flaw was found in Goose. When the terminal integration feature is enabled, the application captures shell command history and sends it verbatim without sanitization to configured Large Language Model LLM provider endpoints during queries. If a user enters sensitive data—such as API tokens,...
CVE-2026-111079 Goose: goose: shell history and environment leak via terminal integration
A flaw was found in Goose. When the terminal integration feature is enabled, the application captures shell command history and sends it verbatim without sanitization to configured Large Language Model LLM provider endpoints during queries. If a user enters sensitive data—such as API tokens,...
EUVD-2026-108113
A flaw was found in Goose. When the terminal integration feature is enabled, the application captures shell command history and sends it verbatim without sanitization to configured Large Language Model LLM provider endpoints during queries. If a user enters sensitive data—such as API tokens,...
CVE-2026-111079
A vulnerability exists in Goose where the terminal integration feature captures shell command history and transmits it verbatim to Large Language Model (LLM) provider endpoints without sanitization. If a user inputs sensitive data such as API tokens, passwords, or environment variables , this inf...
CVE-2026-111079
A flaw was found in Goose. When the terminal integration feature is enabled, the application captures shell command history and sends it verbatim without sanitization to configured Large Language Model LLM provider endpoints during queries. If a user enters sensitive data—such as API tokens,...
PT-2026-121335
Name of the Vulnerable Software and Affected Versions Goose affected versions not specified Description A flaw exists when the terminal integration feature is enabled, causing the application to capture shell command history and send it without sanitization to configured Large Language Model LLM...
Red Hat: CVE-2026-111079: goose: goose: Shell History and Environment Leak via Terminal Integration
A flaw was found in Goose. When the terminal integration feature is enabled, the application captures shell command history and sends it verbatim without sanitization to configured Large Language Model LLM provider endpoints during queries. If a user enters sensitive data—such as API tokens,...
Linux Distros Unpatched Vulnerability : CVE-2026-111079
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A flaw was found in Goose. When the terminal integration feature is enabled, the application captures shell command history and sends it verbatim without...
Linux Distros Unpatched Vulnerability : CVE-2026-109561
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - goose from 1.28.0 before 1.44.0 contains an authorization bypass vulnerability that allows tools to run without user approval in Manual Approval mode because...
RHEL 10 : goose (RHSA-2026:80765)
The remote Redhat Enterprise Linux 10 host has a package installed that is affected by multiple vulnerabilities as referenced in the RHSA-2026:80765 advisory. For details on how to apply this update, which includes the changes described in this advisory, refer to:...
RHEL 9 : goose (RHSA-2026:80764)
The remote Redhat Enterprise Linux 9 host has a package installed that is affected by multiple vulnerabilities as referenced in the RHSA-2026:80764 advisory. For details on how to apply this update, which includes the changes described in this advisory, refer to:...
CVE-2026-109561
A flaw was found in goose. An authorization bypass vulnerability allows tools to run without required user confirmation even when manual approval mode is selected. This occurs because read-only tool annotations from previous sessions are not properly cleared when switching approval modes...
CVE-2026-109561
goose from 1.28.0 before 1.44.0 contains an authorization bypass vulnerability that allows tools to run without user approval in Manual Approval mode because persisted read-only annotations are never cleared by updategoosemode. After a session uses Smart Approval mode, prompt-injected calls to...
CVE-2026-109561
The goose tool (versions 1.28.0 before 1.44.0 ) is vulnerable to an authorization bypass in its permission handling. The root cause is that persisted read-only annotations are not cleared by the update_goose_mode function. This allows an attacker to use prompt injection to execute tools without u...
CVE-2026-109561
goose from 1.28.0 before 1.44.0 contains an authorization bypass vulnerability that allows tools to run without user approval in Manual Approval mode because persisted read-only annotations are never cleared by updategoosemode. After a session uses Smart Approval mode, prompt-injected calls to...