13521 matches found
kcp's impersonation allows access to global administrative groups
Impact Impersonation is a feature of the Kubernetes API, allowing to override user information. As downstream project, kcp inherits this feature. As per the linked documentation a specific level of privilege usually assigned to cluster admins is required for impersonation. The vulnerability in kc...
GHSA-C7XH-GJV4-4JGV kcp's impersonation allows access to global administrative groups
Impact Impersonation is a feature of the Kubernetes API, allowing to override user information. As downstream project, kcp inherits this feature. As per the linked documentation a specific level of privilege usually assigned to cluster admins is required for impersonation. The vulnerability in kc...
GHSA-VM32-9RQF-RH3R pnpm no-script global cache poisoning via overrides / `ignore-scripts` evasion
Summary pnpm seems to mishandle overrides and global cache: 1. Overrides from one workspace leak into npm metadata saved in global cache 2. npm metadata from global cache affects other workspaces 3. installs by default don't revalidate the data including on first lockfile generation This can make...
pnpm no-script global cache poisoning via overrides / `ignore-scripts` evasion
Summary pnpm seems to mishandle overrides and global cache: 1. Overrides from one workspace leak into npm metadata saved in global cache 2. npm metadata from global cache affects other workspaces 3. installs by default don't revalidate the data including on first lockfile generation This can make...
CVE-2024-53866
The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other workspaces; and installs by default don't revalidate the data including on first...
CVE-2024-53866
The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other workspaces; and installs by default don't revalidate the data including on first...
CVE-2024-53866 pnpm vulnerable to no-script global cache poisoning via overrides / `ignore-scripts` evasion
The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other workspaces; and installs by default don't revalidate the data including on first...
CVE-2024-53866
The CVE-2024-53866 entry concerns pnpm before 9.15.0, where overrides from one workspace can leak into npm metadata stored in global cache, and global-cache data can affect other workspaces. This undermines global state integrity and can enable arbitrary code execution on installs, even when igno...
CVE-2024-53866
The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other workspaces; and installs by default don't revalidate the data including on first...
CVE-2024-53866 pnpm vulnerable to no-script global cache poisoning via overrides / `ignore-scripts` evasion
The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other workspaces; and installs by default don't revalidate the data including on first...
PT-2024-35964
Name of the Vulnerable Software and Affected Versions: pnpm versions prior to 9.15.0 Description: The package manager pnpm seems to mishandle overrides and global cache. This can lead to overrides from one workspace leaking into npm metadata saved in the global cache, affecting other workspaces...
pnpm code issues and vulnerabilities
pnpm is a package manager in the pnpm open source. A code issue vulnerability exists in pnpm 9.14.4 and earlier versions, which stems from the presence of a vulnerability that improperly handles overrides and global caching, which can lead to arbitrary code being run in subsequent installations...
CVE-2024-53866: Untrusted Search Path
The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other workspaces; and installs by default don't revalidate the data including on first...
openbabel:fuzz_convert: Global-buffer-overflow in OpenBabel::generate_sequence
Project: https://github.com/openbabel/openbabel.git Detailed Report: https://oss-fuzz.com/testcase?key=4910711186194432 Project: openbabel Fuzzing Engine: libFuzzer Fuzz Target: fuzzconvert Job Type: libfuzzerasanopenbabel Platform Id: linux Crash Type: Global-buffer-overflow READ 1 Crash Address...
[SECURITY] Fedora 40 Update: uv-0.5.5-2.fc40
An extremely fast Python package installer and resolver, written in Rust. Designed as a drop-in replacement for common pip and pip-tools workflows. Highlights: =E2=80=A2 =E2=9A=96=EF=B8=8F Drop-in replacement for common pip, pip-tools, and virtualenv commands. =E2=80=A2 =E2=9A=A1=EF=B8=8F 10-100x...
CVE-2024-11149
In OpenBSD 7.4 before errata 014, vmm4 did not restore GDTR limits properly on Intel VMX CPUs...
OpenBSD security vulnerabilities
OpenBSD is a cross-platform, BSD-based UNIX-like operating system from the Canadian OpenBSD organization. A security vulnerability exists in versions of OpenBSD prior to 7.4 that stems from vmm not properly recovering the GDTR limit on Intel CPUs...
Google Pixel security vulnerabilities
Google Pixel is a smartphone from Google, an American company. Google Pixel suffers from a security vulnerability that originates in the updategpssv and outputgpssv sections of vendor/mediatek/proprietary/hardware/connectivity/gps/gpshal/src/gpshalwor A missing bounds check in updategpssv and...
PT-2024-10658 · Mediatek · Mediatek Gps Hal
Name of the Vulnerable Software and Affected Versions: Mediatek GPS HAL affected versions not specified Description: The issue is related to a possible out of bounds write in the update gps sv and output vzw debug functions of the gpshal worker.c file, due to a missing bounds check. This could le...
Google Pixel security vulnerabilities
Google Pixel is a smartphone from Google USA. A security vulnerability exists in Google Pixel that stems from a lack of boundary checking in m3326gpswrite and m3326gpsread in gps.s. An out-of-bounds read may exist...