15686 matches found
Fedora 37 : rust-bat / rust-cargo-c / rust-exa / rust-git-delta / rust-gitui / etc (2023-e3c8abd37e)
The remote Fedora 37 host has packages installed that are affected by multiple vulnerabilities as referenced in the FEDORA-2023-e3c8abd37e advisory. This update contains rebuilds of all Rust applications against versions of the libgit2-sys crate that ship fixes for CVE-2022-24765 and CVE-2022-291...
[SECURITY] Fedora 37 Update: libgit2-1.3.2-1.fc37
libgit2 is a portable, pure C implementation of the Git core methods provided as a re-entrant linkable library with a solid API, allowing you to write native speed custom Git applications in any language with bindings...
Ubuntu: Security Advisory (USN-5216-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Fedora 37 : libgit2 (2023-470c7ea49e)
The remote Fedora 37 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2023-470c7ea49e advisory. Update to 1.3.2 CVE-2022-29187, CVE-2022-24765 Tenable has extracted the preceding description block directly from the Fedora security advisory. Not...
Debian: Security Advisory (DLA-3282-1)
The remote host is missing an update for the Debian SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Ubuntu: Security Advisory (USN-4769-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
GHSA-9W5J-4MWV-2WJ8 Remote code execution in simple-git
Versions of the package simple-git before 3.16.0 are vulnerable to Remote Code Execution RCE via the clone, pull, push and listRemote methods, due to improper input sanitization. This vulnerability exists due to an incomplete fix of CVE-2022-25912...
@51jbs/incremental-coverage-plugin (1.0.5), @51jbs/spec-plugin (2.0.0) +202 more potentially affected by CVE-2022-25860 via simple-git (>=3.0.3, <=3.15.1)
simple-git NPM version =3.0.3, =0.0.0-ad-beta.1, =0.0.0-aj-alpha.9, =1.4.0, =5.15.0, =10.0.0-version-usage.0, =1.0.1, =2.0.0, =1.1.0, =1.1.0, =0.0.0-semantic-release, =0.0.1-semantic-release - @colliercz/gatsby-transformer-gitinfo 1.3.0 and more Source cves: CVE-2022-25860 Source advisory:...
Remote code execution in simple-git
Versions of the package simple-git before 3.16.0 are vulnerable to Remote Code Execution RCE via the clone, pull, push and listRemote methods, due to improper input sanitization. This vulnerability exists due to an incomplete fix of CVE-2022-25912...
@51jbs/incremental-coverage-plugin (1.0.5), @51jbs/spec-plugin (2.0.0) +202 more potentially affected by CVE-2022-25860 via simple-git (>=3.0.3, <=3.15.1)
simple-git NPM version =3.0.3, =0.0.0-ad-beta.1, =0.0.0-aj-alpha.9, =1.4.0, =5.15.0, =10.0.0-version-usage.0, =1.0.1, =2.0.0, =1.1.0, =1.1.0, =0.0.0-semantic-release, =0.0.1-semantic-release - @colliercz/gatsby-transformer-gitinfo 1.3.0 and more Source cves: CVE-2022-25860 Source advisory:...
de.wellnerbou.jenkins:git-changelog (>=3.0, <=3.31) potentially affected by CVE-2023-24422 via org.jenkins-ci.plugins:script-security (1.46)
org.jenkins-ci.plugins:script-security MAVEN version 1.46 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - de.wellnerbou.jenkins:git-changelog =3.0, =3.31 Source cves: CVE-2023-24422 Source...
CVE-2022-25860
Versions of the package simple-git before 3.16.0 are vulnerable to Remote Code Execution RCE via the clone, pull, push and listRemote methods, due to improper input sanitization. This vulnerability exists due to an incomplete fix of CVE-2022-25912...
[SECURITY] [DLA 3282-1] git security update
------------------------------------------------------------------------- Debian LTS Advisory DLA-3282-1 [email protected] https://www.debian.org/lts/security/ Sylvain Beucler January 26, 2023 https://wiki.debian.org/LTS -...
simple-git security vulnerabilities
simple-git is a lightweight interface for running git commands in any node.js application. A security vulnerability exists in simple-git prior to version 3.16.0, which stems from the clone, pull, push, and listRemote methods not being properly cleaned up and escaped...
DLA-3282-1 git - security update
Bulletin has no description...
Debian dla-3282 : git - security update
The remote Debian 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-3282 advisory. - ------------------------------------------------------------------------- Debian LTS Advisory DLA-3282-1 [email protected]...
GHSA-QRG7-HFX7-95C5 Command injection in Git package in Wrangler
Impact A command injection vulnerability was discovered in Wrangler's Git package affecting versions up to and including v1.0.0. Wrangler's Git package uses the underlying Git binary present in the host OS or container image to execute Git operations. Specially crafted commands can be passed to...
Command injection in Git package in Wrangler
Impact A command injection vulnerability was discovered in Wrangler's Git package affecting versions up to and including v1.0.0. Wrangler's Git package uses the underlying Git binary present in the host OS or container image to execute Git operations. Specially crafted commands can be passed to...
GHSA-8FCJ-GF77-47MG Denial of service (DoS) when processing Git credentials
Impact A denial of services DoS vulnerability was discovered in Wrangler Git package affecting versions up to and including v1.0.0. Specially crafted Git credentials can result in a denial of service DoS attack on an application that uses Wrangler due to the exhaustion of the available memory and...
Denial of service (DoS) when processing Git credentials
Impact A denial of services DoS vulnerability was discovered in Wrangler Git package affecting versions up to and including v1.0.0. Specially crafted Git credentials can result in a denial of service DoS attack on an application that uses Wrangler due to the exhaustion of the available memory and...