15700 matches found
CVE-2024-35242: Improper Neutralization of Special Elements used in a Command
Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the composer install command running inside a git/hg repository which has specially crafted branch names can lead to command injection. This requires cloning untrusted repositories. Patches are availab...
CVE-2024-35241: Improper Neutralization of Special Elements used in a Command
Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the status, reinstall and remove commands with packages installed from source via git containing specially crafted branch names in the repository can be used to execute code. Patches for this issue are...
Exploit for OS Command Injection in Php
CVE-2024-4577 Vulnerability Checker This script is designed t...
Fedora: Security Advisory (FEDORA-2024-40ee18b2e7)
The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Fedora: Security Advisory for rust-git-delta (FEDORA-2024-40ee18b2e7)
The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Fedora: Security Advisory for rust-pretty-git-prompt (FEDORA-2024-40ee18b2e7)
The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
mrx-link (>=0.8.2, <=1.2.0), mrx-link-core (>=1.2.0.dev1, <=1.3.2.dev1) +1 more potentially affected by CVE-2024-35178 via jupyter-server (1.17.0)
jupyter-server PYPI version 1.17.0 is affected by a known vulnerability. The following packages have a transitive dependency on jupyter-server and may be impacted: - mrx-link =0.8.2, =1.2.0.dev1, =0.12.0.dev0, =1.0.2.dev1 Source cves: CVE-2024-35178 Source advisory: OSV:GHSA-HRW6-WG82-CM62...
mrx-link (>=0.8.2, <=1.2.0), mrx-link-core (>=1.2.0.dev1, <=1.3.2.dev1) +1 more potentially affected by CVE-2024-35178 via jupyter-server (1.17.0)
jupyter-server PYPI version 1.17.0 is affected by a known vulnerability. The following packages have a transitive dependency on jupyter-server and may be impacted: - mrx-link =0.8.2, =1.2.0.dev1, =0.12.0.dev0, =1.0.2.dev1 Source cves: CVE-2024-35178 Source advisory: OSV:PYSEC-2024-165...
jenkins-2-plugins: git-server plugin arbitrary file read vulnerability
A flaw was found in the Git Server Plugin for Jenkins. This issue could allow an attacker to read the first two lines of arbitrary files on the server's file system...
jenkins-2-plugins: git-server plugin arbitrary file read vulnerability
A flaw was found in the Git Server Plugin for Jenkins. This issue could allow an attacker to read the first two lines of arbitrary files on the server's file system...
jenkins-2-plugins: git-server plugin arbitrary file read vulnerability
A flaw was found in the Git Server Plugin for Jenkins. This issue could allow an attacker to read the first two lines of arbitrary files on the server's file system...
openSUSE Security Advisory (SUSE-SU-2024:1807-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Amazon Linux AMI : git (ALAS-2024-1939)
The version of git installed on the remote host is prior to 2.38.4-1.81. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS-2024-1939 advisory. Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, repositorie...
SUSE CVE-2022-36070
Poetry is a dependency manager for Python. To handle dependencies that come from a Git repository, Poetry executes various commands, e.g. git config. These commands are being executed using the executable's name and not its absolute path. This can lead to the execution of untrusted code due to th...
Mageia: Security Advisory (MGASA-2024-0204)
The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
MGASA-2024-0204 Updated git packages fix security vulnerabilities
Updated Git to version 2.41.1 to fix CVE-2024-32002 CVE-2024-32004 CVE-2024-32020 CVE-2024-32021 CVE-2024-32465...
Updated git packages fix security vulnerabilities
Updated Git to version 2.41.1 to fix CVE-2024-32002 CVE-2024-32004 CVE-2024-32020 CVE-2024-32021 CVE-2024-32465...
CVE-2024-36028
In the Linux kernel, the following vulnerability has been resolved: mm/hugetlb: fix DEBUGLOCKSWARNON1 when dissolvefreehugetlbfolio When I did memory failure tests recently, below warning occurs: DEBUGLOCKSWARNON1 WARNING: CPU: 8 PID: 1011 at kernel/locking/lockdep.c:232 lockacquire+0xccb/0x1ca0...
RHEL 8 : git (Unpatched Vulnerability)
The remote Redhat Enterprise Linux 8 host has one or more packages installed that are affected by a vulnerability that has been acknowledged by the vendor but will not be patched. - git: client prints server-sent ANSI escape codes to the terminal, allowing for unverified messages to potentially...
RHEL 8 : pcs (Unpatched Vulnerability)
The remote Redhat Enterprise Linux 8 host has one or more packages installed that are affected by multiple vulnerabilities that have been acknowledged by the vendor but will not be patched. - ejs: server-side template injection in outputFunctionName CVE-2022-29078 - The package handlebars before...