15404 matches found
CVE-2022-1440
Command Injection vulnerability in [email protected] in GitHub repository yarkeev/git-interface prior to 2.1.2. If both are provided by user input, then the use of a --upload-pack command-line argument feature of git is also supported for git clone, which would then allow for any operating syst...
CVE-2022-24828
Composer is a dependency manager for the PHP programming language. Integrators using Composer code to call VcsDriver::getFileContent can have a code injection vulnerability if the user can control the $file or $identifier argument. This leads to a vulnerability on packagist.org for example where...
CVE-2022-24826
On Windows, if Git LFS operates on a malicious repository with a ..exe file as well as a file named git.exe, and git.exe is not found in PATH, the ..exe program will be executed, permitting the attacker to execute arbitrary code. This does not affect Unix systems. Similarly, if the malicious...
CVE-2020-15272
In the git-tag-annotation-action open source GitHub Action before version 1.0.1, an attacker can execute arbitrary shell commands if they can control the value of the tag input or manage to alter the value of the GITHUBREF environment variable. The problem has been patched in version 1.0.1. If yo...
CVE-2020-4059
In mversion before 2.0.0, there is a command injection vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This vulnerability is patched by version 2.0.0. Previous releases are deprecated in npm. As a workaround,...
CVE-2020-26233
Git Credential Manager Core GCM Core is a secure Git credential helper built on .NET Core that runs on Windows and macOS. In Git Credential Manager Core before version 2.0.289, when recursively cloning a Git repository on Windows with submodules, Git will first clone the top-level repository and...
CVE-2024-50338
Git Credential Manager GCM is a secure Git credential helper built on .NET that runs on Windows, macOS, and Linux. The Git credential protocol is text-based over standard input/output, and consists of a series of lines of key-value pairs in the format key=value. Git's documentation restricts the...
Important: amazon-ssm-agent
Issue Overview: go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to git-upload-pack flags...
Important: amazon-ssm-agent
Issue Overview: go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to git-upload-pack flags...
Amazon Linux 2023 : amazon-ssm-agent (ALAS2023-2025-824)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-824 advisory. go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of thi...
Important: amazon-ssm-agent
Issue Overview: go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to git-upload-pack flags...
Amazon Linux 2 : amazon-ssm-agent (ALAS-2025-2739)
The version of amazon-ssm-agent installed on the remote host is prior to 3.3.1611.0-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2-2025-2739 advisory. go-git is a highly extensible git implementation library written in pure Go. An argument injection...
Important: amazon-ssm-agent
Issue Overview: go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to git-upload-pack flags...
MAL-2025-1126 Malicious code in git-scm.com (npm)
--- -= Per source details. Do not edit below this line.=- Source: ghsa-malware 93eb12d3d84e8c6651a80e2b684ba3fc83cf832f1fd9efe296c4cbfd3618c331 Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be...
Security update for git
This update for git fixes the following issues: git was updated to 2.45.1: CVE-2024-32002: recursive clones on case-insensitive filesystems that support symbolic links are susceptible to case confusion bsc1224168 CVE-2024-32004: arbitrary code execution during local clones bsc1224170...
SUSE-SU-2025:20049-1 Security update for git
This update for git fixes the following issues: git was updated to 2.45.1: CVE-2024-32002: recursive clones on case-insensitive filesystems that support symbolic links are susceptible to case confusion bsc1224168 CVE-2024-32004: arbitrary code execution during local clones bsc1224170...
Git LFS permits exfiltration of credentials via crafted HTTP URLs
...
CBL Mariner 2.0 Security Update: git-lfs (CVE-2024-53263)
The version of git-lfs installed on the remote CBL Mariner 2.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2024-53263 advisory. - Git LFS is a Git extension for versioning large files. When Git LFS requests credentials from Git for a...
PT-2025-1537
Name of the Vulnerable Software and Affected Versions Prusa PrusaSlicer versions prior to 2.6.2 Description A crafted 3mf project file can lead to arbitrary code execution on a host system during the process of slicing the project and exporting G-code. This issue occurs within the PostProcessor.c...
CVE-2023-45288 affecting package git-lfs for versions less than 3.6.1-1
CVE-2023-45288 affecting package git-lfs for versions less than 3.6.1-1. An upgraded version of the package is available that resolves this issue...