404 matches found
CVE-2026-103371
Insertion of Sensitive Information into Log File in Apache Geode Web Management. This issue affects Apache Geode: from 2.0.0 before 2.0.3. Users are recommended to upgrade to version 2.0.3, which fixes the issue...
CVE-2026-103371 Apache Geode: Management REST API: Insertion of Sensitive Information into Log File
Insertion of Sensitive Information into Log File in Apache Geode Web Management. This issue affects Apache Geode: from 2.0.0 before 2.0.3. Users are recommended to upgrade to version 2.0.3, which fixes the issue...
EUVD-2026-94553
Insertion of Sensitive Information into Log File in Apache Geode Web Management. This issue affects Apache Geode: from 2.0.0 before 2.0.3. Users are recommended to upgrade to version 2.0.3, which fixes the issue...
CVE-2026-103371
Apache Geode versions 2.0.0 through 2.0.3 are affected by a vulnerability where the Management REST API improperly inserts sensitive information into log files. This issue, identified as CWE-532 , could lead to the exposure of confidential data through system logs. To mitigate this risk, users ar...
CVE-2026-103371: Insertion of Sensitive Information into Log File
Insertion of Sensitive Information into Log File in Apache Geode Web Management. This issue affects Apache Geode: from 2.0.0 before 2.0.3. Users are recommended to upgrade to version 2.0.3, which fixes the issue...
PT-2026-107660
Insertion of Sensitive Information into Log File in Apache Geode Web Management. This issue affects Apache Geode: from 2.0.0 before 2.0.3. Users are recommended to upgrade to version 2.0.3, which fixes the issue...
Astra Linux – Vulnerability in Linux 5.10, Linux
In the Linux kernel, the following vulnerabilities have been resolved: hwrng: geode – Fixed the PCI device reference count leak issue. The function foreachpcidev is implemented through pcigetdevice. The comment accompanying pcigetdevice states that it will increase the reference count of the...
Insecure Directory Permissions
org.springframework.data, spring-data-geode is vulnerable to Insecure Directory Permissions. The vulnerability is due to snapshot archives being extracted into predictable, permissive directories under the system temporary location, which allows a local attacker with basic privileges on a shared...
Zip Slip Path Traversal
org.springframework.data, spring-data-geode is vulnerable to a Zip Slip Path Traversal. The vulnerability is due to improper validation of file paths during ZIP archive extraction, which allows an attacker to craft a malicious archive containing traversal paths and write files outside the intende...
@geode/opengeodeweb-front (>=9.13.1-rc.9, <=10.0.2-rc.4), @qingwave/cclens (>=0.1.0, <=0.2.0) +1 more potentially affected by CVE-2026-71321 via @nuxt/nitro-server (>=3.20.0, <=3.21.9)
@nuxt/nitro-server NPM version =3.20.0, =9.13.1-rc.9, =0.1.0, =3.20.0, =3.21.9 Source cves: CVE-2026-71321 Source advisory: SNYK:JS-NUXTNITROSERVER-18565113...
@geode/opengeodeweb-front (>=9.13.1-rc.9, <=10.0.2-rc.4), @qingwave/cclens (>=0.1.0, <=0.2.0) +1 more potentially affected by CVE-2026-71320 via @nuxt/nitro-server (>=3.20.0, <=3.21.9)
@nuxt/nitro-server NPM version =3.20.0, =9.13.1-rc.9, =0.1.0, =3.20.0, =3.21.9 Source cves: CVE-2026-71320 Source advisory: SNYK:JS-NUXTNITROSERVER-18565116...
Linux geode_rng_init Heap Buffer Overflow DoS
The vulnerability of the geodernginit function in the drivers/char/hwrandom/geode-rng.c file of the Linux kernel’s alphabetic devices driver is related to errors during the update of the reference counter. Exploiting this vulnerability could allow an attacker to cause a service failure...
com.lightbend.akka:akka-stream-alpakka-geode_2.11 (0.10), com.lightbend.akka:akka-stream-alpakka-geode_2.12 (0.10) +37 more potentially affected by CVE-2026-49268 via org.apache.shiro:shiro-core (1.3.1)
org.apache.shiro:shiro-core MAVEN version 1.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.shiro:shiro-core and may be impacted: - com.lightbend.akka:akka-stream-alpakka-geode2.11 0.10 - com.lightbend.akka:akka-stream-alpakka-geode2.12...
@cwa/nuxt-edge (>=1.0.0-29304822.f444f03, <=1.0.0-29317775.3ebbdc9), @geode/opengeodeweb-front (>=9.13.1-rc.9, <=10.0.2-rc.4) +1 more potentially affected by CVE-2026-56301 via nuxt (>=3.18.1, <=3.20.1)
nuxt NPM version =3.18.1, =1.0.0-29304822.f444f03, =9.13.1-rc.9, =1.0.1-alpha.0, =1.0.1-alpha.33 Source cves: CVE-2026-56301 Source advisory: GHSA-534H-C3CW-V3H9...
@cwa/nuxt-edge (>=1.0.0-29304822.f444f03, <=1.0.0-29317775.3ebbdc9), @geode/opengeodeweb-front (>=9.13.1-rc.9, <=10.0.2-rc.4) +1 more potentially affected by CVE-2026-56301 via nuxt (>=3.18.1, <=3.20.1)
nuxt NPM version =3.18.1, =1.0.0-29304822.f444f03, =9.13.1-rc.9, =1.0.1-alpha.0, =1.0.1-alpha.33 Source cves: CVE-2026-56301 Source advisory: OSV:GHSA-534H-C3CW-V3H9...
@geode/opengeodeweb-front (>=9.13.1-rc.9, <=10.0.2-rc.4), nuxt (>=3.20.0, <=3.21.5) potentially affected by CVE-2026-47200 via @nuxt/nitro-server (>=3.20.0, <=3.21.5)
@nuxt/nitro-server NPM version =3.20.0, =9.13.1-rc.9, =3.20.0, =3.21.5 Source cves: CVE-2026-47200 Source advisory: MEND:CVE-2026-47200...
@geode/opengeodeweb-front (>=9.13.1-rc.9, <=10.0.2-rc.4), nuxt (>=3.20.0, <=3.21.5) potentially affected by CVE-2026-46342 via @nuxt/nitro-server (>=3.20.0, <=3.21.5)
@nuxt/nitro-server NPM version =3.20.0, =9.13.1-rc.9, =3.20.0, =3.21.5 Source cves: CVE-2026-46342 Source advisory: MEND:CVE-2026-46342...
io.springfox:springfox-data-rest (>=2.6.0, <=2.6.1), org.apache.geode:geode-web-api (>=1.0.0-incubating, <=1.1.1) potentially affected by CVE-2026-41006 via org.springframework.hateoas:spring-hateoas (0.21.0.release)
org.springframework.hateoas:spring-hateoas MAVEN version 0.21.0.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework.hateoas:spring-hateoas and may be impacted: - io.springfox:springfox-data-rest =2.6.0, =1.0.0-incubating, =1.1.1...
io.springfox:springfox-data-rest (>=2.6.0, <=2.6.1), org.apache.geode:geode-web-api (>=1.0.0-incubating, <=1.1.1) potentially affected by CVE-2026-41007 via org.springframework.hateoas:spring-hateoas (0.21.0.release)
org.springframework.hateoas:spring-hateoas MAVEN version 0.21.0.release is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework.hateoas:spring-hateoas and may be impacted: - io.springfox:springfox-data-rest =2.6.0, =1.0.0-incubating, =1.1.1...
@geode/opengeodeweb-front (>=9.13.1-rc.9, <=10.0.2-rc.4), nuxt (>=3.20.0, <=3.21.5) potentially affected by CVE-2026-47200 via @nuxt/nitro-server (>=3.20.0, <=3.21.5)
@nuxt/nitro-server NPM version =3.20.0, =9.13.1-rc.9, =3.20.0, =3.21.5 Source cves: CVE-2026-47200 Source advisory: SNYK:JS-NUXTNITROSERVER-17111073...